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What's New in this Revision? 

Note: Only the latest changes to this documentation are listed here. Changes made to earlier revisions are 
listed in the "Changes to the User Documentation" document which can be downloaded from the Confirmit 
Extranet at https://extranet.confirmit.com. 

The following changes have been made in revision 1 of the Confirmit Horizons 22 Administrator Guide: 

  

• A note is added to the Archiving Task section (go to Archiving Task on page 76 for more information). 

• The Feature Toggling chapter is added (go to Admin > Feature Toggling on page 95 for more information). 

  

Note: The general layout and language in this document is continually being corrected, adjusted and 
improved to ensure the user has the best possible source of information. Only NEW information and details 
of functionality that has changed since the previous issue are listed here - minor corrections to the text and 
document layout are not listed. 

  

Important 
We need your feedback so we can improve this document and provide you with the information you require. If 
you have any comments or constructive criticism concerning the content or layout of this documentation, 
please send an email to documentation@confirmit.com. Please include in your email the section number 
and/or heading text of the section to which your comment applies. 

  

  

https://extranet.confirmit.com/
mailto:documentation@confirmit.com?subject=Feedback%20on%20the%20Admin%20documentation.?subject=Feedback%20on%20the%20Admin%20documentation.
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1.  Definitions 

• System Software Administrator – The person designated to administrate the software-related aspects of 
Confirmit (users, permissions, etc). This is done through the software interface. Technical skills are not 
required for this position. 

• Server Administrator – The person designated to perform installation, maintenance and upgrades on the 
Confirmit servers. Technical skills are required for this position. See the separate documentation: Confirmit 
Server Manual. 

This manual is written for the System Software Administrator. 

  

Types of Users 

The various types of users are defined in Appendix A: User Roles and Permissions (go to APPENDIX A: USER 
ROLES AND PERMISSIONS on page 136 for more information). 

Note: Confirmit is fully cross-browser compliant except that the Survey Comparison tool is currently only 
supported for Internet Explorer. 
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2.  Software Administrator Permissions in Confirmit 

This chapter briefly describes the access the software administrator will normally have in the various areas within 
Confirmit in addition to access to the functionality in the Confirmit Admin menu. 

You also have access to other administrative functionality elsewhere in Confirmit. This functionality is described in 
more detail later in the Other Properties and Functionality chapter. 

Note: A company-wide setting to improve system security can be activated such that system administrators 
are only allowed to log into Confirmit if their computers’ IP address is within a specified range of addresses. 
This is controlled by the ValidIPRangeForSysAdm configuration setting. 

Note: User Access Control (UAC) is enabled for Confirmit. This means that the setup will ask for the required 
Administrator rights during installation and/or configuration of Confirmit. 

2.1.  Permissions in Projects 

As the Software Administrator, you have access to all projects, reports, forms and end-user lists on the server, and 
can give yourself and other users read, write, delete, and administration permissions to these objects. You can also 
give Online Coding Administrator permissions and Open Text Coder permissions on all projects via the Project 
Management > Overview > Permissions tab. 

When you first open a project as Administrator, the project will be Read-only to you. You must then go to the 
Permissions tab and set the required permission. Users with the ProS or system_project_administrate permissions will 
have an additional button, Claim Full Access, in the Permissions tab toolbar. Click this button to give yourself all 
permissions for the selected project. 

2.1.1.  Code Check 

Towards the bottom of the Project Management > Overview > General tab is the Code Check parameter. This 
parameter can be set to Enabled or Disabled. Default is Enabled. 

When Enabled, the Code Check validates all codes in answer lists, predefined lists and loop members in 
questionnaire designer and under database generation, and checks for duplicate codes. 

In cases where it is decided to keep “illegal” codes, for example on projects created and compiled before this check 
was introduced (it was introduced in Confirmit version 8.1), a Software administrator must set the Code Check to 
Disabled. 

2.1.2.  Change the Company 

In the event a project is registered under the wrong company, the Software Administrator who has the 
system_administrate or system_project_administrate permission can change the company so that transactions are 
logged under the correct company. To do this: 

1. Open the appropriate project. 

2. Go to the Project Management > Overview > General tab. 

3. Click the down-arrow beside the Company data field to open a drop-down list of the registered companies, 
then select the required company. 

4. Click Save to save the changes. 

2.2.  Permissions on Tasks 

In the Home > Tasks > Search tab, a search field called User ID is available to the Software Administrator. The 
Software Administrator can search for all tasks initiated by all Confirmit users on the current server. 

2.3.  Permissions in Panel Templates 

The Software Administrator has permission to change the company on a panel template. 
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2.4.  Permissions in Community Portals 

The Software Administrator has access to all Community Portals in Confirmit. 

2.5.  Permissions in Survey Layouts 

The Software Administrator has access to all survey layouts in Confirmit. 

Only the system administrator / global template administrator can set survey layouts to be global. A company 
administrator can set survey layouts to be “public” but only within the company. 

Note: If you are logged on to Confirmit as system / template / global / company administrator, three additional 
columns will be displayed in the Survey layout list. These show the Public, Express and Company Specific 
checkbox settings for the layouts listed. 

2.6.  Permissions in Reportal 

The Software Administrator has permission to administrate all functionality in Reportal. 

The Software Administrator is able to change the company on Reports and Data Sources in Reportal so that the 
transactions are logged under the correct company. This is done in the report or data source properties in the 
Company drop-down. 

2.7.  Permissions in End User Lists 

The Software Administrator has access to all End User Lists on the server. Refer to the Confirmit Authoring User 
Guide for detailed information on administrating end users. 

2.8.  Permissions in Database Designer 

The Software Administrator has access to all forms on the server. 
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3.  The Admin Menu 

The Admin menu provides the company Software Administrator with a set of tools to administrate and monitor server 
activities and Confirmit users. 

The menu includes tools for: 

• Administrating companies and users (go to Admin > Accounts on page  for more information). 

• Publishing news updates (go to Admin > News Update on page  for more information). 

• Updating and translating survey messages and language updates (go to Admin > Languages and Messages 
on page  for more information). 

• Viewing system activities that have been carried out in a certain period of time and/or for predefined projects 
(go to Admin > Activity Logs on page  for more information). 

• Checking CPU usage (go to Admin > Activity Logs on page  for more information). 

These last two allow you to check for transactions, hits and other actions performed on projects, allowing you to 
identify “problem” projects. 

 

Figure 1  The Admin menu 

This manual describes all functionality in the Confirmit Admin menu, in the order it appears in the menu (see above). 
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4.  Admin > Batch 

The following options are available in the Admin > Batch menu: 

• Server Activity - shows the current server activity. 

• Server Config - enables you to configure the servers. 

• Task Type Configuration - enables you to configure the tasks. 

• Tasks - opens the Task management page. 

• Task System Cleanup - removes temporary files. 

4.1.  Admin > Batch > Server Activity 

The Server Activity page shows the current load and the processes running on the Confirmit batch servers. Click the 
Autorefresh on button to make the page refresh automatically every 5 seconds. 

 

Figure 2  The Server Activity page 

4.2.  Admin > Batch > Server Config 

The Batch Server Configuration page displays information relating to the servers that are available for the various 
batch jobs and tasks (see the figure below), and allows you to specify which servers are to be used when running the 
various tasks. It also shows the status of the servers, that is, whether they are running or are stopped. 

The servers are color-coded red or green: 

• Green – means that the server is running. 

• Red – means either that the server is not running, or that the batch executor initiating the batch jobs is not 
running even though the server is running. 

The figure below shows an example of a system with three servers, all of which are currently running. 

To allocate batch jobs to the servers (if you have a multiple server installation), check the boxes corresponding to the 
appropriate jobs and servers. If a task is not specified to run on any of the available servers, the text for that task will 
turn red. For a more detailed explanation of the processes, see the Confirmit Server Manual. 
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Figure 3  The Server Configuration page 

4.3.  Admin > Batch > Task Type Config 

Go to Admin > Batch > Task Type Config to configure the Confirmit batch tasks (see the figure below). To change 
the settings on this page you must have the System_Batch_Administrate permission (go to How to Edit a User’s 
Details on page  for more information). Users without this permission are only able to view these values. The columns 
are: 

• Description - the name of the task. 

• Isolation Level - each task can be configured with an isolation level. The options are: 

o Thread - the lowest isolation level, highest performance. With this level, the task runs in a separate thread in 
the common task system application domain. 

o Process - this is the highest isolation level, and gives the lowest performance. This level runs the task 
instance in a separate process. 

• Max Instances – the maximum number of instances that can run at one time on one batch server. 

• Weight – used to indicate how resource-demanding the task is. For example, a batch server can run five tasks 
with weight 20 but only two tasks with weight 50 simultaneously. Each server may run a number of tasks of 
different types in parallel, and the task system will ensure that the sum of the weights for those tasks are less 
than or equal to 100. 

• ID – the ID number of the task. 
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Figure 4  The top few tasks in the Task Type Configuration page 

4.4.  Admin > Batch > Tasks 

Go to the Admin > Batch > Tasks menu command to open the Task Management page (also available through 
Home > Tasks). Software Administrators have access to all batch tasks on the server. The layout is identical for all 
the tabs. 

 

Figure 5  Example of the Batch > Tasks list 

In the event the list is extensive, you can search using the fields above the list and sort the list by clicking the 
appropriate column header. For statuses Aborted and Completed, only the last week's (7 days) tasks are displayed. 

To view the Rule Executor page for a task, click on the blue Task ID link for that task. The window opens as shown 
below: 
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Figure 6  Example of the Rule Executor window for a task 

4.4.1.  How to Change Task Ownership 

All tasks have a specified “owner”; in most cases the user who originally created the task. However, users can expire 
or be deleted, and if a task previously created by a now-expired/deleted user attempts to run then the task will abort. 
In this case, the administrator has the option of changing the task’s owner. 

Note: To change a task owner, the administrator must have task_admin, system_admin, 
system_project_admin or project_admin permission. Users with other permissions will not see the 
Ownership tab. 

1. Go to the Home > Tasks menu command. 

The Task Management page opens. 

2. Click on the blue Task ID link for the appropriate task to go to the Task Definition page. 

The Task Definition page opens at the Instances tab. 

3. Go to the Definition tab. 

Note that the page header text displays the type of task. 
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Figure 7  The Ownership tab 

4. Type into the Owner field the UserID of the new task owner and click Save to save the changes. 

All future occurrences of the task will be run under the new owner’s credentials. 

4.4.2.  Batch Task List 

Batch tasks are logged. Own tasks are available to project administrators, all tasks are available to Confirmit 
administrators. Tasks may be in the queue, executing, completed, or aborted. The logs available are: 

  

 

Activity Log Export 

Activity Overview Export 

Archiving 

Ascribe Codeframe Import 

Ascribe Export 

Batch Emailing 

Batch Emailing - Dedicated IP address 

Batch Emailing - Fixed Domain 

Bayesian Network Generator 

BitStream Generator 

Calculate Recoded Variables 

CAPI Bulk Assignment Upload 

Configuration Settings Export 

Convert Panelist Credits 

Create report from reportal Wizard 

Instant Analytics Data Export 

Languages And Resources Deployer 

Launch Survey 

Linked Script Library Updating 

Log Reporting 

News Emailing 

NodeStore cleanup task 

Panel Portal Export 

Panel Portal Import 

Panel Portal Publish 

Panelist Credits Export 

Panelist Credits Import 

Panelist permissions upload 

Project Info Collector 

Project Info Exporter 

Sampling - Export Jobs 

Sampling - Export Matrix 

Sampling - Export Sample File 

Sampling - Import Job 

Sampling - Import Matrix 

Sampling - Lightweight Job Import 

Sampling - Refresh Survey History Job 
Information 

Sampling - Remove Sample 

Sampling - Survey Synchronization 

Search index optimization 

Send Push Message 

Single Page Survey Cleanup 

Single Page Survey Generation 

Standard code wrappers deployer 
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CustomerSat Survey Synchronization 

Data Central Rule Executor 

Data Synchronization 

Database Cleanup 

DB Generator 

Debug Survey 

Design log cleanup 

DocumentStore cleanup task 

Email CAPI Console URL 

End user uploading 

Enduser emailing 

Enduser Export 

Export Cati Activity Log 

Express Respondent Upload 

Hierarchy Import 

Hierarchy permissions Import 

Hub AM Program Loader 

Hub Calendar Synchronizer 

Hub Cleanup 

Hub Confirmit Project Loader 

Hub Contact Database Synchronizer 

Hub Db Designer Loader 

Import Triple-S Data 

Indexing history cleanup 

Quota Recalculate All 

Quota Upload 

Random Data Generator 

Recalculate All Quotas in Survey 

Remote Definition Import 

Report Duplicate 

Report Publish 

Report Validate 

Reportal Definition Export 

Reportal Definition Import 

Reportal Excel2007 Export 

Reportal PDF Export 

Reportal PowerPoint2007 Export 

Respondent Bulk Upload 

Respondent Export 

Respondent Report PDF Export 

Restoring Archived Project 

Rule Executor 

Rule Set Executor 

Sample Generator 

Sample Upload 

Sampling - Change Date 

Sampling - Execute Job 

Sampling - Export Job 

Survey Data Template Export 

Survey Data Template Import 

Survey export 

Survey import 

Surveylayout Export 

Surveylayout Import 

Table Content Export 

Table content upload 

Table Synchronization 

Task System Cleanup 

Template Duplicator 

Template Flattener 

Template Generator 

Text Analytics 

Transaction Usage Export 

Translation XML Export 

Translation XML Import 

Update report from reportal Wizard 

Upload Enduser Permissions For 
Report 

User Upload 

Weight Calculation 

WI Generator .NET 

Wizard Content Upload and Sync 

  

Available to project administrators: 

• Creation of objects in survey 

• Property changes of survey nodes 

4.5.  Admin > Batch > Task System Cleanup 

This menu command runs a task that deletes any temporary files that may have been left in the system by other 
tasks. You can set the task to run as soon as possible, or later at a specified date/time. Scheduling the task to run 
later gives you the option of making it a recurring task. 

 

Figure 8  The Task System Cleanup dialog 
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5. Admin > Activity Logs 

The Admin > Activity Logs menu contains the following options: 

• Author Monitor 

• BitStream Monitor 

• Custom Solutions Monitor 

• REST API Monitor 

• Express Monitor 

• Flex Extensions Monitor 

• Panel Portal Monitor 

• Reportal Monitor 

• Survey Dashboard Monitor 

• Survey Monitor 

• Web Service Monitor 

• AD PDF Publishing 

• CATI Interview Activity 

• CATI Management Activity 

• Multimode Log 

• Log Reporting 

• System Activity 

• Transaction Usage Export 

• CAPI/Kiosk Activation 

• Email Activity Log 

• Error Log 

• File Library Report 

• Survey Dashboard Usage 

• Image Upload 

The Activity Logs menu options enable you to overview and control the Confirmit servers’ CPU usage, and allow you 
the possibility to track the activities that have been executed on different projects. The Activity logs also enable you to 
find “problem projects” if the server is slow. 

When using the ...Monitor pages, you must select a certain period of time for the search. Depending on the selected 
activity type, you may then either view each logged representation of the activity, or view the statistics for the activity 
grouped by either project id or user id. Note that all time filtering is based on UTC time. 

If the statistics are of interest, you can also drill down within each represented project id or user id to view the statistics 
at different levels. 

Other logs have different search fields as appropriate. After performing a search, click Reset to clear the search fields. 

The ...Monitor pages also have an Open in New Window button located below the search fields beside the Reset 
button. Click this button to open additional search windows, enabling you to perform comparisons of the data for 
different search criteria. 

Important 
The log data for a project can use considerable storage space. Confirmit therefore reserves the right to delete 
log data that is older than 24 months. 
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5.1.  Admin > Activity Logs > Author Monitor 

Go to Admin > Activity Logs > Author Monitor to search for information about the Authoring server performance. 
The page contains fields for the search criteria that can be used: project ID, Web server, Company, and the time 
periods hourly, daily, weekly, monthly or yearly. Depending on the time period selected, search fields for hour, date, 
week or year are made available. The Group by field offers options depending on the time period selected, and the 
search result is grouped according to the selection made in this field. 

During some operations, some pages could take a considerable time to run and could cause the operation to time-out. 
Pages that have been found to sometimes cause time-outs have therefore been defined as “Async”, meaning that 
those pages support Asynchronous operations. Running those pages as Async allows them to run without timing out, 
but the resulting times may disturb the readings in the operation log. The Async field on the monitor page allows you 
to select whether or not the pages defined as Async are included in the calculations for the operation log. The options 
are: 

• No – Async pages are not included in the log (default). 

• Yes – only Async pages are included in the log. 

• Both – all pages are included in the log. 

 

Figure 9  The Author Monitor page search fields 

Add the appropriate search criteria, then click Search to display the information. The data is arranged according to the 
grouping selected (see the figure below). The information displayed is: number of hits, number of errors, average and 
sum of CPU total, CPU user code and Real total. Time is in milliseconds. 

Grouping by Web Servers, for example, allows you to monitor the authoring server performance (go to Admin > 
Activity Logs > Survey Monitor on page  for more information). 



 
Confirmit Confidential Confirmit Horizons 22  Administrator Guide 

  

- 13 - 

 

Figure 10  Example of an Author Monitor search result 

Click the Open in New Window button (beside the Reset button) to open additional search windows. 

5.2. Admin > Activity Logs > BitStream Monitor 

This monitor logs interactions with BitStream servers, allowing you to monitor the health of the BitStream servers and 
be able to quickly identify the source of any heavy/problematic BitStream queries or file updates. This monitor logs 
much of the same type of information that logged by the other monitors, with the addition of some BitStream-specific 
items (BitStream server, operation type, query type, project, report etc). When a query fails or times out, details about 
the query are also logged. 

 

Figure 11  The BitStream Monitor search fields 

5.3.  Admin > Activity Logs > Custom Solution Monitor 

This monitor displays entries added via the CustomSolutionMonitor web service. 
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Figure 12  The Custom Solution Monitor search fields 

5.4. Admin > Activity Logs > REST API Monitor 

The REST API Monitor function is an internal monitor used to assess performance within the system. On-Premise 
users can use this monitor to see what is going on, who is doing it and how the system is performing. 

The monitor’s functions and interface are very similar to the other system monitors. Click the links below for more 
information. 

5.5.  Admin > Activity Logs > Express Monitor 

Go to Admin > Activity Logs > Express Monitor to search for information about the Express server performance. 
The page contains the same fields and functionality as the Author Monitor described above. 

5.6.  Admin > Activity Logs > Flex Extensions Monitor 

Go to Admin > Activity Logs > Flex Extensions Monitor to search for information about Flex activity. Add the 
appropriate search criteria, then click Search to display the information. 

 

Figure 13  Example of the results of a Flex Extensions search 

Note that you can page through the resulting list by the selected interval, both forwards and backwards, using the << 
and >> buttons at either side of the result list header bar. 

5.7.  Admin > Activity Logs > Panel Portal Monitor 

The Panel Portal Monitor function monitors the traffic on a panel portal. 
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Figure 14  The Panel Portal Monitor 

This monitor’s functions and interface are very similar to those of the Survey monitor. See that section for more 
information. 

5.8.  Admin > Activity Logs > Reportal Monitor 

Go to Admin > Activity Logs > Reportal Monitor to open the Reportal Monitor window. Here you can search for 
information about report usage and performance. The filter fields available in the search window are described below. 

 

Figure 15  Reportal Monitor search fields 

The fields are as follows: 

• Report no – search for a specific report by its number, or search for reports with numbers higher or lower than 
the number entered in the field by using the operators in the drop down list. 

• Web server – if more than one web server is installed, enter one server in the search field. 

• Company – enter the company of the Confirmit user who has created the reports in the search. 

• Cached – this is a drop down list with Yes and No alternatives. This enables the search result to include only 
cached reports or to include only not cached reports. 

• Mode – a drop down list with a number of report modes - select Report Viewer, Report Designer, PDF Export, 
or All. Report Viewer mode counts only the reports accessed by end users with View access. Report Designer 
mode lists the transactions generated by accessing the report. PDF Export mode isolates the report views 
generated by PDF exports. 

• Interval drop-down list – includes hourly, daily, weekly, monthly and yearly. Depending on the selected 
interval, search fields for hour, date, month and year are made available. 

• Grouping drop-down list – includes the options report no, web server, cached, view mode, company and 
different time intervals, that depend on the selected interval for the search. 

Click Search to open the result screen as shown in the figure below. The result columns are the same as those for the 
Survey Monitor, though related to reports (go to Admin > Activity Logs > Survey Monitor on page  for more 
information). After performing a search, click Reset to clear the search fields. 
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Figure 16  Example of the Reportal Monitor search result 

 Click the Open in New Window button (beside the Reset button) to open additional search windows. 

5.9. Admin > Activity Logs > Survey Dashboard Monitor 

This monitor logs interactions with the Survey Dashboard. 

 

Figure 17  The Survey Dashboard Monitor search fields 

This monitor’s functions and interface are very similar to those of the Survey monitor. See that section for more 
information. 

5.10.  Admin > Activity Logs > Survey Monitor 

Go to Admin > Activity Logs > Survey Monitor to open the Survey Monitor window. Here you can search for 
information about survey performance. There are search criteria fields for project ID, DB server and Web Server, and 
Quick Test and Execution Mode selection boxes. Select the time period Hourly, Daily, Weekly, Monthly or Yearly. 
Depending on the time period selected, search fields for entering hour, date, week or year are made available. The 
Group by field offers choices depending on the time period selected, and the search results are grouped according to 
the selection made in this field. 
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Figure 18  The Survey Monitor search fields 

Add the appropriate search criteria, then click Search to display the information arranged by the grouping selected 
(see the figure below for an example). The information displayed is number of hits, number of errors, average and 
sum of CPU total, CPU user code and Real total. Time is in milliseconds. 

If you select Group by - Project, the project ids are displayed. The project ids are links to a new table window with 
information about CPU usage by that specific project. If you click the project ID link on this page, you are sent to the 
Project Management > Overview page for this project. If you select Group by DB Server, then the values are 
displayed per database server. 

 

Figure 19  Survey monitor search result 

Click on the column headers in the table to sort the information by that column. The columns are as follows: 

• Average CPU total – Indicates how much time is spent by the web server(s) processing each questionnaire 
page (page hit). i.e. this is the system-generated load. 

• Average CPU user code – Indicates how much of the CPU total time is spent by the web servers running 
user-made scripts per page hit. i.e. this is the user-generated load. 

• Average Real total – Indicates the time used to complete the request per page hit. i.e. the total time spent 
waiting for disk IO, SQL server, network etc. 

• Sum CPU total – Aggregated CPU time for page hits in the interval or per project. 

• Sum CPU user code – Aggregated CPU time used on user-made scripts in the interval or per project. 
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• Sum Real total – Aggregated time used for completing the request per page hit. i.e. the total time spent 
waiting for disk IO, SQL server, network etc. 

After performing a search, click Reset to clear the search fields. Click the Open in New Window button (beside the 
Reset button) to open additional search windows. 

5.11.  Admin > Activity Logs > Web Service Monitor 

The Web Service Monitor function monitors the traffic on Web Services, for example when applications built on API 
.Net platforms access Confirmit’s web services. 

 

Figure 20  The Web Service Monitor 

The monitor’s functions and interface are very similar to the other system monitors. See those sections for more 
information. 

5.12.  Admin > Activity Logs > AD PDF Publishing Monitor 

Go to Admin > Activity Logs > AD PDF Publishing Monitor to search for information about PDF publishing tasks. 
The page contains fields for the search criteria that can be used: Dashboard name, Hub Id, when cases are 
scheduled from or completed, and statuses. The columns can be sorted. 

 

Figure 21  Example of the AM PDF Publishing Monitor 
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5.13.  Admin > Activity Logs > CATI Interviewer Activity 

Go to Admin > Activity Logs > CATI Interviewer Activity to search for information about CATI interview activity. 
Add the appropriate search criteria, then click Search to display the information. Click Reset to remove all search 
criteria and re-display the full list. 

• Newest on Top - orders the list chronologically. Select Yes to always have the newest event at the top of the 
list; select No to have the oldest event at the top. 

• Set Interval to Partial Hour to open two additional fields; Start Minute and End Minute. These allow you to set 
the search time criteria to the required minute. 

 

Figure 22  Example of the results of a CATI Interviewer Activity search 

Click Export to export the list as an emailed zipped .txt file. 

Note that you can page through the resulting list by the selected interval, both forwards and backwards, using the << 
and >> buttons at either side of the result list header bar. 

5.14.  Admin > Activity Logs > CATI Management Activity 

Go to Admin > Activity Logs > CATI Management Activity to search for information about CATI management 
activity. Add the appropriate search criteria, then click Search to display the information. Click Reset to remove all 
search criteria and re-display the full list. 

• Newest on Top - orders the list chronologically. Select Yes to always have the newest event at the top of the 
list; select No to have the oldest event at the top. 

• Set Interval to Partial Hour to open two additional fields; Start Minute and End Minute. These allow you to set 
the search time criteria to the required minute. 
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Figure 23  Example of the results of a CATI Management Activity search 

Click Export to export the list as an emailed zipped .txt file. 

Note that you can page through the resulting list by the selected interval, both forwards and backwards, using the << 
and >> buttons at either side of the result list header bar. 

5.15.  Admin > Activity Logs > Multimode Log 

Go to Admin > Activity Logs > Multimode Log to search for information about multimode event activity. Add the 
appropriate search criteria, then click Search to display the information. Click Reset to remove all search criteria and 
re-display the full list. 

• Newest on Top - orders the list chronologically. Select Yes to always have the newest event at the top of the 
list; select No to have the oldest event at the top. 

• Set Interval to Partial Hour to open two additional fields; Start Minute and End Minute. These allow you to set 
the search time criteria to the required minute. 

 

Figure 24  Example of the results of a Multimode search 

Note that you can add more than one company ID to the Include and Exclude Company IDs filter fields. Separate the 
IDs with a space. 
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Click Export to export the list as an emailed zipped .txt file. 

Note that you can page through the resulting list by the selected interval, both forwards and backwards, using the << 
and >> buttons at either side of the result list header bar. 

5.16.  Admin > Activity Logs > Log Reporting 

The following sections describe the functionality associated with the Log files.  

5.16.1.  The Purpose of Logs 

Logs give the Software Administrator an overview of usage, and they allow Confirmit to receive transaction data from 
customers according to contractual commitments. Logs are to be sent to Confirmit on a monthly basis, on one of the 
first days of the new month to report for the preceding month. 

5.16.2.  How to Order a Log 

1. Go to the Admin > Activity Logs / Log Reporting menu command. 

The Log Reporting overlay opens as shown in the figure below. 

2. Type the email address to which the log is to be sent. Default is the logged-in user - you. 

3. Choose the Month and Year for the desired log, and set the start time. 

Note that you can set up the transmission as a recurring task by selecting Schedule for later execution then 
setting the parameters (go to How to Set Up a Repeated Task on page 21 for more information). 

4. Click OK. 

An encrypted XML file is sent to the specified email address. 

A log can be ordered to any email address using the same procedure (assuming that e-mail rules in your 
company allow that). If you wish to include a report in clear text (that is readable), check the Include a 
readable report box. 

 

Figure 25  Log reporting 

5.16.3.  How to Set Up a Repeated Task 

To set up a repeated task (for example the monthly Usage report to Confirmit), or schedule the log to be sent at a later 
time, proceed as follows: 

1. Go to the Admin > Activity Logs > Log Reporting menu command. 

The Log Reporting overlay opens as shown in the figure above. 

2. Choose the Month and Year for the log, but for the monthly report leave the Mail to address at the default. 
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3. Click the down-arrow beside the Start time field to open the drop-down list, then select Schedule for later 
execution. 

4. Click OK. 

The Log Reporting overlay changes to display the Recurrence tab. 

 

Figure 26  Setting Log reporting as recurring task 

5. Set Recurring Task to Yes. 

A number of additional options become available. Make the required settings. As an example, the following 
settings will ensure monthly transmission of the required information, starting at 05:00 on 20th April 2010, and 
repeating thereafter at the same time on the 1st day of each month until October. 

o Click the date picker icon beside the date field under New Start Time, and select the date you want to start 
the task (20.04.2010). 

o Set the time (05:00). 

o Set Recurring task to Yes. 

o Click the date picker icon beside the End By field, and select the date you want the task to stop (01.10.2010). 

o Set Recurrence pattern type to Monthly . 

o Set Monthly Schedule to Day 1 of every 1 month(s). 

12. Click Save to save the settings. 

Note: If a user sets up a recurring task and at some point in the future while the task is still running the user’s 
ID expires, the task will be “Aborted by the system”. The following error message will then be written to the 
task log - “Your account has expired. Please contact your system administrator.” For assistance, contact 
Support. The system administrator can also change “ownership” of the task – see the next section. 

5.16.4.  Content of the Log File 

The mail generated by the system on the Software Administrator’s request will include one encrypted XML file and, if 
the "Include a readable report" option is selected, a readable XML file. This allows you to check the transaction 
information before sending it to Confirmit. Once received, the file will be decrypted by Confirmit. 
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The file contains the following information: 

1) addon_<company>_<date> 

List of companies having been granted access to Add-ons 

addon_idaddon_companyidcompany_name 

11Confirmit Company 

etc 

  

2) list_<company>_<date> 

Number of report-accesses granted pr user company list on the server 

  

ListCompanyNumber of users 

Confirmit Company ASPConfirmit Company7 

etc 

  

3) users_<company>_<date> 

List of the User IDs on the server 

  

CompanyUserCreatedExpires 

Confirmit Company ASOveH1998.10.242001.12.31 

etc 

  

4) aggregated_<company>_<date> 

5) activitytype_<company>_<date> 

  

The encrypted files include the number of Transactions / Hits. Given that no attempt has been made to tamper with 
the transaction data, the content of the files will match the numbers displayed in the email On-Screen message. 

5.17.  Admin > Activity Logs > System Activity 

This functionality enables you to track the use of all transaction types in Confirmit. Go to Admin > Activity Logs > 
System Activities to open a search form. In this window you can: 

• Search for activities in a specific time period: yearly, monthly, weekly, daily, hourly. 

• Filter the search on Company, Activity type, Project ID, Project name and/or Project creator. Enduser list, 
Enduser company, and Enduser user fields will appear only when you select “Published report accessed”, 
“Pivot view accessed”, or “Individual report accessed” in Activity type. 

• Sort the result by four different levels (“Group by – then by – then by – then by”). 
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Figure 27  System activity search fields 

You can select a time interval for the search in the Interval search area of the page. 

You can select a specific company and/or a specific project or all companies and all projects. To select an item, click 
on it with the left mouse button to highlight it. If nothing specific is selected when you click Search, all 
companies/clients and all projects are selected. 

The Company and Activity Type fields are multiple-choice fields, that is, you can run a search for several companies 
and activities simultaneously. The Activity types that you can search for are: 

 

Account locked 

Archiving notification sent 

Archiving performed 

Cache settings changed 

Change company setting for data export 
restriction 

Change Password 

Clear responses 

Complete - Registration Survey 

Create project 

Create survey layout 

Data Central Operation 

Data cleaning delete 

Data cleaning delete (panelist) 

Data cleaning delete (respondent) 

Data cleaning update 

Database is prepared/compiled 

Debug information 

Delete Company 

Delete Current Response 

Delete Hub 

Delete project (permanent) 

Delete project (softdelete) 

Edit survey layout 

Email sent 

Error event 

External data uploaded (inserts) 

Failed Login 

Free Reportal Export (e.g. Single-Page 
Excel) 

Generic SSO 

Index created 

Interview complete - CAPI 

Interview complete - CATI 

Interview complete - CAWI 

Interview complete - Sample Only 

Interview generated 

Interview Medium 

Interview Mini 

Interview Poll 

Interview Quota Full - CAPI 

Interview Quota Full - CATI 

Interview Quota Full - CAWI 

Interview Screened - CAPI 

Interview Screened - CATI 

Interview Screened - CAWI 

New user 

Open report generated 

Panel settings changed 

Panelist registered mobile device 

Project accessed 

Push messages sent to panelists 
mobile devices 

Recoding of variables 

Reportal export 

Respondent Report PDF Export 

Restore a soft-deleted project 

Snapshot Rule 

Start Panelist Deletion 

Start Respondent Data Deletion 

Start Survey Data Deletion 

System Admin Login 

Test 

Text Analytics entries processed (all) 

Text Analytics entries processed (new) 

The granted permission set does not 
reflect the users assigend user level. 

The number of events in 
aggregated_activities has been 
changed 

The number of page hits in an interview 
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Delete records (from rule) 

Delete Rule 

Delete RuleSet 

Delete survey layout (permanent) 

Delete survey layout (softdelete) 

Delete Triple-S Template 

Delete User 

Duplicate project 

Duplicate survey layout 

Interview Small 

Interview Unknown - CAPI 

Interview Unknown - CATI 

Interview Unknown - CAWI 

LDAP 

Login event 

Login event - Duplicate 

Logs changes to the addons table 

New Company 

Time elapsed 

Update batch server config 

Update Company 

Update Configuration Setting 

Update User 

User accesses questionnaire designer 

User has started prepare/compile of 
database 

Check the Description box to show Description in the activity results. This presents a detailed description of what was 
performed in the activity (for example, server.setting: old value -> new value). 

Depending on the data that is logged for each activity type, you may have the possibility to group the results. Not all 
group alternatives are allowed for all activities. If an illegal selection is made, a message appears with information 
regarding this. In the list box “Group by” there are five permanent options: None, Project, User, Company, Enduser 
list, Enduser company, and Enduser user. And depending on the search time interval, you will be able to group by 
more detailed intervals. 

Note: Not all searches may be successful. In cases when you receive a Timeout expired message, try to break 
down your search, for example into smaller time intervals. 

5.17.1.  Result Window - System Activities 

Set the appropriate period, filter and group settings and click Search to open a page with the results. The results page 
will display various different kinds of data depending on the search settings used. The example in the figure below 
shows the results for all activity types , grouped by Company for the interval 14:00 to 15:00 on 22 March 2010. The 
search was defined for a specific hour, but you can view the previous and next hours by clicking the << and >> 
buttons. 

 

Figure 28  Example of a system activity search result 

In this example, the result page shows that there were 115 complete responses for this project in December 2002 and 
that two Publisher Report Nodes had been generated. 

If you check the Partial sums checkbox in the Search window, the result shown in the figure above will be displayed 
with Totals for each activity and a Grand total, as shown in the figure below. 
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Figure 29  The same system activity search result but with Partial Sums checked 

To export the search result, click the Export button in the search window and follow the instructions. The results are 
exported to tab-delimited ASCII files. 

5.17.2.  Granularity Window - System Activities 

To open the Granularity window, click the hyperlink of either a project id or user id. The default granularity is “Pr. 
hour”, meaning that the number of occurrences per hour within the actual time period is displayed. The picture below 
shows the details of the user “User”. 

 

Figure 30  The System activities Granularity window 

To change the granularity: 

1. Select the required granularity from the list box “Granularity”. 

2. Click Show. 

The “Granularity” list box has the following options: 

o Pr. hour 

o Pr. day 
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o Pr. week 

o Pr. month 

3. Click Back to return to the result window from which you first followed the hyperlink. 

5.17.3.  Step-by-Step Instructions 

To summarize the stages in a report: 

1. Go to the Admin > System activities menu command. 

2. Select the time period. 

3. Select the activity type. 

4. Select the grouping. 

5. View the results of the search. 

6. Export the results. 

7. Follow the hyperlink for project, user, month or company. 

8. Change granularity. 

9. Click the Back button. 

5.18. Admin > Activity Logs > Transaction Usage Export 

This report allows users with the SYSTEM_ADMINISTRATE or SYSTEM_COMPANY_ADMINISTRATE permissions 
to export transaction usage data. A tab-delimited text file is created and zipped, then attached to an email. 

• With SYSTEM_ADMINISTRATE permission, you have access to Transaction Usage Export and you can 
select any company. 

• With SYSTEM_COMPANY_ADMINISTRATE permission, you have access to Transaction Usage Export but 
you cannot select the company. Your company is specified automatically; it is not visible for you. 

• If you have SYSTEM_COMPANY_ADMINISTRATE and SYSTEM_ACCOUNT_READ permissions, you have 
access to Transaction Usage Export and you can also select any company. 
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Figure 31  The Transaction Usage Export overlay 

1. Set the Start and End dates to restrict the export to the required time interval. The maximum date range is 90 
days. 

2. Select whether you want to export usage data for surveys or reports. If the selected transaction type is Survey 
the activities are grouped by ProjectID. If the transaction type is Report the activities are grouped by 
Description. 

3. If you have access to more than one company, select the company for which the data is to be exported. 

4. A particular project id and/or project creator can be specified if required. 

5. Check that the email address to which the export is to be sent is correct (default is your address). 

6. Click Export. 

An email with the export file attached is sent to the specified address. 

The following transaction activities are exported: 

• For surveys: 

o Complete - Registration Survey 

o Interview complete - CAPI 

o Interview complete - CATI 

o Interview complete - CAWI 

o Interview complete - Sample Only 

o Interview Medium 

o Interview Mini 

o Interview Poll 

o Interview Small 
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• For reports: 

o Open report generated 

o Reportal export 

o Respondent Report PDF Export 

5.19.  Admin > Activity Logs > CAPI/Kiosk Activation 

The CAPI/Kiosk Activation screen shows CAPI consoles that have been activated on the server. There are two modes 
to this screen, "Summary" and "Details". The Summary mode shows one line per physical machine. 

 

Figure 32  Example of the CAPI/Kiosk Activation page 

The columns are as follows: 

• Machine key – A physical machine is identified by its machine key (which is based on the hard-disk id on the 
particular machine). For machines running Windows, the value presented will be the hard drive serial number 
converted to HEX. Click the link to get further details on the machine. For Android machines, the machine key 
is the IMEI number of the device. 

• Company – The company that has activated the machine. 

• Times activated – The number of times this machine has been activated. 

• Times deactivated – The number of times this machine has been deactivated. 

• Status – Activated or Deactivated (it is deactivated if the number of "times activated" - "times deactivated" = 
0). 

• Mode – CAPI activation or Kiosk activation. 

Note: The “Times Activated” for a machine can be greater than one, but one machine cannot support multiple 
consoles. If the user has not deactivated the inactive consoles, they will count as active licenses. 

Click on a machine key to open the "Details" mode for that machine. Here you can see which consoles have been 
activated for this physical machine. You can also go directly to the Details mode by choosing Details in the drop-down. 
In the Details mode the information is presented one line per console (and each console does not have to be on a 
physical machine). The details are as follows: 

• Machine key – A physical machine is identified by its machine key (which is based on the hard-disk id on the 
particular machine). 

• Company – The company that has activated the machine. 

• Console Name – The name of the console. The console is automatically named as Company name + a 
number. 

• Activated – The time and date when the console was activated. 

• Deactivated – The time and date when the console was deactivated. This field is blank for active consoles. 

• Mode – CAPI activation or Kiosk activation. 
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5.20.  Admin > Activity Logs > Email Activity Log 

Company Administrators and System Administrators have access to the Email Activity Log. This report shows the 
number of emails sent for the current company per month. The report can be grouped by date, weekday, week, 
quarter or all. 

 

Figure 33  Example of the Email Activity Log for February 

5.21.  Admin > Activity Logs > Error Log 

This menu command takes you to the Home > Tasks page Aborted tab, and displays the last 30 day's entries on the 
error log for batch jobs. The Task ID is a link to the properties and log of a specific task that enables you to investigate 
the error further. 

 

Figure 34  Example of the Error log 
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5.22.  Admin > Activity Logs > File Library Report 

Go to Admin > Activity Logs > File Library Report to view a list of all companies that have the File Library add-on. 

 

Figure 35  Example of the File Library Report list 

The list shows the Account Type a company has (Standard, Enhanced, Multimedia), the space limit granted to this 
company in MB, and how much of this space has been used, also in MB. (go to Admin > Accounts on page  for more 
information). 

5.23. Admin > Activity Logs > Survey Dashboard Usage 

This log report provides an overview of Survey Dashboard Usage. It displays a list of the allocated licenses per 
survey/end user list, filterable by company, survey and count of allocated licenses. 

 

Figure 36  The Survey Dashboard Usage filter 

5.24.  Image Upload Usage 

This log lists the images that have been uploaded by respondents using the Image Upload object. The Image Upload 
object allows respondents to upload an image as the answer to a question (refer to the Authoring User Guide for 
further details). If you have access to more than one company then you can select which company log you view. 

Note that when uploaded, the images will automatically be rescaled to 640 x 480 pixels, maintaining the aspect ratio. 
Images over 200kb in size cannot be uploaded. 
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6.  Admin > Accounts 

Note: To be able to add new, and edit or delete existing users, groups and companies, the Confirmit 
administrator needs the permission “system_account_administrate”. The Confirmit administrator called 
“administrator” (username “administrator”) is the only administrator by default, who can give other Confirmit 
administrators this permission. It is recommended that the system_account_administrate or 
system_adminstrate permission is granted to another user, and that the password for the administrator 
account is changed as soon as possible after an installation, to avoid unwanted entry by unauthorized users. 
Once a replacement administrator has been set up, the original administrator can be set with an expiry date in 
the past to prevent logons for the account. The administrator account cannot be deleted. 

The Admin > Accounts menu command contains the following options: 

• Users. 

• Roles. 

• Groups. 

• Companies. 

• Overview. 

6.1.  Admin > Accounts > Users 

Go to the Admin > Accounts > Users menu command to display an overview of all registered users. By default, 
users are listed alphabetically by the user ID. 

 

Figure 37  Example of the list of registered users 

In this list you can search for and sort users by User ID, the user's first and last name, Company, license expiry date, 
and the date of Last Modification. In addition you can search for users by User Level type, Expiry Status, and the date 
the license was created. 

For Created, Expires and Last Modified dates you can select the operators: Less than, less than or equal to, equal to, 
greater than, and greater than or equal to. 

If your search returns more items than can fit on one page, use the Page arrows in the lower right corner to switch 
between pages and browse through the list. The default number of items displayed on one page is 50. 

To sort the list by one of the columns, click on the column header. An arrow indicates in which direction the list is 
sorted; ascending or descending. 

Click on the alphabet buttons across the bottom of the window to return users whose User ID starts with the letter that 
you clicked. 

Use the User Level drop-down to select the user level by which you want to search. The default value is All users, 
meaning that all users are displayed. The other options are: Professional, Standard, Translator, and No Access. 

Use the Expire Status drop-down to search for Active and Expired licenses. 
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To view a user's details, click on the User ID link. A new frame opens with the information towards the right side of the 
browser. To view the company's details, click on the Company link. Again a new frame opens towards the right side of 
the browser. 

Click Reset to remove all search criteria and display the full list of users. 

6.1.1.  How to Create a New User 

To add a new user to the system: 

1. Go to the Admin > Accounts > Users menu command. 

The registered users list opens. 

2. Click New Users in the upper right corner of the user overview window. 

Note: If the new user is to be connected to a new company in Confirmit, this new company must be created 
BEFORE the new user is added (go to Admin > Accounts > Companies on page  for more information). 

 

Figure 38  The New Users button 

A new frame opens towards the right side of the browser. This frame contains fields for registering user 
details. 

 

Figure 39  User details 

Note: One User ID entitles only one named person to use Confirmit. User ID details must refer to a named 
person, and the e-mail address must belong to that person. Anonymous / shared names (for example "user1") 
or addresses (for example "dataprocessing@client.com) are not permitted. 

3. Enter the appropriate information in all fields in the user registration window. 

Note: The Expiry date field will contain the date set by the Default user expiry date field on the company's 
General tab (go to Company Details Page General Tab on page 53 for more information). You can change this 
date here, but the field cannot be empty. 

4. Click Save. 
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All user settings are explained in the following sections. 

To allow users to transfer PGP-encrypted files and data from Confirmit, their public PGP key must be set. 

Note: PGP encryption is a payable add-on. 

6.1.2.  How to Add Several Users Simultaneously 

In cases where several users with similar settings are to be created, you can create them in one operation. 

1. Go to the Admin > Accounts > Users menu command. 

The Registered Users list opens. 

2. Click New Users in the upper right corner of the window. 

3. Enter the appropriate information in the fields. 

4. In the Add field, specify the number of new users that are to be created. 

5. Click Add users. 

A number of rows equal to the number of users specified in the Add field are added to the list (see the figure 
below). 

6. Edit the data fields for the new users. 

Note: One User ID entitles only one named person to use Confirmit. User ID details must refer to a named 
person, and the e-mail address must belong to that person. Anonymous / shared names (for example "user1") 
or addresses (for example "dataprocessing@client.com) are not permitted. 

 

Figure 40  Example of the User Details for several users 

7. When you have specified the details for all new users, click Save to save the settings. 

The page changes to show the list of users that were created in this operation (see the figure below). 
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Figure 41  Example of the Created Users list 

6.1.3.  How to Add a User to the Permissions List 

The users in this list are those who are registered to your company and those who it is intended should have access 
to administrate End User lists. This can for example include system administrators of client companies who will need 
administrative rights to the lists you are creating. 

To add a user to the list: 

1. Go to the Admin > Accounts > Users menu command. 

The User List opens. 

2. In the User List, find the user you wish to add to the Permissions list and click on the blue User ID link for that 
user. 

The Details page for that user opens. 

3. Towards the upper-right corner of the Details page is the User Key property. Copy this key to your clipboard 
by clicking the link. 

 

Figure 42  The Key property in the user’s Details page 
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4. Go to the End Users > Current List menu command, then go to the Permissions tab. 

5. Scroll to the bottom of the page and click the Add other users link. 

The Enter Keys of New Users dialog opens. 

6. Paste the key you copied in step 3, into the data field, then click Add. 

The window closes and the new user is added to the Permissions list in the Other Users section at the bottom 
of the page. You can now give the user the appropriate permissions. 

7. Save the changes. 

6.1.4.  How to Edit a User’s Details 

If you need to edit a user’s details or permissions: 

1. Go to the Admin > Accounts > Users menu command to open the list of registered users. 

2. Find and click the User ID link for the required user. 

The Details page opens for the user as shown in the figure below. 

3. Make the necessary changes (go to User Details on page 36 for more information). 

4. Click Save. 

 

Figure 43  Example of the User Details page 

6.1.4.1.  User Details 

The properties and settings on the User Details page are as follows: 

• Username - the username of the user. 

• Lastname - the user's last name. 

• Firstname - the user's first name. 

• Email - the user's email address. This is the address to which any error or system emails will be sent. 
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Note: User ID details must refer to a named person, and the e-mail address must belong to that person. 
Anonymous or shared names (for example "user1") or e-mail addresses (for example 
"dataprocessing@client.com) are not permitted. 

• Language - the default language for this user. All surveys created by the user will have this language as the 
default. Select from the drop-down list. 

• User level - the level of access this user is to have. 

o No access - the user is registered but is not allowed to access Confirmit. This setting could be used to 
"switch off" users temporarily. 

o Translator - the user is to work as a translator. The set of permissions is predefined and hard-coded in 
Confirmit so it is not possible to add or remove permissions for these users. These users will only have 
access to the Confirmit Translator Module. Refer to the Authoring User Guide for more information about 
the Translator module. The Translator user has the following permissions: system_translator_user_access. 

o Professional - the "normal" level given to a Confirmit Professional user. Any permissions can be given (or 
not given) to a Professional user as required. See Groups, Roles and Permissions for a more detailed 
description of all permissions. 

o Standard - the level given to a Standard user. This limits the functionality available to the user, simplifying 
operations. Refer to the Authoring User Guide for further details. 

o Express - the user only has access to the Confirmit Express functionality. Refer to the Confirmit Express 
User Guide for further details. 

• User type - specifies the type of user. 

o Normal - indicates that the user account is a normal licensed Confirmit user. This is for information only, for 
use by the administrator; roles and permissions come in addition, and these will define the level of access 
the user has. 

o Test - indicates that the user account is set up for testing purposes. This is for information only, for use by 
the administrator. 

o Training - indicates that the user account is set up for training purposes. This is for information only, for use 
by the administrator. 

o Solo - applies only to Express users. A solo user does not require approval, and is limited to maximum 25 
questions. 

• Company - the company to which the user is registered. 

• Created - the date and time when this user account was created. 

• Created by - the username of the administrator who created this user account. 

• Modified - if any changes have been made to the user's details after they were first registered, the date and 
time of the most recent changes is displayed here. 

• Modified by - if any changes have been made to the user's details after they were first registered, the user 
name of the administrator who made the most recent changes is displayed here. 

• Converted - if the user account type is changed, the date and time of the change is displayed here. 

• Key - the User Key, unique to each user and generated automatically when the user account is first created. 
This key is required when adding users to your company's Permissions tab. Refer also to the Authoring User 
Guide for further details. 

• Password - in the event the user's password must be changed, click the Reset Password link. (go to How to 
Reset a User’s Password on page 47 for more information). 

• Expires - the date on which this user’s access to Confirmit is to expire. The default setting for this field is set in 
the Company Details page (go to Company Details Page General Tab on page 53 for more information). This 
date will usually be related to the contract your company has with Confirmit; when the contract expires, access 
will be revoked. To change the date, click the calendar button and select the desired expiry date. This field is 
mandatory and you cannot save changes to the page if an expiry date is not selected. Note that this is not 
related to the user’s password expiry date. 
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• External username - used for the Single Sign-on (SSO) system (go to The Single Sign-on Functionality on 
page 128 for more information). This field should contain a combination of <company>_<username>, where 
company is a constant configured in SSO and username is the username the user has in the company server 
system and which is also provided through SSO. When a user logs on to his/her company's server using their 
username and password, as long as both the company and the username match the data in this field then the 
user will be able to access Confirmit without further login. 

• Public encryption key - when the user's company has the PGP Encryption (encrypted data delivery) add-on 
functionality, this field becomes available (go to Public Encryption Key on page 48 for more information). 

• Skip news on login - check this box if the user does not need (or wish) to have news items displayed when 
they log in to Confirmit. 

• Subscribe to emailed news items - [default checked] uncheck this box if the user does not wish to receive 
news items via email. 

• Permissions - some additional functionality may be available to be given to individual users who have 
particular roles. For example, the Multilingual permission can be given to a Standard user in the event that 
user needs to create multi-lingual surveys. 

Note: To prevent accidents, when assigning privileged rights (Administrator rights) to professional users, 
groups or roles, you must have secondary approval by a privileged user. This approval is applied via 2-factor 
authentication. Refer to the Authoring User Guide for further details. 

6.1.4.2.  Groups, Roles and Permissions 

To allow particular users access to specific parts of the functionality (and to block users from parts of the functionality 
that they should not have access to), the majority of the functionality within Confirmit is controlled by permissions. This 
allows for example, a particular user to be allocated a specific set of permissions to enable him or her to perform their 
job whilst preventing them from accessing other areas where a mistake could delete respondent data. 

To simplify the allocation of permissions to large numbers of users, individual users who have similar jobs and 
therefore require similar permissions can be collected into logically-named Groups. One Group could for example be 
Administrators. 

In addition, separate permissions that would be needed by all users with similar responsibilities can be gathered into 
Roles (go to Admin > Accounts > Roles on page 50 for more information). For example, all the permissions required 
to perform the Administrator's job could be gathered into a Role called 'Administrator'. Once the Groups and Roles 
have been defined and created, it is then a relatively simple job to allocate Roles to Groups. 

Note: To prevent accidents, when assigning privileged rights (Administrator rights) to professional users, 
groups or roles, you must have secondary approval by a privileged user. This approval is applied via 2-factor 
authentication. Refer to the Authoring User Guide for further details. 

Once the Groups of users have been allocated Roles, you can then fine-tune the system by adding additional 
permissions as required to specific users. 

In the Group Management and Role Management pages, there is one Available column and one Selected column. To 
add a Group, a Role, a Permission or a Member to a Group or to add a permission to a Role, in the appropriate 
Available field, highlight the items that you wish to allocate to the group and click the >> button. The selected items 
are moved across to the Selected fields and are allocated to the Group/Role. 

To de-select items, highlight them in the Selected field and click the << button. The selected items are moved across 
to the Available field. 

Most of the permissions also determine which Confirmit menus the user will see and have access to. The menus and 
areas to which the user does not have access, will in most cases not be visible to the user. In a few cases the user will 
have read-only access to functionality. 

Note: With the introduction of the Standard user (which required considerable simplification of the 
functionality and user interface), a large number of additional permissions became necessary to close off 
areas of the functionality that are not needed by Standard users. These permissions, mainly denoted 
FEATURE_, will normally be required for users other than Standard users. 
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6.1.4.2.1.  System Administration Permissions 

The permissions listed here are those that could be allocated to system administrators. 

• SYSTEM_ACCOUNT_ADMINISTRATE – allows access to create, change and delete new companies, 
groups, roles and users. 

• SYSTEM_ACCOUNT_READ – allows read access to account details. 

• SYSTEM_ACTIVITY_LOGS_READ – allows access to activity logs. 

• SYSTEM_ADMINISTRATE – is the main administrator permission in Confirmit. This gives access permission 
to all users and administrative functionality, and is the permission required when setting up Confirmit. 

• SYSTEM_BATCH_ADMINISTRATE – administrate batch server configuration and task type configuration. 

• SYSTEM_CAPI_ADMINISTRATE – allows access to generate the CAPI Activation files (see CAPI user guide 
for more information). 

• SYSTEM_CATI_ADMINISTRATE – allows access to view all surveys for the user's company in the CATI 
supervisor, independent of the presence/absence of the 'Supervise CATI project' survey level setting (see the 
CATI Supervisor guide for more information). It also gives administration access to all privileged areas for 
company configuration in CATI and call objects.  

• SYSTEM_CLEAR_PRODUCTION_DATA - allows users to use the "Clear Data" functionality to delete 
responses from the production database. 

Note: Users without this permission will get a "Permission denied" message if they attempt to use the 
functionality. Users with the SYSTEM_DATA_DELETE permission (go to Advanced User Access to 
Functionality on page 40 for more information) can use the Clear Data functionality except on the production 
database. System Administrators automatically have access to clear production data so do not need this 
permission, and access to clear the test database also does not need this permission. 

• SYSTEM_DB_ADMINISTRATE – allows access to database administration, i.e. controlling which db server a 
project database should be stored in. 

• SYSTEM_DB_DESIGNER_ADMINISTRATE – allows access to all forms and Database Designer. 

• SYSTEM_DEVELOPMENT_ADMINISTRATE – allows access to a Development menu item that contains 
settings for debugging old .asp pages. This is typically used by Confirmit developers or Confirmit On-Premise 
administrators, for example to extract more detailed feedback on any errors that might arise. This permission 
can only be set by the System Administrator. 

• SYSTEM_ENDUSER_ADMINISTRATE – allows access to all end user lists. 

• SYSTEM_FLEX_EXTENSIONS_ADMIN - grants access to the Admin - Flex Extensions pages. 

• SYSTEM_GLOBAL_TEMPLATE_ADMINISTRATE – read/write/delete access to Global templates. Can set 
templates to be Global. 

• SYSTEM_LANGUAGES_ADMINISTRATE – allows access to system Languages and Messages (default 
error messages). 

• SYSTEM_NEWS_ADMINISTRATE - grants access to add, edit and delete news articles that will appear to 
users when they first log on. 

• SYSTEM_PANEL_SECURITY_ADMINISTRATE - gives access to the Panel Settings page, including the 
Features tab and the Security tab. 

• SYSTEM_PROJECT_ADMINISTRATE – read/write access to all projects/panels/Reportal data 
sources/reports/templates. 

• SYSTEM_PROJECT_DATA_EXPORT_ADMIN - allows a user in the Confirmit company (company id 1) who 
already has the system_project_administrate permission, to export data from a project owned by another 
company. 
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• SYSTEM_QUOTATARGET_EDITOR_ACCESS - can be given to users who do not have full professional 
access to Authoring. This permission allows for example a supervisor to view and modify quota targets and 
achieved figures, but not create new quotas for the survey. The Project Management > Quota Targets menu 
item becomes active. 

• SYSTEM_RESTORE_PROJECT_ACCESS - allows access to restore projects. Included in the Normal role. 

• SYSTEM_SECURITY_ADMINISTRATE – allows access to grant permissions to the following administrative 
levels: 

o SYSTEM_ACCOUNT_ADMINISTRATE 

o SYSTEM_ACTIVITY_LOGS_READ 

o SYSTEM_BATCH_ADMINISTRATE 

o SYSTEM_DB_ADMINISTRATE 

o SYSTEM_DB_DESIGNER_ADMINISTRATE 

o SYSTEM_ENDUSER_ADMINISTRATE 

o SYSTEM_GLOBAL_TEMPLATE_ADMINISTRATE 

o SYSTEM_LANGUAGES_ADMINISTRATE 

o SYSTEM_PROJECT_ADMINISTRATE 

o SYSTEM_SECURITY_ADMINISTRATE 

o SYSTEM_TASK_ADMINISTRATE 

o SYSTEM_TEMPLATE_ADMINISTRATE 

• SYSTEM_TASK_ADMINISTRATE – allows access to all tasks. 

• SYSTEM_TEMPLATE_ADMINISTRATE – Read access to all templates with company = 'all'. 
Read/Write/Delete access to all templates with company != 'all'. It is not possible to change company. 

6.1.4.2.2.  Advanced User Access to Functionality 

The permissions listed here are those available to be allocated to Advanced users. Note that additional Feature 
permissions are required to allow access to functionality that is hidden from Standard users (go to Feature 
Permissions on page 43 for more information). 

• SYSTEM_ANALYSIS_SERVICES_ACCESS - grants the user access to Analysis Services functionality; 
Community Panel - Cube Management (available once the Community Panel and Community Snapshot Panel 
add-ons have been granted to a company). 

• SYSTEM_API_ACCESS – if you are programming towards the Confirmit APIs with XML Web Services, 
authentication is conducted through the userid and password of a Confirmit authoring account. You will only 
have access to that user's projects. Only userids with the API_ACCESS permission enabled can be used for 
this. When this access is enabled, a check box appears on the properties page for the Email object. Check this 
box to log in a table information on each email sent in batch emailing. That table has no visible user interface, 
but can be accessed through the use of API. 

• SYSTEM_ARCHIVING_ACCESS - controls access to the Home > Archiving menu item if Archiving has been 
enabled. 

• SYSTEM_BASIC_PANEL_ACCESS – allows access to the Basic Panel functionality (when the Basic Panel 
add-on has been granted to a company). 

• SYSTEM_CAPI_SUPERVISOR – gives access to the CAPI Supervisor functionality in Confirmit (when a 
company has the CATI add-on). 

• SYSTEM_CATI_SUPERVISE_ACTIVITY – gives access to the CATI Activity functionality (when a company 
has the CATI add-on). 

• SYSTEM_CATI_SUPERVISE_INTERVIEWERS – gives access to the CATI Interviewers functionality (when a 
company has the CATI add-on). 
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• SYSTEM_CATI_SUPERVISE_RECORDED – gives access to the CATI Recorded functionality (when a 
company has the CATI add-on). 

• SYSTEM_CATI_SUPERVISE_REPORTS – gives access to the CATI Reports functionality (when a company 
has the CATI add-on). 

• SYSTEM_CATI_SUPERVISE_RESOURCES – gives access to the CATI Resources functionality (when a 
company has the CATI add-on). 

• SYSTEM_CATI_SUPERVISE_SCHEDULING – gives access to the CATI Scheduling functionality (when a 
company has the CATI add-on). 

• SYSTEM_CATI_SUPERVISE_SURVEYS – gives access to the CATI Surveys functionality (when a company 
has the CATI add-on). 

• SYSTEM_COMMUNITYPANEL_ACCESS – allows access to the Community Panel functionality (when the 
Community Panel add-on has been granted to a company). 

• SYSTEM_COMPANY_ADMINISTRATE – allows access to all tasks, projects and reports within a company, 
and the Home > Company menu items. 

• SYSTEM_COMPANY_EXPRESS_ACCOUNT_ADMINISTRATE - allows access to manage Express users 
within own company (go to System_Company_Express_Account_Administrate Permission on page 122 for 
more information). 

• SYSTEM_COMPANY_PROJECT_ADMINISTRATE – allows access to all tasks, projects and reports within a 
company, but does not allow access to the Home > Company menu items. 

• SYSTEM_CONFIRMIT_ACCESS – allows access to Confirmit. 

• SYSTEM_DATA_CLEANING_ACCESS – allows access to Survey Data Editor. 

• SYSTEM_DATA_DELETE – allows access to Clear Data functionality. 

Note: If you wish to clear data from a production database then you must have the 
SYSTEM_CLEAR_PRODUCTION_DATA permission (go to System Administration Permissions on page 39 for 
more information). 

• SYSTEM_DATA_EXPORT – allows access to Data exports. 

• SYSTEM_DATA_IMPORT – allows access to Data imports. 

• SYSTEM_DATA_PROCESSING_ACCESS - allows access to the Data Processing functionality (when the 
Data Processing add-on has been granted to a company). 

• SYSTEM_DB_DESIGNER_ACCESS – allows to create/edit/delete schemas in database designer (when the 
Database Design add-on has been granted to a company). 

• SYSTEM_DEBUG_STATION_ACCESS – allows access to the Debug Station functionality. 

• SYSTEM_DESIGNER_PROFESSIONAL_ACCESS – allows access to Professional designer. 

• SYSTEM_EMAILING_PROFESSIONAL_ACCESS – allows access to email transmission from Respondents 
> Emailing. 

• SYSTEM_ENDUSER_ACCESS – allows access to create/edit/delete end users lists. 

• SYSTEM_EXPRESS_ACCESS – allows access to the Confirmit Express functionality. 

• SYSTEM_EXPRESS_APPROVER – defines the user as a Confirmit Express Approver. 

• SYSTEM_FEATURE_TOGGLE_ADMINISTRATE - gives administrative access to the Feature Toggle 
functionality, allowing the user to set and change feature toggles. 

• SYSTEM_FEATURE_TOGGLE_READONLY - allows the user to view the Feature Toggle settings but not to 
change them. 

• SYSTEM_FILE_LIBRARY_ACCESS – gives access to the File Library functionality (when the File Library 
add-on has been granted to a company). 
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• SYSTEM_HIERARCHY_MANAGEMENT_ACCESS - gives access to the Hierarchy Management 
functionality. Without this, users will not see hierarchy management in the menus. 

• SYSTEM_ONLINE_CODING_ACCESS – allows access to Online Coding (when the Online Coding add-on 
has been granted to a company). 

• SYSTEM_PROJECT_CREATE – allows the user to create new project. 

• SYSTEM_PROJECT_IMPORT_EXPORT – allows the user to import and export project definitions. 

• SYSTEM_PROJECT_PRODUCTION_LAUNCH – allows access to Production mode and launch survey. 

• SYSTEM_PROJECT_TEST_LAUNCH – allows access to Test mode. 

• SYSTEM_QUALITY_CONTROL_ACCESS – allows access to Quality control functionality. 

• SYSTEM_RAPID_RESULTS_ACCESS – allows access to Rapid Results. 

• SYSTEM_REPORTAL_ACCESS – allows access to Reportal (when the Reportal add-on has been granted to 
a company). 

• SYSTEM_REPORTING_SERVICES_ACCESS - grants the user access to Reporting Services functionality; 
Professional Panel - Reporting (available once the Professional Panel and Panel Snapshot add-ons have 
been granted to a company). 

• SYSTEM_RESPONDENT_ACCESS – allows access to respondent uploading and editing. 

• SYSTEM_SAMPLE_ACCESS – limits access to start sampling on a panel. The user can enter jobs, but the 
available options are significantly reduced (available once the Community Panel add-on has been granted to a 
company). 

• SYSTEM_SAMPLE_APPROVE – gives access to approve samples if you have an arrangement whereby jobs 
created by employees must be approved by a manager or colleague before execution (available once the 
Community Panel add-on has been granted to a company). 

• SYSTEM_SMARTHUB_ACCESS - allows access to the SmartHubs functionality. 

• SYSTEM_TASK_ACCESS – allows access to the Task system. 

• SYSTEM_TEMPLATE_ACCESS – allows access to create/edit/delete WI templates. Note that Standard users 
have the FEATURE_EASY_LAYOUT_DESIGNER_BASIC permission, which gives access to the same 
designers as used in Express. 

• SYSTEM_TEXT_ANALYTICS_ACCESS - allows access to the Text Analytics functionality. 

• SYSTEM_TRANSLATION_XML_ACCESS – allows access to the Translation XML Import and Export 
functions (available once the Translator add-on has been granted to a company). 

• SYSTEM_TRANSLATOR_ACCESS – allows access to translator administrate part in projects (available once 
the Translator add-on has been granted to a company). 

• SYSTEM_TRANSLATOR_USER_ACCESS – allows translator-users access to Translator (available once the 
Translator add-on has been granted to a company). 

• SYSTEM_TRIPLE_S_EDITOR_ACCESS - allows the user access to the Triple-S Template editor (available 
when the Data Processing add-on has been granted to a company). 

• SYSTEM_VARIABLE_RECODING_ACCESS – allows access to create and calculate recoded variables. 

6.1.4.2.3.  Standard User Access to Functionality 

A series of permissions have been added to the Normal role to hide "advanced" functionality from Standard users 
(when the User Level is set to Standard. Normal users have User Level set to Professional). 

Standard users have the following functionality as default: 

• FEATURE_DATA_EXPORT_BASIC - hides advanced export options (the second step in the wizard on the 
Survey Data > Exports page). 

• FEATURE_DEPLOY_SURVEY_BASIC - gives access to "express" deployment; Designer > Deploy Survey. 
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• FEATURE_EASY_LAYOUT_DESIGNER_BASIC - enables the Designer > Edit Layout menu which points to 
the same designer as in Express. It is possible to choose different layouts on the page. All layout changes are 
saved to the layout / template itself (not to the project). Note; Normal users have the 
SYSTEM_TEMPLATE_ACCESS permission which enables Designer > Edit Survey Layout. 

• FEATURE_EMAILING_BASIC - gives access to "express" emailing; Respondents > invite Respondents / 
Send Reminders. 

• FEATURE_NODE_PAGEBREAK - provides the Standard user with a Page-Break object instead of a 
Directive. 

• FEATURE_SURVEY_DETAILS_BASIC - gives access to the simplified Survey Details page. 

• FEATURE_SURVEY_SINGLE_PAGE_EXPORT - allows the user to export surveys in single page format. 

• FEATURE_SURVEY_WORD_EXPORT - allows the user to export as Word files. 

The following permissions are given to all users to allow general access, however much of the functionality within the 
permissions is now restricted by the requirement for the new FEATURE permissions (go to Feature Permissions on 
page 43 for more information). Therefore for Normal users, the appropriate FEATURE permissions must be given in 
addition to open the required functionality. 

• SYSTEM_CONFIRMIT_ACCESS - gives basic access to Confirmit. 

• SYSTEM_DESIGNER_PROFESSIONAL_ACCESS - gives general access to the Designer functionality. 

• SYSTEM_PROJECT_CREATE - gives access to the project creation functionality. 

• SYSTEM_PROJECT_PRODUCTION_LAUNCH - gives access to the basic project launch functionality. 

• SYSTEM_RAPID_RESULTS_ACCESS - gives access to Rapid Results functionality. 

  

Display standard user menus setting - this setting allows a user who has both the Normal and Standard roles to 
toggle between the Normal and Standard menu layouts. The setting is only visible when a user has at least one of the 
following combinations of permissions: 

1. FEATURE_DEPLOY_SURVEY_BASIC and FEATURE_PROFESSIONAL_SURVEY_LAUNCH. 

2. FEATURE_EMAILING_BASIC and SYSTEM_EMAILING_PROFESSIONAL_ACCESS. 

3. FEATURE_NODE_PAGEBREAK and FEATURE_NODE_DIRECTIVES. 

4. FEATURE_SURVEY_DETAILS_BASIC and FEATURE_PROJECT_OVERVIEW. 

  

The only additional permission that can be given to Standard users as required is: 

• FEATURE_MULTILINGUAL - allows the Standard user access to the Active Languages page, and the ability 
to create multilingual projects. 

6.1.4.2.4.  Feature Permissions 

The permissions listed here are in the majority of cases "Feature" permissions that allow users with the Normal role 
access to Confirmit features that are hidden from users with the Standard role. The permissions are described along 
with any "conditions of use" that may apply. 

Permissions related to answer lists and question tabs 

• FEATURE_ANSWER_COL_WIDTH - controls visibility of the 'Col width' column. 

• FEATURE_ANSWER_GROUP_HEADINGS - controls the ability to add group headings. 

• FEATURE_PROFESSIONAL_LAYOUT_DESIGNER - controls visibility of the 'Style' column in answer list. 

• FEATURE_REUSABLE_LISTS - controls the ability to add predefined list and Reusable scale/list folder in 
questionnaire tree. 

• FEATURE_SCRIPTING - controls visibility of the Validation tab, Triggers tab, Question masks and Precode 
masks within masking (except predefined scripts). 
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• FEATURE_TOPLINE - controls visibility of the Results tab. 

Permissions related to the hiding of design functionality that is not required for Standard users: 

• FEATURE_ACTION_MANAGEMENT - controls access to Action Management functionality. 

• FEATURE_ACTIVE_DASHBOARD - controls access to Active Dashboards functionality. 

• FEATURE_CAPI - controls access to CAPI. 

• FEATURE_CATI - controls access to CATI. 

• FEATURE_GRIDVIEW - controls access to grid view functionality. 

• FEATURE_LEGACY_DB_ACCESS - controls the use of and access to legacy databases. 

• FEATURE_MULTILINGUAL - allows the Standard user access to the Active Languages page, and the ability 
to create multilingual projects. 

• FEATURE_PERMISSIONS_OTHER_USERS - controls the ability to give project permissions to other users. 

• FEATURE_PROFESSIONAL_SURVEY_LAUNCH - gives access to Designer > Launch Survey. 

• FEATURE_PROJECT_OVERVIEW - controls access to the advanced Project Overview page. If the user does 
not have this permission they will only be able to see the basic Overview page.. 

• FEATURE_QUESTION_PROPERTY_SHEET - controls access to a question's Properties sheet. 

• FEATURE_QUESTIONNAIRE_REVIEWER - gives access to Designer > Questionnaire Reviewer. 

• FEATURE_QUOTAS - controls the ability to create quotas. 

• FEATURE_REVIEW_OPENENDS - gives access to the CATI openend reviewer module. This permission is 
assigned to the CATI Supervisor role. 

• FEATURE_SURVEY_HELP_URL - gives access to help links on the URL Setup tab (Project Management > 
Overview). 

• FEATURE_SURVEY_MESSAGES - gives access to Project Management > Survey Messages. 

• FEATURE_SURVEY_PROJECT_LOG - gives access to Project Management > Project Log. 

• FEATURE_SURVEY_ROUTER - allows access to the Survey Router functionality, assuming the company 
has the add-on. 

• FEATURE_SURVEY_SETTINGS - gives access to Project Management > Survey Settings. 

• FEATURE_SURVEY_VERSIONING - gives access to Designer > Compare Survey Versions. 

• FEATURE_TEST_DB - controls access to the test database. 

  

Node permissions: These permissions have been added to the Normal role to hide "advanced" functionality from 
standard users: 

• FEATURE_CALLBLOCKS - controls the ability to add CallBlocks. 

• FEATURE_NODE_3DGRID - controls the ability to add 3D-Grids. 

• FEATURE_NODE_BLOCK - controls the ability to add Blocks. 

• FEATURE_NODE_DIRECTIVES - controls the ability to add Directives (see also below). 

• FEATURE_NODE_LOOP - controls the ability to add loop references. 

• FEATURE_NODE_PAGE - controls the ability to add Page nodes. 

• FEATURE_NODE_SCRIPT - controls the ability to add Script nodes. 

Note that a Standard user can open a project containing 3D-Grid, loop, block, block to call, page, script or directive. 
The Standard user cannot edit, duplicate, move or create any of them. 
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The Standard role has been extended with the FEATURE_NODE_PAGEBREAK permission (the Normal role does 
not have this). The Standard user cannot insert a Directive, but with this permission instead has access to the Page 
Break node. The Page Break node has no details page. 

The FEATURE_NODE_DIRECTIVE permission is added by default to the Normal role and the 
FEATURE_NODE_PAGEBREAK permission is added by default to the Standard role. Professional users can have 
both of these permissions. Below are the rules that apply to different scenarios. 

• FEATURE_NODE_DIRECTIVE, no FEATURE_NODE_PAGEBREAK - no change from today anywhere (and 
no new node type available). 

• FEATURE_NODE_PAGEBREAK, no FEATURE_NODE_DIRECTIVE 

o a Directive appears in the questionnaire as a Pagebreak if MULTI is selected and no other properties are 
selected. 

o a Directive appears in the questionnaire as read-only if other than MULTI is selected or multi and other 
properties are selected. 

o It is possible to add a Pagebreak, it is not possible to add a Directive. 

• FEATURE_NODE_DIRECTIVES and FEATURE_NODE_PAGEBREAK - in this scenario the 'Display standard 
user menus' setting is visible on the User Settings page. 

o 'Display standard user menus' checked - the functionality behaves as "FEATURE_NODE_PAGEBREAK, no 
FEATURE_NODE_DIRECTIVE". 

o 'Display standard user menus' unchecked - the functionality behaves as "FEATURE_NODE_DIRECTIVE, no 
FEATURE_NODE_PAGEBREAK" 

Display standard user menus setting - this setting allows a user who has both the Normal and Standard roles to 
toggle between the Normal and Standard menu layouts. The setting is only visible when a user has at least one of the 
following combinations of permissions: 

1. FEATURE_DEPLOY_SURVEY_BASIC and FEATURE_PROFESSIONAL_SURVEY_LAUNCH. 

2. FEATURE_EMAILING_BASIC and SYSTEM_EMAILING_PROFESSIONAL_ACCESS. 

3. FEATURE_NODE_PAGEBREAK and FEATURE_NODE_DIRECTIVES. 

4. FEATURE_SURVEY_DETAILS_BASIC and FEATURE_PROJECT_OVERVIEW. 

6.1.5.  How to Remove a User 

Actually deleting a user from Confirmit can cause a lot of problems in the system, so deletion should not be attempted. 
If you wish to remove a user from the system; perhaps they have left your company or you wish to close their account 
for some other reason, the best way to do this is to cause their password to expire with immediate effect. The user will 
then no longer have access to Confirmit, but their details, projects etc. will remain available to the system 
administrator for future reference. To expire a user's password: 

1. Go to the Admin > Accounts > Users menu command to open the list of registered users. 

2. Find the desired user and click the blue User ID link. 

The Details overlay opens for that user. 

3. Click on the calendar icon beside the Expires property, and select a past date, for example yesterday's date. 

4. Click Save or Save and Close, and close the User Details overlay. 

Note that when an Expiry date is set and the user's password has expired, the user cannot just click the Forgot Your 
Password link to reset his/her password. The system administrator must go into that user's Details overlay and 
remove the expiry date or change it to a future date to allow the user renewed access. 

Note: When a user is "Expired", he/she will retain ownership of all his/her Confirmit objects (projects, 
templates, reports, Reportal reports, data sources, templates, etc.) until the access permissions to these 
objects are changed. In the event the Expiry is intentional and permanent, the system administrator will need 
to give access to those objects to other users. 
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6.1.6.  How to Modify Users 

To modify a user’s or several users’ roles, permissions etc: 

1. Go to the Admin > Accounts > Users menu command to open the list of registered users. 

2. At the left end of each row in the list is a check-box. Click in the box for each user for whom you wish to modify 
the settings, then click Modify Users in the upper-left corner (see the figure below). 

 

Figure 44  Selecting several users for modification 

The User Modification page opens for the user(s) (see the figure below). In this page you can change the 
users’ Roles, Permissions, Groups, and Expiry date. 

 

Figure 45  The User Modification page 

• Roles – to add a Role to the user(s), choose the role and click Add roles. If you want to remove a Role from 
the user(s), choose the role and click Remove roles. 

• Permissions – to give the user(s) new permissions, choose the permission(s) and click Add permissions. If 
you want to remove permissions from the user(s), choose the permission(s) and click Remove permissions. 
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• Groups – to add the user(s) to a group, choose the group(s) and click Add to groups. If you want to remove 
the user(s) from a group, choose the group(s) and click Remove from groups. 

• Expiry date – to change the expiry date of the licenses, choose a new date and click Update users. 

3. Make the necessary changes. 

4. Click Close to close the User Modification page. 

Note: The changes are saved automatically when you close the page. 

6.1.7.  Passwords and License Expiry 

For a user to be valid, a password and a valid expiry date must be entered in the appropriate fields. The license 
expires at 11.59 pm on the date entered. If no expiry date is set, the user’s license will never expire. For further 
information on Confirmit's password policy, go to (go to Password Policy on page 129 for more information). 

6.1.7.1.  How to Reset a User’s Password 

The users’ passwords are not displayed in the Confirmit User Administration module, and are hashed (one-way 
encrypted) in the database, so administrators have no direct access to the passwords. Administrators can however 
reset a user's password, requiring the user to type in a new one. To do this: 

1. Go to the Admin > Accounts > Users menu command. 

The User list page opens. 

2. Click on a user name to open the Details page for that user. 

Towards the right side of the Details page is the Reset password link. 

3. Click on the Reset password link. 

The Reset Password dialog opens (see the figure below). 

 

Figure 46  The administrator’s Reset Password dialog 

4. Type a new password for the user into the field, and repeat it to confirm. 

Note: By default, Confirmit requires passwords to be a minimum of six characters. See also the Password 
Policy section. You can customize the password settings on the site and company levels; see the Server 
manual, and (go to Admin > Accounts > Companies on page  for more information). 

5. Click Save to save the changes. 

The user’s password is now changed temporarily to that which you have just saved. You must now inform the 
user of their new temporary password. The next time the user logs in to Confirmit (using the temporary 
password), he/she will have to change their password to a new “private” password. Again, this new password 
will have to follow the requirements for number of characters etc. 
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Figure 47  The user’s Change Password notification 

6.1.7.2.  License Expiry 

When an account has 30 days or less remaining until it expires, the user will be notified about this each time they log 
in. The expiry date is set for the company (go to Admin > Accounts > Companies on page  for more information). 

 

Figure 48  Account will expire in x days message 

When an account has expired, the next time a user attempts to log on a warning message is shown below the login 
dialog. The actual warning message that is displayed can be customized for your Company (go to Admin > Accounts 
> Companies on page  for more information). 

6.1.7.3.  Public Encryption Key 

When the company to which the user is registered has the PGP Encryption (encrypted data delivery) add-on 
functionality, the Public encryption key field link becomes available on the user's Details page (go to User Details on 
page 36 for more information). This link opens a window in which you can enter the PGP encryption key for the user 
(go to Admin > Accounts > Companies on page  for more information). See also the Confirmit Server Manual for more 
information regarding the set up of PGP encryption. 

Note: PGP encryption is a payable add-on. 

1. Go to the user's Details page (go to How to Edit a User’s Details on page 36 for more information). 

2. Click the Set Key link (go to User Details on page 36 for more information). 

The Public Encryption Key dialog opens. 
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Figure 49  The Encryption Key dialog 

3. Paste the user’s public PGP key into the text field. 

4. Click Save to save the changes. 

6.1.8.  How to Reactivate an Account after Invalid Login 

To increase system security, if a user attempts to log in to Confirmit using the wrong password too many times in 
succession then the account will be locked. The default number of attempts to login is set to three. This is set using a 
registry setting and can be changed by the server administrator if desired. 

When a user account has been closed due to too many invalid logins, the Confirmit Software Administrator can 
reactivate the account in the User administration window. 

1. Go to the Admin > Accounts > User menu command. 

2. On the user list, click the User ID for the user who is locked out. 

The User’s Details page opens. 

3. Check the Activate checkbox located in the upper-right quadrant of the page. 

Note: This check box only appears when the user’s account has been locked due to too many invalid logins. 
See the figure below. 

 

Figure 50  Resetting the user password 
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4. Click Save to save the changes. 

If the only administrator on a system has locked his/her account, the invalid logon count must be reset directly on the 
SQL server to allow the administrator to log in to the system for the account. 

Note: It is not possible to change Confirmit users’ passwords outside the Confirmit GUI. 

6.2.  Admin > Accounts > Roles 

Roles are sets of permissions. The Role management function allows you to define any number of roles to which you 
can then assign the Confirmit users. This makes it possible to differentiate between users with respect to the 
functionality to which they should have access. 

For example, on Confirmit's SaaS servers, a number of roles have been pre-defined, for example: 

• Translator User – has access to the Translator module only. 

• SysAdmins - a system administrator. 

• ProS – a more advanced user with administration permissions, for Professional Services and R&D 
Departments. 

• Normal – a normal Confirmit license with most of the functionality. 

• Express User – has access to Confirmit Express only. 

• CATI Supervisor – can supervise CATI projects. 

• CAPI Activation User – can generate the CAPI/Kiosk activation files. 

To create a new Role, in the Role Management list (Admin > Accounts > Roles), click the New Role button in the 
upper-right corner of the window. Type in a name for the role, then click Save. 

In the Role Management list, click on a blue Name link to open the management overlay for that role. Here you can 
add and remove permissions as required such that users with the selected role will be able to perform the appropriate 
tasks. 

 

Figure 51  Roles 

Server customers can define their own roles on their server. 

6.3.  Admin > Accounts > Groups 

You can group Confirmit users into different groups, and then give permissions on a group level. For example, you 
can gather into one group the users who often work together on the same projects and then give that group read, 
write, delete and administrate permissions to projects instead of granting the permissions on an individual user basis. 
Group management allows you to add, delete or edit user groups. 
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6.3.1.  How to Create a New Group 

1. Go to the Admin > Accounts > Groups menu command. 

The group list opens. 

2. Click the New Group button in the upper-right corner of the group list. 

The New Group overlay opens. 

 

Figure 52  The New Group overlay 

3. Type the name of the new group into the Name field. 

4. Click Save to save the changes. 

The group is added to the list. Click on the group's Name link to open the Details page. Here you can other 
groups, roles, permissions and members to the group. 

 

Figure 53  Example of the Group Details window 

6.3.2.  How to Include a Group in Another Group 

You can enter a group as a member of other groups. 

1. Go to the Admin > Accounts > Groups menu command. 

The group list opens. 
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2. In the Group List, click on the group you wish to edit. 

The Group Details window opens (go to How to Remove a Group from Another Group on page  for more 
information). 

3. In the Available column, Member of field, select the group to which you wish to add the group you are 
currently working with. 

4. Click the >> button to move the group into the Selected field. 

5. Click Save to save the changes. 

To give the group permissions, repeat the procedure for the “Permissions” field. 

6.3.3.  How to Remove a Group from Another Group 

To remove permissions or to remove the group from another group: 

1. Select the permissions or groups in the “Selected” field. 

2. Click the << button. 

Note: The >> and << buttons operate on both the “Member of” and the “Permissions” fields. 

6.4.  Admin > Accounts > Companies 

Every Confirmit user must be connected to a company, and all the users that are connected to a company are listed 
on the Users tab in that company's Details window. Go to Admin > Accounts > Companies to open the Company 
List window. This window provides an overview of all the companies registered on the server. By default, the 
companies are listed alphabetically by the Company Name. The Company management function enables you to add 
new companies and edit existing ones. 

Note: Only a server administrator is allowed to delete companies. 

 

Figure 54  Example of the Company List 

In the Company List you can search for and sort companies by Company Name, number of Active licenses, Total 
number of licenses, Modified by, when the company details were last modified, and the number of Reportal Design, 
Viewer and Analyst licenses. 

If your search returns more items than can fit on one page, use the Page arrows in the lower right corner to switch 
between pages and browse through the list. The default number of items displayed is 50. 

For Active, Total, Modified, Design, View and Analyst, you can select operators: Less than, less than or equal to, 
equal to, greater than, and greater than or equal to, and specify a number in the text field. 

To sort the list by one of the columns, click on the column header. An arrow indicates in which direction the list is 
sorted; ascending or descending. 

Click on the alphabet buttons across the lower edge of the window to return companies whose name starts with the 
letter that you clicked. 

If you need to search for companies with specific add-ons, click the down-arrow beside the Has Add-on field to open a 
drop-down list. Select the add-on module that is to be used as one of the search criteria, then click Search. 

If you want to view a company’s details, click on the Company link. The Details window for that company opens. 
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A drop-down list from the Company name gives direct links to the Company details, all users in the company, and the 
interface for creating new users. Place the curser over the company name in the list to activate the drop-down list for 
that company. 

 

Figure 55  The Company drop-down 

6.4.1.  How to Register a New Company 

1. Go to the Admin > Accounts > Companies menu command. 

The Companies List window opens. 

2. Click the New Company button in the upper right corner of the list. 

The New Company registration dialog opens as shown below. 

 

Figure 56  The New Company Details dialog 

3. Enter the name of the new company. 

4. Click Save to save the changes. 

The company is registered into the system and appears in the Company List. Go to the company in the list and 
click on its blue Company Name link to open the Company Details page, then set up the options and 
properties as required. 

6.4.2. The Company Details Page 

When the Company List page is open, click on a blue Company link to open the Company Details page for that 
company. The page comprises 10 tags, each holding options related to the name of the tag. The first time you open 
the page during a Confirmit session, the page opens at the General tag. 

6.4.2.1.  Company Details Page General Tab 

 The Company Details overlay opens at the General tab. 
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Figure 57  The Company Details overlay General tab 

• Company ID - the identification number allocated automatically by Confirmit when the company is created in 
the system. 

• Name - the company name as specified by the user creating the company in the system. 

• Notes - any descriptive text, comments etc. 

• Created - the date on which the company was created in Confirmit. 

• Modified - the date the company details were last modified. 

• Default user expiry date - the expiry date is the date on which the users’ access to Confirmit is to expire. This 
will usually be related to the contract your company has with Confirmit; when the contract expires, access will 
be revoked. The date set here will be applied as default to all new users within the company. Note that this 
field is mandatory for the company. Once the default expiry date is set for the company, the administrator can 
change the date for specific users if necessary (go to User Details on page 36 for more information). 

• User expired message - the message that will be presented to a user when that user's account has expired. 
Enter the warning message that you wish to use for your company. 

• Max number of versions stored for survey runtime files - each time a survey is launched, a new version of 
the files is made. This property specifies how many old versions of the survey package (binary) file are stored 
in the database before the oldest is overwritten. If the survey is updated while respondents are in the process 
of responding, keeping several versions of the runtime files will enable those respondent to finish the survey in 
the same version as they started it. 

• Max number of versions stored for XML... - each time a survey is launched, a new version of the files is 
made. This property specifies how many old versions of the survey schema XML files are stored in the 
database before the oldest is overwritten. These XML files are used for "Compare Survey Versions" in 
Authoring. 
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• Survey Dashboard/Instant Analytics users - this field allows you to allocate the number of survey 
dashboard/Instant Analytics users for a company. The Confirmit license contains the value for the number of 
end users available in total at the site level. These licenses can be allocated to individual companies within the 
site but the number allocated across all companies cannot exceed the site limit. If this property is set to "0", all 
allocated permissions for Survey Dashboard/Instant Analytics End Users will be revoked for the current 
company. End User lists will still be associated with surveys, but no permissions will be allocated to the end 
users. A confirmation dialog will be displayed before the "0" setting is saved. 

• Assigned Survey Dashboard/Instant Analytics users - this field is the count of currently assigned 
dashboard/Instant Analytics users for the site. When changing the number of users, it cannot be made less 
that the number of already assigned users, nor can it exceed the total number that can be allocated at the site 
level. A license is "used" when an end user is allocated permission to at least 1 project (via Project 
Management > Dashboard end users). The same user can be granted access to multiple projects; this will still 
only use 1 license for that user. 

• Confirmit Express Licenses - enter into this field the number of licenses granted to the company for the 
Express option. If the field is left blank, then Confirmit will interpret this to mean “zero licenses”. 

• Current active Express users - the number of users currently running Express. 

• Current pending Express users - the number of Express users who have been set up and got their 
activation link, but who have not yet activated their accounts. 

• User type - the type of File Library access that is to be available to users in your company. Note that the 
various access levels are chargeable at different rates. 

• Total upload file limit - the current maximum size (in kb) for files to be uploaded to the File Library. 

Note: The file types that can be uploaded are controlled by the system administrator. For SaaS users this will 
be Confirmit, while for On-Premise users this will be your local system administrator Refer to the Confirmit 
Server Manual for details). The files available to you may therefore differ from the lists below. 

o Standard - allows upload of jpg, gif, bmp, jpeg, tif and png files. 

o Enhanced - allows uploSad of jpg, gif, bmp, jpeg, tif, png, css, htm, html, js and swf files. 

o Multimedia - allows upload of jpg, gif, bmp, jpeg, tif, png, ico, css, htm, html, js, swf, pdf, xml, txt, ppt, doc, 
emf, flv, zip, htc, avi, mpeg, mpg, mov, rm, wmv, wma, mp3, m3u, wav, aiff and cur files. 

6.4.2.2.  Company Details Page Add-ons Tab 

This tab allows you to specify which add-ons are to be available to the company. 

 

Figure 58  The Company Details overlay Add-ons tab 

To add an add-on to the company, select it in the Available list and click the >> button. To remove an add-on, select it 
in the Selected list and click << (go to Add-on Modules on page 68 for more information). 
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6.4.2.3.  Company Details Page Security Tab 

This tab holds the options and selections that enable you to set up the desired level of security for the company. 

 

Figure 59  The Company Details overlay Security tab 

• Always use SSL in surveys – check this box if you want the company to generate all links to limited surveys 
as secure links, for example https://survey.yourserver.com/wix/pXXXXXX.aspx. The Respondents > 
Emailing > Secure option will then be chosen by default and locked to prevent changes. 

• Always use SSL in Authoring and Reportal – forces all users in this company to use the https:// link for 
authoring and Reportal. The http:// link will not work. 

Note: To use HTTPS/SSL you will need to obtain a server certificate from a certification authority (for example 
VeriSign or Thawte) and bind it to your Web server(s). 

• Always use encrypted file transfer – check this box to encrypt all data exports, report exports and 
respondent exports. The setting forces all exports and imports that support encryption to be encrypted. The 
system cannot prevent the user uploading plain text data files to the client as the encryption is not checked 
until the import task is actually run, so unencrypted files can lie on the server. However any import tasks will 
fail if the data file is not encrypted. Note that when the box is checked, to be able to upload respondents for the 
users in this company, the respondent list must also be encrypted. 

Survey Definition imports and exports do not have to be encrypted. Read more about the setup of PGP 
encryption later in this chapter and in the Confirmit Server Manual. 

• Always use FTP for file transfer – makes FTP the only option available in the “File transfer” field on the set 
up page for data exports, report exports and respondent export. The Email option is not available. Data 
imports and survey import and export are not affected by this setting and do not have to be to/from a FTP 
server. 

• Enforce SFTP (SSH for FTP) - check this option to enforce SSH when using FTP for importing/exporting 
data. 
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• Enforce db encryption - if the Database Encryption add-on is licensed for your company (go to Add-on 
Modules on page 68 for more information), this check-box becomes available. Check the box to enforce 
encryption for all new databases for projects administered by the company. Note that this is not retro-active 
and will only apply to new databases. If you want the databases to be encrypted for existing company projects, 
the projects must be re-launched and new databases must be created. Encryption only applies to the 
production survey database, system databases and multimode databases are not encrypted (go to The 
Database Encryption Add-on on page 70 for more information). 

• Restrict data export tasks... - If this option is checked, only users registered to the same company as the 
survey owner will be able to perform exports on this customer's surveys. Even users with system_admin or 
company_admin permission will not be able to perform exports if they are not registered with the survey 
owner's company. Note that any changes to this property are registered in the system activity log with date, 
time and user id of the user making the change. 

• Prevent most SaaS service management staff... - check this option to prevent users with 
SYSTEM_PROJECT_ADMINISTRATE from implicitly being granted access to projects (surveys, polls and 
panels) in this company. Any user can still gain access to the project, but only if they are explicitly granted 
permission to do so. Users with SYSTEM_ADMINISTRATE can access all projects irrespective of this setting. 

• Enable survey db level auditing - check this option to enable SQL Server auditing at the survey database 
level. When enabled, all surveys created for this company will have database auditing enabled. This audit log 
is not accessible through the Confirmit user interface. 

• Use password options – check this box to display the Password expiry days and Password validation code 
fields. 

• Password expiry days – specify how many days the password is to be valid after first use. The system will 
then prompt the users to change their password. The users will get the message: 

“Your password has expired. Please change your password. 

• Password validation code - specify the required number of characters in the password. You must insert a 
Jscript code in the Validation code field, using the specified primitives, for example: 

-------------------------------------------------------------------------

---------- 

if(password.length<8) 

{ 

warning="Password must be at least 8 characters"; 

} 

-------------------------------------------------------------------------

---------- 

• Enforce SSO for Professional users - when checked, companies where SSO (Single Sign On) is 
implemented are forced to only log in via SSO and cannot log in through the normal login page. Note that 
users with SYSTEM_ADMINISTRATE access can access the system via the login page irrespective of this 
company setting. 

• Company AES key – if Single Sign-on or External Respondent Limited Surveys are to be used, an AES key is 
required. This key can be entered here, although key validation is not performed on saving. When this value is 
defined it allows the survey setting to be selected by users; when not defined it is grayed out. The key can be 
entered manually, but the 'Generate AES key' link should be used as this will create a valid key. 

Note: Editing this key can be dangerous (if it is changed, old links will not be valid) therefore once the key is 
defined, the value is read-only until 'Change aes key' is clicked. A warning message is then displayed, and 
the field becomes editable. 

6.4.2.4.  Company Details Page Emailing Tab 

Here you can configure the emailing options for the company. 
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Figure 60  The Company Details overlay Emailing tab 

• Enable emailing options - check the box to enable the remaining options on the tab. 

• Mail Server - the DNS name / IP address of the remote email server. This is only required if a specific 
company needs to use a different mail server than others. Note that this field supports CRAM-MDS SASL only. 

• Port - the TCP/IP port at which the remote server is configured to listen for incoming connections. Set if Mail 
Server (above) is set. 

• User ID - if the remote mail server requires authentication, the username should be entered here. 

• Password - if the remote mail server requires authentication, the password should be entered here. 

• Email Directory - This functionality requires the Dedicated IP add-on. To reduce the chances of a company 
being affected by other companies being registered as SPAM producers (or themselves affecting other 
companies), a company can create its own dedicated email server. Type the address to the dedicated email 
directory into the field. 

• Override sitewide fixed sender domain - This functionality requires the FixedSenderDomain add-on. 

Under normal circumstances Confirmit authors are forced to use a specific domain (bounceback domain) in 
the From field when they send emails via Respondents > Emailing. This domain would be a site-wide setting 
on the current Confirmit server, for example “@us.confirmit.com” on Confirmit's US ASP server. It can 
however be overridden for each company with a domain that the client/company would like to be set up 
towards the IP addresses of your Confirmit mail servers. The MX-record of the bounceback domain (a pointer 
that shows to which IP address the emails from this domain should be delivered) will point to the server that 
sends the email, i.e. the Confirmit mail server. Non Delivery Reports will always be sent to the From 
addresses. In this case, as the domain points to the IP addresses of your Confirmit mail servers, the delivery 
reports will be picked up by your Confirmit mail servers. This then makes it possible to log an Email Delivery 
Report for the respondents. 

One of the advantages with this bounce back system is that when an email is sent out, an additional header is 
put on the SMTP message. This header includes the address of the sending server. If this header does not 
include the same address as specified in the “from” field, many mail relays will classify this as SPAM. If the 
bounce back functionality is enabled, it forces the header to be the same as the one specified in the “from” 
field, and the possibility of e-mails being classified as SPAM is thereby reduced (go to Batch Emailing Tasks 
on page  for more information). 
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Important 
When adding a From address, if you add the wrong domain, a custom domain you do not control yourself, or 
a domain which has not been configured to allow Confirmit servers to send on its behalf by using SPF 
records, then you risk severely degraded deliverability, and negatively affecting the service as a whole. 
Also, if an email sent by Horizons is automatically forwarded from one recipient’s inbox to another the email 
may not arrive at the second inbox, as the original DKIM signing and SPF records will not match the 
originating server. 

• Domain - type in the domain you wish to use. 

• Override sitewide domain keys certificate ID - appears when the DomainKeys add-on is selected. 
DomainKeys is a technology that gives e-mail providers a mechanism for verifying both the domain of each e-
mail sender and the integrity of the messages sent (i.e. that they were not altered during transit). If the function 
is used, it will reduce the chance that your emails are interpreted as spam. Check this box to use the function. 
For more information, refer to the web address below: 

http://antispam.yahoo.com/domainkeys 

• Certificate ID - specifies the certificate ID to be used for this company for overriding the system default 
DomainKeys certificate when digitally signing outgoing emails. The certificate ID can be found using the WSE 
x509 Certificate Tool. 

• Selector - specifies the domain name selector to use for the DomainKeys public key. Used by remote mail 
servers to determine the validity of the email digital signature. 

6.4.2.5.  Company Details Page Survey Channels Tab 

This tab holds the options for setting up CAPI/Kiosk and CATI user licenses. 

 

Figure 61  The Company Details overlay Survey Channels tab 
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• Override sitewide domain in survey URLs - if you are running surveys for customers, the customers may 
not wish the links to their surveys to include another domain name, for example ....Confirmit.com. Your 
company may therefore set up a permanent domain override as a company-wide default setting. If you wish to 
use a domain other than the default in the survey links, select the Override sitewide domain in survey URLs 
checkbox and specify the new domain in the field below. Note that the domain will be your company's 
responsibility; contact Confirmit Support for further details. 

Important 
When typing the domain link into either of the "Override..." fields, ensure you do not include a trailing space 
(a space character at the end of the domain). A trailing space in this link will give an error during launch for 
all surveys, preventing any surveys from being launched by the company. 

• When using domain override... - the domain override functionality (see above) adds the specified URL into 
the survey link. If you want the domain specified in Domain Override to be the only domain that is allowed to 
be used in survey links to your company's surveys, you can restrict access by checking this box. This will 
prevent access to the surveys from links containing any other domain configured to point towards the Confirmit 
deployment servers, including the default (for example "2survey.confirmit.com"). 

• Override sitewide domain in short survey URLs - if you wish to use a domain name other than the default 
in short URLs for surveys, you may set up a permanent domain override as a company-wide default setting. 
You must first register the domain you wish to use (if not already done) and set up a domain record to point 
towards the public IP address of the interviewing server(s) in the DNS domain manager (see the Authoring 
User Guide for more information). Once the domain is set up, select the “Override sitewide domain in short 
survey URLs” checkbox and specify the new domain in the field below. Note the Important note above! 

o CAPI/Kiosk Settings – these fields become available if the company has the CAPI/Kiosk add-on. Use these 
fields as follows:Enduser list id – the CAPI/Kiosk Interviewers must be created in an End User List (see the 
Authoring User Manual and CAPI/Kiosk User Manual for more information). The ID of this End User List must 
be registered in the Enduser list id field. Only one CAPI/Kiosk Interviewer End User list can be registered per 
company. 

o CAPI Licenses – when a company has access to the CAPI/Kiosk functionality, specify the number of 
licensed CAPI consoles in the CAPI Licenses field. 

o Kiosk Licenses – when a company has access to the CAPI/Kiosk functionality, specify the number of 
licensed kiosk consoles in the Kiosk Licenses field. 

• CATI Settings - these fields become available if the company has the CATI add-on. Use these fields as 
follows 

o Company alias - the CATI interviewer must log in using his/her username and password and also a 
company name as part of the identification. This will be the alias specified for this company, and the field 
cannot be empty. 

o Telephony enabled - if the company is using the SaaS dialing capabilities (from MagneticNorth) this box 
should be checked. This will then allow for the non-manual dialing modes to be active. When enabled, it is 
also possible to enable predictive dialing. 

o Predictive dialing enabled - if Telephony enabled is checked, this sub option appears. The dialer supports 
two modes that are charged for at different rates per CATI interviewing seat. The options are: 
CATI (no dialer, not predictive) 
CATI with dialer (not predictive) 
CATI with dialer and predictive capabilities. 

• Maximum concurrent interviewers - this is the maximum number of concurrent interviewers that can log into 
the system. Once this number is reached, additional interviewers cannot log into the system. Note that the 
interviewing restriction is based on the interviewer being logged in - they do not necessarily have to be inside 
an actual interview. 

• Temporarily extended license - in the event your company has a large but short-term job, it is possible to 
increase for a limited period the maximum number of concurrent interviewers logged in. If activated, the start 
date, duration and additional number of logins must be supplied (additional fields become available on the 
tab). While this period is active, the maximum number of interviewers will be the initial value + this value. Once 
the period expires, the maximum number allowed automatically reverts to the original value. 
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• Initialize/Remove Multimode Instance - if the CATI or CAPI add on are applied to a company, the Initialize 
Multimode Instance button becomes available at the bottom of the page. The multimode functionality MUST be 
initialized once for companies with these add-ons. This initialization process creates the necessary 
databases/services on the multimode system. Note that the initialization needs to be performed only once. I.e. 
If the project is created for a CAPI company and they then also get CATI, you do not need to create another 
instance.  

Warning 
Once the databases and services have been created, it is possible to remove them (the button changes to 
Remove Multimode Instance). Removing them will display a warning, and completing the removal will delete 
the CATI/CAPI data from the system. This data may not then be recoverable. 

6.4.2.6.  Company Details Page Reportal Tab 

This tab holds the administrator options for the Reportal functionality. 

 

Figure 62  The Company Details overlay Reportal tab 

• Unlimited usage per license - this setting concerns the different types of end user licensing model. Contact 
your account manager for further details. 

• View licenses - the number of View licenses available to the company (enter the number of licenses granted 
to the company for the license type into the field), and the number currently allocated to specified users. 

• Analyst licenses - the number of Analyst licenses available to the company (enter the number of licenses 
granted to the company for the license type into the field), and the number currently allocated to specified 
users. 

• Design licenses - the number of Design licenses available to the company (enter the number of licenses 
granted to the company for the license type into the field), and the number currently allocated to specified 
users. 

• Disable Extended table engine - check to disable the new Extended Table Engine and use the older version 
2 instead. Refer to Appendix D of the Reportal User Guide for further details. 

Note: If a company has granted a number of viewer licenses to end users, and a Software Administrator tries 
to decrease the number of viewer licenses in the company properties, a warning will be displayed and you 
will not be able to perform the change. 

6.4.2.7.  Company Details Page Permissions Tab 

This tab lists the users currently registered to the company, and enables you to set up the user permissions for those 
users. 
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Figure 63  The Company Details page Permissions tab 

The Permissions tab lists the Users in your own company, Groups and Other Users who are registered as 
administrators of your company. These may for example be your colleagues in your company, or system 
administrators of client companies for which you are creating end user lists. Use this tab to give other users access to 
the company in the Company drop-down list on the Project Overview page. 

The Permissions tab lists a maximum of 50 users on the current page; click the next/previous Page buttons in the 
lower-right corner of the page to move between pages. Click a letter-button (along the lower edge of the page) to list 
only those users who's User ID starts with that letter. The list can be sorted on the User ID, First name and Last name 
columns; click the appropriate column header to toggle the sort order up or down on that column. 

The Permissions tab list has a search function to enable you to more easily find the required administrator(s) in the 
event that the list is extensive. 

•  Display - the drop-down allows you to select the types of users/groups to be displayed. 

• Show Assigned - the drop-down allows you to select whether you wish to see all users, or only those that 
have already a permission assigned to them. 

• Permission type - click the down-arrow beside a user's field to open a drop-down list of the permissions, then 
select the appropriate permission for that user. The options are:  

o None - the user does not have access to the project.  

o Read - the user has only Read permission, i.e. he/she can view the questionnaire and associated reports but 
is not allowed to add new or delete existing elements in them.  

o Write - the user has Write permission, i.e. he/she is allowed to add questions to the questionnaire and 
reports.  

o Delete - the user has Delete permission, i.e. he/she is allowed to work on the questionnaire and reports, and 
is allowed to delete objects in them.  

• Grant all - select a permission from the drop-down beside this button and click the button to give that 
permission to all the currently listed users. Note that if you do not wish to give the selected permission to all 
users in your company then you must first conduct a search such that only the appropriate users are listed on 
the page.  
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• Revoke all - select a permission from the drop-down beside this button and click the button to remove that 
permission from all the currently listed users. Note that if you do not wish to remove the selected permission 
from all users in your company then you must first conduct a search such that only the appropriate users are 
listed on the page.  

The Save button in the upper-left corner of the tab flashes in the event the tab contains unsaved changes. 

6.4.2.7.1.  How to Add Other Users 

Initially, only users and groups within your organization are listed on the Permissions tab. However, more users may 
be added. To add users, you must supply Confirmit with the correct user keys of these users. Typically, an external 
user will send you his or her user key by email. 

1. Copy this key and click the Add other users button at the bottom of the Permissions tab.  

The User Key Entry window opens. 

 

Figure 64  The user key entry window 

2. Paste the key into the User Key Entry window.  

Note: Make sure you do not have any space after the last character in the user key. 

3. Click Add.  

The Entry window closes and you are returned to the Permissions tab. The newly added user will be listed in 
the Other users field. You can now give the new user the appropriate permissions. 

To remove a user from the Other Users field, click on the Remove other users link and then choose the users 
you wish to remove. 

6.4.2.8.  Company Details Page Flex Extensions Tab 

This tab lists and provides details for the Confirmit Flex extensions that are available to your company. All extensions 
are listed; those that your company's users currently have access to are set to Granted in the Access column. 
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Figure 65  The Company Details overlay Flex Extensions tab 

The fields and columns on this page are as follows: 

• Access - specifies whether the current company has access to this extension. Open the drop-down list and 
select Denied or Granted as appropriate. 

Note: If access to an extension is denied for a company, the extension will be disabled and removed from all 
projects owned by that company. Due to this, if access is disabled after the extension has been taken into 
use in a company's projects, then a message box is displayed requesting that you confirm the denial. 

• Active for new projects - specifies whether the extension is to be active by default for all new projects 
created by users attached to this company. Select as appropriate. 

• Name - the name of the extension. 

• Status - the current status for the extension (go to The Extension Details Page on page 108 for more 
information). 

• In Use - indicates whether the extension is being used in a project owned by the current company. If "Yes", 
this will be a link - click the link to open a list of the projects using the extension (go to The In Use Link on page 
111 for more information). 

The following details are extracted from the extension's Information XML page. In the event some information is not 
available, NA will be displayed in the relevant column(s). 

• Title - the title of the extension 

• Created By - the name of the company to which the person who created the extension is registered. 

• Version - the version number for the extension. 

• Each extension row can also include a description to simplify identification etc. 

Refer to the Flex Extension User Guide for further information on using the Flex extensions. 
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6.4.2.9.  Company Details Page Users Tab 

This tab lists the users that are registered for your company. The information presented on this tab is identical to that 
on the Admin > Accounts > Users page (go to Admin > Accounts > Users on page 32 for more information), and you 
have the same search and sort facilities. Click on a blue User ID link to open the User Details page for that user (go to 
User Details on page 36 for more information). Note however that you cannot create new users from this tab. 

 

Figure 66  The Company Details overlay Users tab 

6.4.2.10.  Company Details Page Fiscal Calendar Tab 

This tab allows you to set up a non-standard fiscal calendar such that you can later create reports based on your 
company's accounting time-plan. 

 Users with the Company Administrator permission can set up the calendar through the Admin > Accounts > 
Companies menu or via the Home > Company > Company Settings menu. Note that only one fiscal calendar can 
be set up per company. 

 

Figure 67  The Company Details overlay Fiscal Calendar tab 

For further details and procedures concerning the Fiscal Calendar tab, refer to the Other Properties and Functionality 
chapter (go to The Fiscal Calendar Tab on page 113 for more information). 
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Note: The Fiscal Calendar functionality will be available only for reports using the Extended Tabulation 
Engine. Refer to the Reportal User Guide for further details on the Extended Tabulation Engine. 

6.4.2.11.  Company Details Page Other Tab 

This tab lists options that do not fall naturally under one of the other "specialist" tabs. 

 

Figure 68  The Company Details overlay Other tab 

• Set 'Do not perform data cleaning…' – in Confirmit Designer, if a condition evaluates to FALSE, the answers 
to all questions inside the THEN folder are deleted. (If it evaluates to TRUE and has an ELSE folder all the 
answers to the questions inside the ELSE folder are deleted.) This is to ensure consistency in the data if the 
respondent moves back and forth in the questionnaire and changes his/her answers (if you have allowed the 
respondents to modify their answers). However sometimes you do not want to delete the previously entered 
data. This could for example be in a questionnaire where the respondent is allowed to re-enter, but should only 
get access to some of the questions or a different set of questions than the first time. In a Condition’s Details 
page, the author can check the “Do not perform data cleaning” property to prevent deletion of the answers 
inside a THEN or ELSE folder with a check that this is the first or second time the user accesses the survey. 
However, as the administrator you can check this box to set the property as default for the entire company. 

• Set 'No cleaning on question masking'... - if a Question Mask evaluates to TRUE, the question is hidden 
and the answers to the question are deleted. This is to ensure consistency in the data if the respondent moves 
back and forth in the questionnaire and changes his/her answers (if you have allowed the respondents to 
modify their answers). However sometimes you do not want to delete the previously entered data. The 
question property "No cleaning on Question Masking" will prevent this cleaning. A system or company 
administrator can select the company setting "Set 'No cleaning on Question Masking' as default" for the entire 
company. 
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• Do not show survey name in browser - when selected the survey title will not be set as the browser title for 
survey pages. This will apply to all rendering modes, including mobile touch and mobile generic. It will only be 
applicable to surveys launched after the setting is effective. The setting is disabled by default. 

• Ascribe account id (FTP) – use this field to specify the user company's Ascribe ID for transferring Ascribe 
exports. 

Ascribe™ is an application for coding open text (verbatim) responses, provided by Language Logic 
(http://www.languagelogic.info) and is not part of the Confirmit offering or part of any product of service 
provided by Confirmit Company. The Ascribe export will give an XML file with questionnaire and codebook 
definitions, as well as response data. It gives you a simple way to transfer the data from Confirmit to Ascribe. 

Either send the XML file by email, or transfer it directly to an Ascribe FTP server. 

To use the FTP option, your company's Confirmit account must be set up with the correct FTP settings for the 
Ascribe FTP site. You must establish an Ascribe account by contacting Language Logics directly, and you will 
receive the relevant FTP account name from them. 

• Enforce Optimized data storage - check this box to enforce that all project databases created will be in the 
Optimized database format. The Legacy database format will not then be available as an option. This setting 
applies to all new projects created, either via the New Project menu item, by duplication of an existing project 
or by importing a survey XML. Any existing projects created in the Legacy format will remain in this format 
even if re-launched. 

• Enforce shared database storage- this option applies to Optimized format database projects only. Enabling 
this option will enforce that all Optimized database projects that are created will reside within the company-
wide shared database. This setting applies to all new projects created, either via the New Project menu item, 
by duplication of an existing project or by importing of a survey XML. Existing Optimized database format 
projects that do not exist in the company-wide shared database will not be migrated even if re-launched. The 
shared company-wide database is only created after the first project is launched; it is necessary to launch a 
project for the first time to create the company-wide shared database. 

• Enable shared databases for Professional surveys - available if Optimized data storage is selected (see 
above). Check the box if you wish the users in your company to have the option of using one database to store 
multiple surveys. Note that Polls and projects created for data import in Reportal will be stored in shared 
databases per company; one database for each project type. Contact Confirmit before activating this property. 

• Enable shared databases for Express surveys - available if Optimized data storage is selected (see above). 
Check the box if you wish the users in your company to have the option of storing multiple Express surveys in 
one database. New Express surveys will be created in the Optimized format by default if this option is 
selected. Contact Confirmit before activating this property. 

Note: The following points should be clearly understood when using shared databases: 
• Even though surveys will share a database, the surveys will have separate schemas and tables within the 
shared database. 
• The configuration is intended more for "many small" surveys, rather than "few large" surveys. The shared 
setup reduces the administrative overhead for many small surveys, but separate management (for example 
backup, restore, etc.) of individual surveys becomes very difficult. 

• Allow users to request pre-V18 survey XML export - check the box if your users need "backward-
compatible access" to older survey exports. 

• Allow users to request pre-V18 translation XML export - check the box if your users need "backward-
compatible access" to older translation exports. 

• Email Sender for Data Exports - if you wish to set up a standard Sender email address for your company, 
type the address here. This address will then be used throughout the company as the Sender address for data 
exports sent via email, FTP notifications and ‘Failed import / export’ emails to the user. 

• Ignore template-defined positions for SPSS export - applies to SPSS File exports (sps/dat). By default, 
SPSS export will use the column positions specified in the template when running an export with templates. If 
you check this box, the template-defined positions will be ignored and the positions will be calculated 
automatically according to the business rules, and system variables (interview_start, interview_end) will be 
exported as DATETIME variables with 19 columns. 

http://www.languagelogic.info/
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• Recipients of Archiving notification emails - notification messages regarding the archiving of projects of 
your company will be sent to the email addresses specified in this field in addition to the project creator. This 
allows management of archiving processes even if the person who created the project is unavailable or has 
left the company. you can specify one or several e-mail addresses on the company level, in addition to the 
archiving project recipient, to which the notification emails are to be sent.These emails will be sent to both 
project recipient and company recipient. 

• Google Analytics Account ID - when set, this account id will be included in the GA script in surveys, 
Community Portals and Reportal view mode, to allow customers to track the usage of these pages via GA (go 
to Integration with Google Analytics on page 71 for more information). 

• Tasks - Force the Reportal... - check this box to enforce Reportal reports and PDF exports from this 
company to execute on specified batch servers. When this box is checked, a list of the servers available to the 
company appears; select the desired servers. 

6.4.3.  Add-on Modules 

Add-on modules are additional parts of the Confirmit software. These modules must be activated by the Confirmit 
server administrator before they will be available for the Software Administrator to assign to individual 
users/companies. Confirmit includes a system for administrating access to Add-ons. 

Note: Some of the Add-on modules are chargeable items, and some are only available to SaaS customers. 
Contact Confirmit for details. 

Note: Some of the Add-on modules are visible to Confirmit users even if they are not activated. However if a 
user tries to enter one of those modules, a message will appear saying that the user does not have access. 
Some Add-on modules are not displayed if the users do not have access to them. 

The Add-on modules that are currently available are: 

• Basic Panel – functionality to run and maintain panels and panelists in Confirmit. 

• CAPI – gives access to the CAPI (Computer Assisted Personal Interview) functionality. See the CAPI/Kiosk 
User Guide for a detailed description of the functionality. 

• CATI - gives access to the CATI (Computer Assisted Telephone Interview) functionality. See the CATI User 
Guide for a detailed description of the functionality. 

• Code Completion - enables the code-completion functionality for scripting in Authoring and Reportal. Refer to 
the Authoring and Reportal User Guides for further details. 

• Community Panel – gives access to the Community Panel functionality. See the Community Panel User 
Manual for a detailed description of the functionality. 

• Community Snapshot Panel - for Community Panels, enables the user to take regular snapshots of the 
panel data. The add-on allows a new Community Snapshot panel, and a rule that transfers the data from the 
panel to the snapshot panel, to be created,  

• Concurrent Sampling - for Community Panels, enables the user to multiple sampling jobs and execute them 
simultaneously. Scarce resources will then be allocated fairly across all the selected jobs. Refer to the 
Community Panels User Guide for further details. 

• Database design – allows the setting-up of tables and table structures that can be used as answer lists in 
single questions in Confirmit surveys. Advantages are the possibility to maintain answer lists outside Confirmit 
(for use in several projects) and the possibility to define parent-child structures with any number of sub levels. 

• Database Encryption - delivers support for project-level encryption for the production survey database (data-
at-rest encryption) (go to The Database Encryption Add-on on page 70 for more information). 

• Data Processing - allows the user access to the Data Processing functionality. This includes the Data 
Processing menu (refer to the Authoring User Guide for further details). 

• Dedicated IP – gives access to the Dedicated IP functionality (go to The Company Details Page on page  for 
more information). 

• Domain keys – allows e-mail providers to verify both the domain of each e-mail sender and the integrity of the 
messages sent (i.e. that they were not altered during transit). If the function is used, it will reduce the chance 
that your emails are interpreted as spam. 
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• Email delivery report – is implemented on company-wide level, and forces all users in that company to use 
the predefined domain in the “From” field when sending out e-mails from Confirmit. For example, on the 
Confirmit ASPs this domain is set to "us.confirmit.com" (US ASP) or "euro.confirmit.com" (UK ASP). In 
addition to improving deliverability, this also allows access to the Email Delivery Report giving full visibility into 
the status of the e-mail send-outs from Confirmit. 

• File Library – gives access to functionality where Confirmit users are allocated their own domain to store files. 
See the Authoring User Manual for a detailed description of the functionality. 

• Fixed sender domain – gives access to the corresponding functionality (go to The Company Details Page on 
page  for more information). 

• FTP for file transfer – data transfer through File Transfer Protocol. 

• Kiosk – gives access to the Kiosk functionality. See the CAPI/Kiosk User Manual for a detailed description of 
the functionality. 

• Legacy Reporting - to reduce support, training, documentation, QA, and maintenance, the "legacy" Reporting 
functionality is now supplied as an add-on. For new customers, the functionality is included in other areas of 
the application. 

• Multi code data export – allows the export of code data for multi questions. 

• NonPredictive Telephony - CATI add-on. See the CATI User Guide for a detailed description of the 
functionality. 

• Online coding – functionality for coding answers to open text questions and “Other, specify” answers into the 
answer list of a multi question. This gives more possibilities within reporting of these data. 

• PDF Respondent Report – functionality to allow the generation and emailing of a PDF file with HTML. This 
can, for example, be used to send an email of the respondent’s answers to a manager. 

• PGP Encryption – encrypted data delivery. To make use of this the server must be set up with PGP 
Encryption. See the Confirmit Server Manual for information regarding PGP Encryption set up. Note that an 
encryption key must be entered for all users that should be able to use and receive encrypted data (go to 
Admin > Accounts on page  for more information). 

• Predictive Telephoney - CATI add-on. See the CATI User Guide for a detailed description of the functionality. 

• Questionnaire Reviewer – gives access to the Questionnaire Reviewer functionality. This enables Confirmit 
authors to allow third-parties access to a limited part of Confirmit so the third-parties can review and make 
minor changes to Confirmit questionnaires. See the Confirmit Authoring User Guide for further information. 

• Random Data Generator – allows users to create more than 50 responses in the Random Data Generator 
functionality. See the Authoring User Manual for a detailed description of the functionality. 

• Reportal – provides access to the Reportal functionality. See also the two add-ons below. 

• Reportal Public Access – allows Reportal reports to be defined as public, and an open link can be sent to 
Viewers/End users. 

• Reportal Report Export – allows the export of entire Excel and PPT reports from Reportal. The users will also 
be able to give report Viewers and Designers rights to export a certain number of reports. 

• Sample Only - allows the user to upload links to an external survey. On each job, a new option is available; 
"External survey links" which allows you to upload a repository of unique links to an external survey. The links 
will be added to the Sample file and can be uploaded to a Confirmit project that handles the statusing and 
redirecting for the Sample Only job. 

• Single Sign On – provides access to the Single-sign-on functionality which allows user’s to re-use their local 
logon credentials when logging on to Confirmit. 

• Spell checker – functionality for spell-checking text in questions, answer lists, information nodes etc. 

• Survey Router - enables you to gather surveys in a group, and if the situation arises where a respondent 
cannot complete the survey he/she is initially allocated to (due to screening or quotas), then the respondent 
can be moved seamlessly onto another survey in the group. 
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• Translator – functionality for administrating the translation of multilingual projects with several translators 
working outside authoring. 

6.4.3.1. The Database Encryption Add-on 

The Database Encryption add-on delivers support for project-level encryption for the production survey database 
(data-at-rest encryption). 

The add-on applies encryption to the project's production database only; the test database, system databases and the 
multimode databases are not encrypted. The company shared database used for Express projects, and the company 
shared database used for shared projects, will assume the setting is in use when the databases are created for the 
first time.  

The encryption is delivered through SQL Server TDE (Transparent Data Encryption) using a secure certificate 
deployed on the encryption-enabled SQL Server database instance(s). Encryption can only be applied at the 
database creation stage, and it cannot be changed when a survey is re-launched unless a new DB is being created. 

When the add-on is activated for your company, the Security tab in the Admin > Accounts > Companies page 
includes the Enforce db encryption checkbox (go to Company Details Page Security Tab on page 56 for more 
information). Check this box to enforce encryption for all new databases for projects administered by your company. 
Note that this action is not retro-active and will only apply to new databases; pre-existing databases will not be 
encrypted. If you want the databases to be encrypted for existing company projects, the projects must be re-launched 
and new databases must be created. 

When the add-on is activated for the company and the Enforce db encryption check-box is not checked, then an 
optional setting for selecting encryption for a project's database is visible to the project author on the Project Overview 
page and the Survey Launch page. Again, this can only be applied to new databases; if the author wants to encrypt 
the database for an existing project, the project must be re-launched and a new database must be created. 

Encryption is essentially transparent to survey authors apart from the setting itself; data viewing, editing, importing, 
exporting etc. remains unchanged. It is also transparent to respondents. 

Testing has shown the encryption overhead to be negligible, but it does introduce more load onto the SQL Server 
instance than for unencrypted project databases. Note that during back-up, un-encrypted databases are compressed 
to save space before the back-up is taken. However encrypted databases cannot be compressed, so the space 
required for backups of encrypted databases can be significantly greater than for the unencrypted version. 

Database Encryption is available as a licensable add-on for On-Premise customers (not in Confirmit versions prior to 
v15), however SQL Server TDE is only available in Enterprise edition SQL Server.  

6.4.3.2.  Changes to Add-ons 

The following sections describe changes that have been made to some of the add-ons. 

6.4.3.2.1.  Fixed Sender Domain Add-on 

In versions of Confirmit prior to version 11, users could activate the Fixed Sender Domain functionality without the 
add-on. From Confirmit version 11, users must have the add-on (go to The Company Details Page on page  for more 
information) to use this functionality. Any relevant settings that a company may have made in previous versions of 
Confirmit will no longer be accessible/available unless the add-on is licensed. If the Fixed Sender Domain add-on is 
licensed for version 11, then all previous settings will be reactivated. 

6.4.3.2.2.  Domain Keys Add-on 

In versions of Confirmit prior to version 11, users could activate the Domain Keys functionality without the add-on. 
From Confirmit version 11, users must have the add-on (go to The Company Details Page on page  for more 
information) to use this functionality. Any relevant settings that a company may have made in previous versions of 
Confirmit will no longer be accessible/available unless the add-on is licensed. If the Domain Keys add-on is licensed 
for version 11, then all previous settings will be reactivated. 

6.4.3.2.3. The Results of the Changes 

On-Premise clients without Premium Emailing - These clients will not be able to use the Fixed Sender Domain, 
Email Delivery Report, and Dedicated IP functionality after the Confirmit 11 upgrade. In addition, these users will not 
be able to use the Domain Keys functionality after the upgrade unless this is included in the license. 
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On-Premise clients with Premium Emailing - These clients must order a new license that includes the Fixed 
Sender Domain add-on. Confirmit will then activate the functionality. 

SaaS clients - These clients will have access to the Fixed Sender Domain and Email Delivery Report functionality as 
part of their existing license. 

6.4.4. Integration with Google Analytics 

Confirmit can make use of Google Analytics, a web analytical service provided by Google, Inc. (“Google”), to provide a 
tracking facility for Confirmit activity. Confirmit server page traffic is tracked for our own use-analysis (set at system 
configuration), and customer (your) survey page traffic can be tracked to enable you to analyze the use and 
effectiveness of your surveys (set at the Company Account page (go to Company Details Page Other Tab on page 66 
for more information)). 

Google Analytics uses “cookies”, which are text files placed on the respondent's computer, to help the user (Confirmit 
or you the customer) analyze how users use the site. The information generated by the cookie about the use of the 
website (including the user's IP address) will be transmitted to and stored by Google on servers in the United States. 
Google will use this information for the purpose of evaluating use of the pages served, compiling reports on activity for 
website operators, and providing other services relating to activity and Internet usage. Google may also transfer this 
information to third parties when required to do so by law, or when such third parties process the information on 
Google's behalf. Google will not associate the respondent's IP address with any other data held by Google. The 
respondent may refuse the use of cookies by selecting the appropriate settings on their browser, however it must be 
understood that if they do this some functionality may be restricted. 

By using the Confirmit system or by enabling Google Analytics tracking for your company, you consent to the 
processing of data about you by Google in the manner and for the purposes set out above. 

Note that if your company wishes to make use of the Google Analytics facility, your company must create its own 
Google Analytics Account. Once the account exists, enabling this feature will result in an asynchronous JavaScript 
code fragment being embedded on all pages of surveys launched within your company, all Community Portal pages 
and all published Reportal reports. Then, activating the account will cause data to be sent to Google, Inc. (“Google”). 
Enabling Google Analytics should not lead to any deterioration in performance or decreased user experience. 

The addition or removal of Google Analytics code will only take effect after surveys are launched or re-launched, and 
portals and reports are published. 

Google is outside of CONFIRMIT’s control, and CONFIRMIT explicitly disclaims any warranty of this feature. 
CONFIRMIT will provide support for this feature at CONFIRMIT’s discretion only. 

6.5.  Admin > Accounts > Overview 

This menu item provides you with an aggregated overview of all Confirmit licenses on the server: 



 
Confirmit Horizons 22  Administrator Guide Confirmit Confidential 

  

- 72 - 

 

Figure 69  The Account Overview overlay 



 
Confirmit Confidential Confirmit Horizons 22  Administrator Guide 

  

- 73 - 

7. Archiving 

Use this function for “house-keeping” on the server. Here you can define a set of rules such that for example after a 
preset number of days with no activity on a project, a warning will be sent to the owner (creator) informing them that 
the project will be archived on a certain date. The owner then has the chance to delete the project, define a new 
archiving date or place a “do not archive” flag on the project. 

When a project is archived, an email is sent to the project creator to inform him/her of the change, and the project is 
then soft-deleted. This means that the project still exists, but it is marked as "deleted". The project will then be deleted 
later by the Database clean-up task. Archiving emails can also be sent to a company contact if an email address is 
entered in the ‘Recipients of Archiving notification e-mails‘ text box in Company Settings in Confirmit Authoring. 

All business rules are processed before the actual archiving is performed. If a project does not fit the business rules, it 
is not included in the initial list and is not archived. 

Note: When a Reportal report is viewed, the date and time that it was accessed is stored. For the survey that 
the report is based on, the date/time value is checked when the survey is evaluated for archiving. This 
ensures that surveys which have active reports that have been viewed recently are not archived, irrespective 
of any interviewing activity. 

In addition, the following types of project do not appear in the archiving list, and are not archived: 

• Template 

• Library 

• Benchmark 

• Express Library 

Note: For multimode surveys, the multimode portion of the survey (CATI call queue, call history and CAPI 
productivity statistics etc...) will not be archived. These parts will just be deleted. 

Go to Home > Archiving to see a list of your projects that are scheduled for archiving (if you are the system 
administrator then you will see a list of all the jobs on the server that are scheduled for archiving) (go to Archiving List 
on page  for more information). 

The system administrator can restore surveys that have previously been archived (go to Restoring on page 78 for 
more information). Note that due to the practical challenges involved with testing new versions of Confirmit against 
innumerable old surveys, the Project Restore functionality is only supported for projects that have been launched in 
one of the latest three versions of Confirmit. It will normally be possible to restore older projects, but Confirmit cannot 
guarantee this. 

Note that project restoration will fail if the survey layout that was used has been deleted. 

7.1.  Archiving Option Setup 

1. Go to the Admin > Archiving Options menu command. 

The page shown below opens: 
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Figure 70  Example of the Archiving options page 

This page displays the parameters used by the Archiving task. 

• Delay days – an integer that will be added to the last active date for a project when calculating the project’s 
expiry-date. Once a project has had no activity for this number of days, the archiving routine will start. 

• Notification days – an integer that specifies how many days prior to a project’s expiry date a notification mail 
is to be sent. 

• Max number of completes – if an integer is added to the field, projects with more completes than the number 
specified will not be considered for archiving. That is, an expiry date will not be computed for the project. 

Notification messages regarding archiving projects will be sent to the e-mail addresses specified in the following fields 
in addition to the project creator. This enables management of archiving processes even if the person who created the 
project is unavailable or has left the company. 

• Notification message – type the message that is to be added to the notification e-mail that will be sent to the 
project’s owner. 
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• Archive success message – editing field for the Archive success message. This message is added to the 
email that is sent to the project creator when a project has been successfully archived. 

• Archive abort message – editing-field for the “Archive abort” message. The message is added to the email 
that is sent to the project creator, and to the System Administrator e-mail address, if an error occurs while 
archiving a project. 

• Cleanup Error message – editing-field for the “Cleanup Error” message. The message is added to the email 
that is sent to the project creator and other specified recipients if the deletion of project-data fails after a project 
is archived. 

• System Administrator Email – the email address to a System Administrator/project creator who is to receive 
an email if a project archiving process should fail. 

• Global Notification Email – an email address to which notifications and alerts about all archiving processes 
are to be sent. 

Note: If an email address is added here, this will override any other email addresses that are entered and no-
one else will receive an email. 

The following keywords are supported in the archiving notification emails: 

^CURRENTTIME^ 

^SITEID^ 

^INSTALLATIONID^ 

^TASKID^ 

Old keywords <-? 

^PROJECTNAME^ 

^PROJECTID^ 

^CREATOR^ 

^CREATED^ 

These keywords are substituted with actual values. 

2. Click Save to update the data-fields in the database. 

Note: The Confirmit server installation ID will be included in the emails that are sent from the archiving 
functionality. If archiving is running on more than one Confirmit site, the installation ID will indicate on which 
server the archived project is to be found. 

7.2.  Archiving List 

Go to Home > Archiving to display the archiving list. The list opens as shown in the example below 

 

Figure 71  Example of the Archiving list 

When you initially open the page, it lists the surveys that are due to expire in the next ‘n’ days (‘n’ being the number of 
“Notification days”). 
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To search for surveys, enter search criteria into the fields in the Search row, and click the Search button. The page 
will then be refreshed with surveys that match the criteria. The criteria will remain in the Search row until you delete 
them. 

To search for surveys that have been archived, change the value in the Archived selection box to Yes and click 
Search. 

A user who is defined as a System Administrator is able to view all surveys, while Survey Administrators can only view 
the surveys they administrate. System administrators can: 

• Update the Email Recipient field. This defaults to the email-address for the creator of the survey. 

• Update the Expiry Date User field. A survey that is created between two executions of the archiving task, will 
display no value in the Expiry Date System field. 

• Set/deselect the Never Expire option. This causes the expiry date for that survey to be cleared and no new 
expiry date will be calculated by the archiving task as long as the option is set. 

• Click Save to save any changes, update the survey information and refresh the page. The changes will be 
reflected in the survey list and the Survey archiving details area will be cleared. 

Survey administrators (for the selected survey) can: 

• Update the Email recipient field. This defaults to the email address for the creator of the survey. 

• Set/change the Expiry Date User field to override the expiry date that has been calculated by the system 
(Expiry Date System). Click the calendar icon and select a date, then click Save. 

• Set/deselect the Never Expire option. Click the down-arrow beside the field for the appropriate survey and 
select the desired setting, then click Save. 

Note: A system administrator can override changes made by a survey administrator. So if a survey 
administrator sets Never Expire, or sets an Expiry Date User that is some time ahead, a system administrator 
can if necessary change the Never Expire setting or change the Expiry Date User to force a project to be 
archived on an earlier date. 

Users with only “Read” permission for a survey will not see the survey listed on the Archiving page. 

7.3.  Archiving Task 

The archiving task is executed by Confirmit’s task system. 

Note: The Archiving task needs to compress the projects for archiving, and the zipping component uses a 
temporary folder on the C: drive. Make sure that the Batch server running the Archiving task has sufficient 
disk space on the C: drive. 

To view instances of the task and set the recurrence pattern for the task: 

1. Go to the Tasks page in Confirmit and click the Search tab. 

2. On the Search page, choose Archiving as the task type. 

3. Click Search. 

A list of instances is displayed. 

4. To start a new instance, go to the task-definition for one of the existing instances and start a new instance or 
set a recurrence-pattern. 

The batch server must be configured to run Archiving tasks: 
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Figure 72    Archiving task 

Only the System Administrator will be able to view instances of and administrate the archiving-task. The task will run 
through all projects that do not have the “Do not expire” flag set and for each project, one or more of the following 
processes will be run: 

• If the option “Max number of completes” is set and the project has more completes than the value, no expiry-
date will be calculated. 

• If a system administrator has not set the project’s expiry-date, a new expiry-date will be calculated. 

• If the expiry-date is within the number of notification-days, a notification email is sent. 

• If the project expires “today”, it will be archived and an email will be sent to the email recipient for the project. 

• If a project has its expiry-date calculated for the first time and the date is “today” or less than “today”, then the 
project will not be archived immediately. The expiry-date will be set to the current date extended by the 
number of notification days, and a notification email will be sent. If a user does nothing to the expiry-date, the 
project will be archived on the expiry-date set. 

Note: All business rules are processed before the actual archiving is performed. If a project does not fit the 
business rules, it is not included in the initial list and is not archived. 

Important 
Archiving is not performed for open multimode projects. If a project has the "CATI survey" checkbox checked 
in its Survey Settings, it will only be included in an archiving list if the project is closed on the CATI side. If it 
is not closed, or if it is closed on the Confirmit core side, it will not be archived. 

7.4.  Start Task 

The administrator can run an archiving task as required. 

1. On the Admin > Archiving Options page, click the Start Task button. 

The Archiving Properties dialog opens. 
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Figure 73  Example of the Archiving Options dialog 

2. Make the settings as necessary. 

• Project Types - select the type of project you wish to archive. 

• Project Company - using standard Windows selection techniques, select the company or companies that you 
wish to conduct the archiving operation for. 

• Project Created - if you wish to archive only projects created relative to a specific date, select the date and 
operator here. 

• Delay Days - allows you to tune a recurring archiving task. 

• Comment - add a comment as necessary. 

• Start Time - select ASAP or Schedule for later execution as required. 

3. Click OK. 

7.5.  Restoring 

You can restore archived projects which are soft-deleted (Database cleanup has not been run after the archiving 
operation), or hard-deleted (Database cleanup has been run after the archiving operation). 

Note: The Restore functionality must be configured on the server before it will be available for use. 

The procedure is the same for both operations: 

1. Go to the Home > Archive menu item. 

2. Set Archived = "Yes" and click Search. 

3. Click the Restore link by the project. 

The Restore archived project confirmation dialog appears. 

4. Click OK. 
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When a project has been restored, the "Owner" of the project will be set to the original owner if that user still exists, 
or the restoring user in the event the original owner is no longer registered in the company. A restored project will 
belong to the Original company. 

In the event of an error occurring during a restore task, the task will roll-back. The roll-back will delete the restored 
survey and clear disk space of any temporary files which were created during the restore operation. 

Note: Due to the practical challenges involved with testing new versions of Confirmit against innumerable old 
surveys, the Project Restore functionality is only supported for projects that have been launched in one of 
the latest three versions of Confirmit. It will normally be possible to restore older projects, but Confirmit 
cannot guarantee this. 

7.6.  Additional Storage Space 

Confirmit Horizons v18 introduces a number of new features that require additional storage on the SaaS Service. In 
relation to those new features, each client is granted the following data storage levels at no additional cost: 

• 5GB for multimedia file storage. 

• 10GB for SmartHub storage (SmartHub is to be release in Q2 2014). 

Your company should regularly verify the volumes of storage used, via the Software and / or logs provided to you, and 
should delete any data and files that are not needed so that the storage required is kept to a minimum. Note that if 
your company exceeds the allocated levels of storage, your company will be required to sign up for additional storage 
for the remainder of the current license period, at applicable fees. 

7.7.  Archiving Questions and Answers 

This information is also available (edited as appropriate) in the Authoring User Guide. Below are some common 
questions regarding archiving, and the appropriate answers: 

• What does archiving mean for you? 

Surveys that have been inactive (no editing or respondent activity) for 60 days on the Confirmit SaaS site will 
be archived. Survey creators will receive an email notification 30 days prior to the archiving procedure, and 
thus have the possibility to either set a new Archiving date (Expiry Date User) or set the survey to Never 
Expire on the Archiving page in Confirmit (Home > Archiving menu), which means that the survey will never 
be archived. Survey creators will also receive a confirmation email when the survey has been archived. 

If you receive an Archiving email notification for a survey that you do not need to keep for the future, we 
suggest you delete the survey before it is archived. 

If the survey creator is no longer employed in the company, to avoid notifications being missed there is a 
'Recipients of Archiving notification e-mails' field in Confirmit. The address(es) specified in this field will receive 
all archive emails (both notification and archive success messages). Your company's Designated Support 
Contact(s) will be added to this field by us. Confirmit Software Company Administrators can update this field 
with other email addresses. 

Surveys that have been archived can easily be restored via a 'Restore' link on the Archiving page. 

• What is included when my survey is archived? 

The survey’s archive package includes survey definition and SQL database. Reports are not archived. 

• Are reports ever archived? 

No. The survey’s archive package includes survey definition and SQL database. 

• What happens to a report when the survey (datasource) is archived? 

Reports are not archived. The project’s archive package includes the survey definition and the SQL database. 
What happens to a report depends on whether the report has single or multiple datasources: 

o If the Database Cleanup task is enabled, a report with a single datasource is soft-deleted X days (system 
setting: DaysToKeepSurveyDatabasesForDeletedProjects) after the survey is archived. Soft-deleted 
reports can be restored from the Home > Deleted Reports page in Reportal. If the cleanup task is not 
enabled then reports for archived projects will not be deleted. 
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o A report with multiple datasources will not be deleted. 

Confirmit recommends using the Export > Export Report Definition functionality in Reportal if you need to 
keep the Report Definition for a report connected to a project which is going to be archived. 

• What if I no longer need the survey? 

Delete surveys that do not need to be archived. You can do this from your Survey List. If you do not delete, the 
survey will still take up storage capacity even after it is archived. 

• Why are so many emails sent? 

Every survey will get one archiving notification email, and an email when it is archived. Upon activation of 
archiving, a number of emails will be sent at the same time. Thereafter you will only get email whenever a 
survey meets the criteria for archiving. 

• Who receives Archiving notification emails? 

The Survey creator, and email recipient(s) defined in Confirmit Company settings (“Recipients of Archiving 
notification e-mails” on the Other tab) 

• When I receive an Archiving notification email, must I take any action? 

Your surveys will not be archived if they are active, so in that case no action is required. “Active” is defined 
below. 

• I don’t want my survey to be archived, what must I do? 

Set your survey to “Never expire” in the Archiving section in Confirmit. Surveys with categories Template, 
Benchmark or Library will never be archived. 

• Why did I get an Archiving notification for my active survey? 

Your survey was marked for archiving as it did not have any activity (as defined below) within the last X days 
(Delay Days). The notification will be sent X days (Notification Days) before archiving. 

• I just received an Archiving notification email. When will my survey be archived? 

If your survey receives no further activity (survey responses) it will be archived X days (Notification Days) after 
you received the notification. Note that if activity is registered for a survey, the System Expiry date will be reset 
and moved forward by X days (Delay Days). 

• What is an active survey? 

Activity on a survey consists of respondent activity such as Completes, Incompletes and Screened within the 
last X days (Delay Days). Surveys with active reports (defined below) or that have had data imported through 
rules or custom applications within the last X days (Delay Days) are also considered active. Surveys with 
recurring tasks will be archived. 

• What is an active Report? 

An active report is a report that has been viewed in the last X days (Delay Days). The "last viewed" timestamp 
will be updated when the report is opened in view mode by any user. This includes surveys used in multi data-
source reports. 

• What happens when a panel-linked survey is archived? 

A member of a panel will have a list of "surveys yet not taken" available to him from the survey overview page. 
When the survey is archived, the survey will be hidden from the survey overview page. 

• How do I restore an Archived survey / un-archive a survey? 

Go to the Archiving section in Confirmit, filter to show Archived surveys, find your Archived survey and click 
Restore. 

• For how long can I restore my survey after it's been archived? 

Archived surveys are retained on disk until permanently deleted by system administrators. 



 
Confirmit Confidential Confirmit Horizons 22  Administrator Guide 

  

- 81 - 

 Note: Due to the practical challenges involved with testing new versions of Confirmit against old surveys, the 
Project Restore functionality is only supported for surveys that have been launched in one of the latest three 
versions of Confirmit. It will normally be possible to restore older surveys, but Confirmit cannot guarantee 
this. 
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8.  Admin > News Update 

Go to the Admin > News Update menu command to open the Confirmit News window. Use this window to enter, edit 
and delete the news items announced on the Main page and the announcements on the Login page. 

You can search for news texts by the various columns. Click on the down-arrows beside the column headers and 
select from the options available, then click the Search button. 

 

Figure 74  Example of the News Update window 

To view a news item, right-click on the blue Title link to open the drop-down menu, then select View News Item. A 
viewing window opens. 

To edit a news item, right-click on the blue Title link to open the drop-down menu, then select Edit News Item, or just 
click on the link. An editing window opens (go to How to Add a News Item on page 82 for more information). 

The "Date of last email sent" column contains either 'Never' if the news item has never been sent via email, or the 
date/time it was last sent. 

To send a news item via email, click on the 'Never' link (or the date/time) for the new item. This displays an overlay 
previewing what will be sent to the subscribed users. Note that the news item cannot be edited from this preview. 
Clicking Send news via email will create a new task that will send the email to all subscribed users. A confirmation 
dialog appears and must be confirmed before the task is initiated. 

It is possible to send emails to active and non-active news items. It is possible to send the same news item multiple 
times, and every time it will be sent to ALL subscribed users. 

8.1.  How to Add a News Item 

1. Click the Add News button located towards the right end of the window toolbar. 

The Add News Item window opens as shown in the figure below. 
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Figure 75  The Add News Item window 

2. Fill in the details as required. 

When creating an interactive news item, the important fields are Title, HTML Ingress and HTML Body as these 
will form the news item. The two Text… fields are only used in conjunction with the HTML fields when the 
news item is emailed, to ensure that a multi-part email is sent out. 

• Active – check to make the news item visible to ordinary Confirmit users. 

• Display on Login – check to place the message on the Confirmit Login page. 

• Sticky – check if you wish to preserved the news item on the front page even when more recent news items 
are added. 

• Type - select the type of item you wish to display. 

o IM - Instant Message - when this type of news item is created, an overlay is displayed automatically at the 
given date/time (additional fields appear when IM is selected) to all users who are logged into the system. 
This type of message could be useful if for example you need to tell users "The system will be reset in 5 
minutes". You can also select whether the message is to be sent only to Authoring users, only to Reportal 
users, or to both - check the appropriate boxes. 

o News Item - a "standard" news item. News items can be set as IM and regular news simultaneously, so they 
will be displayed as IM and will also show up on the front page in the News section afterwards. 

o Title – the title of the news item. 

o Ingress – a summary of the news item. This can be written as HTML text or as plain text. 

o Body – the main text for the news item. This can be written as HTML text or as plain text. 

3. Click Save or Save and Close the save the changes and publish the news message. 

4. Click Close Window to close the window and return to the Confirmit News page. 

To delete a news text, check the box to the left of the news title and click Delete at the top of the list. 
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Note: There is a limit of 5000 characters per news text item. 
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9.  Admin > System Configuration 

Refer to the Confirmit Server Manual for information about configuring the system. 

As a System Administrator, you can view the current installed license and you can install a new site wide license (go 
to The License Tab on page 85 for more information). 

9.1.  The License Tab 

As a System Administrator, you can view the current installed license and you can install a new site wide license. Go 
to the System Configuration menu > License tab. 

 

Figure 76  The License tab 

Click the View License link to open the View License overlay. This gives you an overview of all the details. 
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Figure 77  The View License overlay 

Click the Install License link to open the installation overlay. 

 

Figure 78  The Install License overlay 

Browse to and select the license file, then click Install License. 

The license is validated before it is installed, so it is not possible to install an invalid license. The installed license is 
displayed after it has been installed. 

You can also validate a new license before it is installed. The differences between the installed license and the new 
license are highlighted. 
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10.  Admin > Projects 

The Admin > Projects menu contains four items: 

• Custom fields. 

• Project Info Report. 

• Project Log. 

• BitStream Server Configuration. 

10.1.  Admin > Projects > Custom Fields 

You can add Custom fields for better project classification. The fields can be Required or Optional. Required custom 
fields must be chosen specifically for each project. 

• Go to Admin > Projects > Custom Fields. 

The Custom Fields list opens. This list may be empty, or if some custom fields have been defined previously, 
they will be listed here. 

 

Figure 79  Custom fields list, empty 

10.1.1.  How to Create a New Custom Field 

1. In the Custom Fields list, click New. 

The Manage Custom Fields page opens. 

  

 

Figure 80  Custom fields management 
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2. Define the specifications of the new custom field. 

The fields marked with the red asterisk are required fields. The fields are as follows: 

o ID – enter the ID name or number of the custom field. 

o Name – enter the name or a short description of the custom field. 

o Required – select this box if the new custom field is to be a required field in each project. 

o Type – select between Open-Text and Drop-down. If you specify the custom field type to be Drop-down, you 
must then define the options that are to be shown in the drop-down list (see the figure below for an 
example). 

o Options – is displayed when Type is set to Drop-down. Use this field to define the options that are to be 
included in the drop-down list. 

o Length – This field is displayed and made required if you have specified Type to be Open-Text. Specify the 
maximum number of characters that can be written into this field in the Project Management > Overview 
page. 

 

Figure 81  Example of a custom field type drop-down list 

3. Click Save to save the changes. 

When a new custom field has been created, it will be displayed in the custom field list. 

10.1.2.  How to Add a New Option to the List 

1. Click the New button or press the down-arrow key on your keyboard. 

A new row is added to the list. 

2. Type in the appropriate text for the option. 

3. Click Save to save the changes. 

10.1.3.  How to Delete an Option from the List 

1. Click in the check box beside the option you wish to delete. 

2. Click the Delete button. 
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The custom fields are displayed in the Project Overview page. Only a user with Administration permissions to 
the project will be able to see the custom fields. 

 

Figure 82  Custom fields in the Project Overview window 

10.1.4.  Administrator Project Overview 

The Software Administrator and users with Administrator permissions to a project will have the following frames and 
fields on the Project overview page in addition to the Project Details frame (go to Code Check on page 2 for more 
information): 

 

Figure 83  Project info fields 
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Figure 84  Administrator information 

 

Figure 85  Growth information 

The fields are as follows: 

• Start date - Info field describing the start date of a survey. 

• End date - Info field describing the end date of a survey (Note: Will not close the survey automatically.) 

• Complete responses - Number of complete responses in the survey. 

• Incomplete responses - Number of incomplete responses in the survey. 

• DB server name - Name of the DB server where the project DB is located if multi server installation. 

• Size of database data - Current size of database data. 

• Size of database log - Current size of database log. 
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• Questionnaire last modified - Last time the questionnaire was modified. 

• WI last generated - Last time the web interview was generated. 

• DB last generated - Last time the database was generated. 

• Last response - Last time a respondent accessed an element in the survey. 

• Reporting last accessed - Last time someone accessed the online reporting module. 

• Project info last updated - The last time all the project admin info fields were updated. 

• Data growth last day - Growth in database data size during the last day. 

• Log growth last day - Growth in database log size during the last day. 

• Data growth last week - Growth in database data size during the last week (7 days). 

• Log growth last week - Growth in database log size during the last week (7 days). 

• Data growth last month - Growth in database data size during the last month (same day last month). 

• Log growth last month - Growth in database log size during the last month (same day last month). 

• Custom fields (if defined) - All defined custom fields. 

• Refresh - Click to update all the administrator information above. 

• From date - Use to specify the from date when checking the growth within a specified range. 

• To date - Use to specify the to date when checking the growth within a specified range. 

• Data size - The calculated database data growth from the range specified above. 

• Log size - The calculated database log growth from the range specified above. 

• # Complete - The calculated growth in complete responses from the range specified above. 

• # Incomplete - The calculated growth in incomplete responses from the range specified above. 

• Calculate - Perform the calculation and display the results on the page. 

• Recurring tasks - A link to the recurring tasks for this project, if there are any. 

10.2.  Admin > Projects > Project Info Report 

You can search for specific projects under Admin > Projects > Project Info Report. On this page you can perform a 
search by entering search criteria in one or more columns. 

Click Expand Report to open the full report. 

 

Figure 86  Project search page 

The columns are as follows: 

• Project ID - Search by specific project ID number. 
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• Project name - Search by specific project name. 

• Languages - Search by project languages. 

• Administrators - Search by project administrator names. 

• Description - Search by text in project description. 

• Company - Search by company name. 

• Creator - Search by project creator name. 

• Status - Search for either Closed projects or projects in Production. 

• Deleted - Search for projects that either have been deleted or have not been deleted. 

• # Completes - Numeric field: search by a specific number of complete responses. 

• # Incompletes - Numeric field: search by a specific number of incomplete responses. 

• DB data size - Search by database data size. 

• DB log size - Search by database log size. 

• Date - Search by dates for specific actions, for example Created, project Start date, End date, last WI 
generation, etc. 

• Custom fields (here: Department) - Search by specific custom fields. 

Enter the appropriate search criteria and click Search. Any projects matching the criteria will then be listed. Click 
Reset to delete all search criteria and re-display the full list. 

10.2.1.  How to Order a Report 

1. Click the Order Report button. 

The Export Properties dialog opens. 

2. Check that the email address to which the report is to be sent is correct. 

3. Add any comments to the Comments field. 

4. Select the desired Start Time. If you will have the report sent later, set the appropriate date and time. 

5. Click OK. 

 

Figure 87  Search result to be sent by email 
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You can order the task “as soon as possible” or set it up as a Recurring task. 

10.2.2.  Project Info Collector 

To ensure the data you receive when ordering a Project Info Export is always up-to-date, start the Project Info 
Collector task. This is a batch task that is set up to run at least once every 24 hours. Project Info Collector gathers 
data for all projects on the server. This information can then be ordered via the Project Info Export. If you want to view 
project information for a particular project only, go to the Project Overview page and click the Refresh button under 
the Administrator Info field. 

After the task has been initiated by your server administrator, it will be located under Tasks. You can then change the 
recurrence pattern at any time. 

To run the collector, go to the Admin > Projects > Project Info Collector menu item. 

 

Figure 88  Project info collector / exporter tasks 

The batch server should also be configured to run Project Info Collector tasks. 

10.3.  Admin > Projects > Project Log 

All projects created on the server are listed with Userid, Project id, and the Date when they were created. 

10.4. Admin > Projects > BitStream Server Configuration 

If your site has multiple BitStream servers, you can specify that a particular project will exist on several BitStream 
servers and that when requests are made for data for this project, a load-balancing approach (e.g. round robin) is 
taken to distribute the load. 

1. Go to the Admin > Projects > BitStream Server Configuration menu command. 

The configuration page opens. 

 

Figure 89  Example of the BitStream Server Configuration page 

The available servers are listed towards the right side of the page. 
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2. For each project that you wish to specify the server(s) for, check the boxes for the server(s) you wish to be 
used. 

3. Save your changes. 

Note that in the event the list of projects is extensive, you can enter search criteria into the column header fields and 
click Search to reduce the list. 

Important 
If a report uses several projects / data sources, the assigned BitStream servers are not the same for all 
projects, and there is a union done between the data sources, then the BitStream files should either: 
- Not be load balanced 
- Be load balanced onto the same BitStream servers 

You can also select one or more projects and trigger BitStream update tasks. This function is a shortcut to updating 
multiple projects in one go, and can be useful for example when moving projects from one server to another in order 
to generate files on the new server. 

• Select the projects you wish to update by clicking in the boxes in the left column of the list, then click Update 
and Synchronize BitStream Files. 

Note that the “force new” option is not available here. 
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11.  Admin > Feature Toggling 

For installations that are on continuous delivery, it is possible to enable new features that either have not yet been 
officially released (they are still in Beta version), or that have been released for customers on SaaS/continuous 
deployment only. This capability is controlled by a server add-on, so requires an updated license that includes the 
ability to control feature toggles. 

All such features are by default toggled off. Feature toggles can be enabled for specific users, or for the entire system 
(thereby becoming available for all users on that system), and are grouped under different product areas such as 
Reporting, Authoring, SmartHub etc. The specific toggles that are available at any time will vary depending on 
development. 

To administrate feature toggles for a server environment, you must be a system administrator or have the 
“SYSTEM_FEATURE_TOGGLE_ADMIN” permission. 

Go to the Admin > Feature Toggling menu item and select whether you wish to administrate the users or the entire 
system. 

11.1.  Assigning Features 

To toggle a particular feature on for a user: 

1. Go to the Admin > Feature Toggling > Users menu command. 

The Users with features assigned page opens. 

 

Figure 90  The Users with features assigned page 

This page lists all the users who have features toggled on for them, with up to 50 users presented per page. 
Use the pagination buttons in the lower-right corner of the page to move between pages. Each feature is listed 
separately for each user, so a user will have a row in the list for each feature that is toggled on for that user. 
The Area column indicates to which application area the feature applies. The letter buttons across the bottom 
of the page apply to the User ID; click a letter to show only those User IDs that start with the selected letter. 
Use the search and sort functionality to find a particular user, company or feature name; the Area column has 
a drop-down list of the areas.  

2. Click Assign features to users in the upper-right corner of the page. 

The Assign features to users overlay opens. 
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Figure 91  The Assign features to users overlay 

3. Towards the top of the overlay, select the Area to which the feature you wish to activate is associated. 

The features associated with the selected areas are listed. The number of features available and the number 
you have selected are indicated below the field. 

4. Browse to and select the feature(s) you wish to activate for the user(s) you will be selecting. 

5. In the event you have admin access for more than one company, select the company with the user you wish to 
work with. 

All the users registered in the selected company are listed. 

6. Browse to and select from the list the users you wish to activate the selected features for, or add users 
manually to the list. 

7. Click Assign features to selected users to complete the procedure. 

The overlay closes and the selected users are added to the list with the selected features activated. 

11.2.  Revoking Features 

If a user no longer needs a feature to be toggled on, access can be revoked. 

1. Go to the Admin > Feature Toggling > Users menu command. 

The Users with features assigned page opens. 

2.  Search/browse to and select the user you wish to revoke the feature for. 
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Note that the user may have more than one feature toggled on, so ensure you select the appropriate instance. 

3. Click Revoke features in the upper-right corner of the page. 

A confirmation dialog opens. 

4. Click OK to complete the revocation procedure, or Cancel to abort. 

Note that when a feature has become so "mature" that it is to be made available as part of a "Frozen" release, it will 
be removed from the list of feature toggles that can be assigned to users or systems. The feature will however not be 
automatically removed from the list of assigned feature toggles. While this will make no difference to the system 
functionality, it may be inconvenient to have out-of-date feature toggles in the list. In this case, you can remove it 
manually by revoking it from all users in the list. To do this: 

1. Search for all instances of the Feature Name. 

2. Select all users assigned the feature (check the box at the top of the checkbox column). 

3. Revoke the feature. 

11.3.  Toggling Features for the Entire System 

Admin users with the appropriate permission can toggle features for an entire server installation. All users registered 
to the system will then have access to the functionality under the feature toggle. To administrate feature toggles for a 
server environment, you must be a system administrator or have the “SYSTEM_FEATURE_TOGGLE_ADMIN” 
permission. 

1. Go to the Admin > Feature Toggling > System menu command. 

The 'Features granted to all users in the system' page opens. 

 

Figure 92  The Features granted to all users in the system page 

All the features currently granted to the users in the system are listed. 

2. Click Add system features in the upper-right corner of the page. 

The Add system features overlay opens. 
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Figure 93  The Add system features overlay 

3. Towards the top of the overlay, select the Area to which the feature you wish to activate is associated. 

The features associated with the selected areas are listed. The number of features available and the number 
you have selected are indicated below the field. 

4. Browse to and select the feature(s) you wish to activate for the users in the system. 

5. Click Add system features. 

The overlay closes and the features are added to the list on the Features granted... page. 

To revoke features for the system, select the feature(s) you wish to revoke and click Revoke features in the upper-
right corner of the page, then confirm the revocation. 
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12.  Admin > Languages and Messages 

Note: Any changes you make to the parameters available here are global – that is, everyone who logs onto 
the server can see and use them! 

12.1.  Admin > Languages and Messages > Primary Languages 

This window lists the primary languages registered in Confirmit, in alphabetical order. An identity code and a character 
set are specified for each primary language. 

Note: The character set used for the languages may influence how the survey is displayed to the respondents 
in their browsers. The browsers also use a character set; in Internet Explorer this is selected under View > 
Encoding. If respondents have problems reading the survey, the reason may be that different character sets 
are used in the survey (Confirmit) and in their browser. 

 

Figure 94  The Primary Language window 

You can add new languages if necessary. 
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Note: Any changes you make to the parameters available here are global – that is, everyone who logs onto 
the server can see and use them! 

12.1.1.  How to Add a New Primary Language 

1. Go to the Admin > Languages and Messages > Primary Languages menu command. 

The Primary Languages window opens. 

2. Click New Primary Language. 

The New Primary Language overlay opens. 

 

Figure 95  The New Primary Language overlay 

3. Add information and make the selections as appropriate. 

4. Open the drop-down and select a character set to be used. 

5. Check the RTL box if you want the user to be able to read the page from right to left (for example if the survey 
language is Arabic). 

6. Click Save or Save and Close to save the changes. 

Note: Once you have saved the changes you will need to go to the Deploy Language Info and Messages menu 
command to deploy the changes onto the server (go to Admin > Languages and Messages > Deploy 
Language Info and Messages on page  for more information). 

12.2.  Admin > Languages and Messages > Sublanguages 

This window lists all sub-languages (if any) for the primary languages. When you add a new sub-language, you must 
choose the primary language first. This means that the primary language must exist in the Primary Language list. 
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Figure 96  The Languages window 

12.2.1.  How to Add a New Sub-Language 

Note: Any changes you make to the parameters available here are global – that is, everyone who logs onto 
the server can see and use them! 

1. Go to the Admin > Languages and Messages > Sublanguages menu command. 

The Sub Languages window opens. 

2. Click the New Sub Languages button in the upper-right corner of the window. 

3. The New Sub Language overlay opens. 

 

Figure 97  The New Sub Language overlay 

4. In the drop-down, select the Primary Language to which you wish to add the sub-language. 

5. In the open fields, enter the language names and Identity code. 

6. Select the character set the language uses, and check the box if the language is read right-to-left. 
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7. Click Saveor Save and Close to save the changes. 

Note: Once you have saved the changes you will need to go to the Deploy Language info and Messages menu 
command to deploy the changes onto the server (go to Admin > Languages and Messages > Deploy 
Language Info and Messages on page  for more information). 

12.3.  Admin > Languages and Messages > Survey Messages 

Confirmit contains a large number of texts and messages of different types; for example the message that appears 
when a respondent forgets to answer a required question, the message that is displayed to a respondent when a 
survey is closed, the text displayed on the Cancel button etc. These texts and messages are already translated into a 
number of "standard" languages, and the user can specify that any of these languages are to be used by a project. 
For other languages, error messages will default to the main language. For example: if Venezuelan Spanish is the 
selected language, then the messages will be translated into Spanish. If a language is not available, the error 
messages will be displayed in English, this being the default language overall 

However you may wish to have the messages displayed in a language that Confirmit does not provide as standard. Or 
perhaps you wish to change some of the texts and messages to suit your company, a particular survey or dialect. 

Confirmit provides three levels of "message editing" functionality: 

• Site-wide - available to the Site Administrator via the Admin > Languages and Messages > Survey 
Messages menu command. This level is described in this Administrator Manual. 

• Company level - available to the Company administrator via the Home menu command. This level is 
described in this Administrator Manual. 

• Project level - available to the project supervisor via the Project Management > Survey Messages menu 
command. This level is described in the Authoring User Guide. 

Note: Messages edited at the Project level override any edited at the Company or Site level. 

Note: If a project containing edited message texts is duplicated, the edited message texts will be included in 
the new project. 

Under this menu item you can edit and translate all messages in Confirmit. You may change the translations provided 
by Confirmit by entering your desired translation in the Edit Local Text field. If you enter any text into this field and 
save it, then the text you have entered will replace that in the Current Text field and will be the text the respondent will 
see when that language is selected. 

The primary languages and sub-languages are arranged in a hierarchy. For example, where French is the primary 
language, a sub-language is Canadian French. If no translated text has been entered for a message for Canadian 
French, then the French text is automatically displayed. If the messages have not been translated into the primary 
language (in this case French), then the English text is displayed to the respondents. 

Note: Once you have saved the changes you will need to go to the Deploy Language info and Messages menu 
command to deploy the changes onto the server (go to Admin > Languages and Messages > Deploy 
Language Info and Messages on page  for more information). 

12.3.1.  How to Edit the Text of a Message 

To edit a message: 

1. Site-wide: Go to the Admin > Languages and Messages > Survey Messages menu command. 

Or 

Company-wide: Go to the Home > Company > Survey Messages menu command. 

The Site/Company Specific Survey Messages form opens. 



 
Confirmit Confidential Confirmit Horizons 22  Administrator Guide 

  

- 103 - 

 

Figure 98  The Survey Messages form 

2. To find a particular message, click the down-arrow beside the Go to field and browse to the required 
message. 

The messages are listed in logical groups; for example Standard - General, Standard - Login, Error - Numeric, 
etc. 

3. If the project is available in several languages, select the message language you wish to edit. 

For example, if the project is available in English and French, you can edit just the messages that will appear 
for English-language projects, just the messages that will appear for French-language projects, or both. 

4. Edit the message text as appropriate. 

 

Figure 99  Editing a message text 
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5. Click Save to save the changes. 

The text you have typed into the Edit Local Text field will be moved up to the Current Text field. You must now deploy 
the changes (go to Admin > Languages and Messages > Deploy Language Info and Messages on page 104 for more 
information). The text will then be entered into the system, and will be displayed to the respondent instead of the 
original text supplied by Confirmit if/when the appropriate situation arises. 

Note: If the project is duplicated, any edited message texts will be included in the new project. 

12.4.  Admin > Languages and Messages > Deploy Language Info and 
Messages 

Any changes to the language parameters, for example the addition of a new sub-language, must be compiled and 
published on the servers before they can be used. 

Note: Once changes have been compiled and published they are available for all! 

To compile and deploy the changes: 

1. Go to the Admin > Languages and Messages > Deploy Language Info and Messages menu command. 

An overlay appears with a Deploy button. 

2. Click the Deploy button. 

The deployment task starts and a progress pane opens. On completion an information message is displayed. 
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13. Admin > Multimode 

The multimode component is used both for CATI capabilities and CAPI productivity. This means that there are two 
systems that need to communicate with each other. All communication between the two systems is channeled through 
a queue (specific for the company), and if a problem arises with the communication (perhaps there is an error in one 
task or a loss of communication), processing of the queue stops for that company. However the system then keeps 
track of all subsequent messages in the Sync Log. So while there are no problems, the Sync Log for the company will 
be empty. 

If a problem arises with a task then subsequent tasks for that company will be queued and the log list will start to build 
up. In most cases the item at the top of the list will have an error associated with it. You can react to this message and 
repair the fault, or you can delete the problem task from the queue. If you repair the fault or delete the task it will clear 
the problem, and you can then restart the synchronization process and any tasks in the list will eventually be cleared. 
Assuming you are successful, the communication should then proceed as normal. 

An example of the type of error message that will appear in the event a problem arises is shown in the figure below. 

 

Figure 100  Example of the type of error message that will be displayed in the event of a synchronization problem 

If this error appears, then the administration personnel must investigate the problem. 

The menu contains the following sub-menu: 

• Synchronize - displays a list of the tasks that are queued, and allows you to synchronize any queued items 
for selected or all companies. 

13.1.  Synchronization Log 

If there is a problem with the queue, then the queue processing will stop and users will be shown a warning when they 
attempt to perform tasks that require this queue, for example launching a CATI-enabled survey (the CATI part will not 
be loaded) or loading CATI respondent data. The Synchronization Log page then lists any items that are waiting to be 
synchronized. The log contains a description of the items, and you can sort and search in the list. Note that while 
there are no problems, the list will be empty. 

If you have the SYSTEM_ADMINISTRATE or ProS access permission you will see a company selection field in the 
upper-right corner of the page. The drop-down list will include any companies to which you have access, that have 
tasks in the log queue (go to Restarting the Synchronization Process on page 106 for more information). 

In most cases the oldest item in the log page list will contain the cause of the problem, and this item will usually have 
an associated error message indicating the cause. You then have two options: 

1. Analyze the error message, repair the fault and re-start the synchronization process. 

2. Delete the item containing the error and re-start the synchronization process. 
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Figure 101  Example of the Synchronization Log page 

13.2.  Restarting the Synchronization Process 

To restart the synchronization process: 

1. Go to the Admin > Multimode > Synchronize menu command. 

The Synchronization Log page opens (go to Synchronization Log on page 105 for more information). 

2. As required, click the down-arrow beside the Synchronize Company field located towards the upper-right 
corner of the page to open a drop-down list of the companies whose tasks have been logged, and select the 
company you wish to restart the synchronization process for. 

Note that you can leave All selected to restart the process for all companies in the list. 

 

Figure 102  The Synchronize Company button and field 

3. Click Synchronize Company. 

Assuming you have cleared the fault that originally caused the process to stop, the process should now re-start and 
the items in the log should clear for the selected company. 
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14. Admin > Default Survey Settings 

Default Survey Settings templates can be created for the site, at the company level, or for individual users. Then for 
example, if the same settings are used for all surveys created by your company, the users will not have to go in and 
set them up for every survey. 

It is possible to have one site-wide template, one company template, and one user template per user. Once a 
template exists, the Use default survey settings button becomes available in the Survey Settings page toolbar - click 
the button to use the template. By default, the User Settings template will be used if one exists, otherwise the 
Company or Site-wide template will be used in that order. 

The users can specify if they wish to use your personal survey settings (user template) on the project wizard page 
when they are creating the project. 

The Survey Settings Template page contains the same tabs and properties as the "standard" Survey Settings page 
inside a project. Note that if a project is based on a project template then no survey settings template is applied. 

The settings in a survey settings template are applied to a project when the project is first created. The template is not 
linked to the project, so once the project exists, the template settings can be changed and the project will not be 
affected. Survey settings templates do not apply to Basic panels. 
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15. Admin > Flex Extensions 

Go to the Admin > Flex Extensions menu command to open the Extensions Overview page. This page lists the 
extensions that are available to your company, and allows you to create new and edit existing extensions. 

 

Figure 103  Example of the Extensions Overview page with available extensions listed 

The list columns are as follows: 

• ID - the id number for the extension. This number is generated automatically when the extension is created 
and cannot be changed. 

• Name - the name of the survey. Click the link to open the Extension Details page for that extension (go to The 
Extension Details Page on page 108 for more information). 

• Contact - the person responsible for the extension. 

• Status - the current status of the extension. 

• Checkbox columns - the boxes are checked if the Extension Details page has information in the appropriate 
fields (go to The Extension Details Page on page 108 for more information). 

Note: There is a limit on the number of extensions that can be registered for a site. This limit is determined 
inside Confirmit's license files. When the limit is reached, administrators will not be able to register new 
extensions in the Admin > Flex Extensions page. 

You can find out which projects by the current company are using a particular extension (go to The In Use Link on 
page 111 for more information), and you can find out which extensions are being used by a particular company. 

15.1. The Extension Details Page 

Click on a Name link in the Flex Extensions Overview page to open the Extension Details page for that extension. 
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Figure 104  Example of the Extension Details page for an extension 

This page is where you set up the various URLs to call the extension when required. The fields and buttons on this 
page are as follows: 

• Validate URLs - click this button to run a check of the URLs that have been entered on the page. 

• ID - the ID number for the extension. This number is allocated automatically when the extension is created and 
cannot be changed. 

• Name - the name of the extension. This is the name that will be displayed in the various Confirmit windows. It 
may be different from the actual name or title of the extension application. 

• Consumer key - the Extensibility SDK uses Oauth (http://oauth.net/) to authorize Extensions to appear within 
Confirmit and to access specific REST web services that are part of the Extensions SDK. The Consumer Key 
and Consumer Secret are generated when an extension is registered in Confirmit. 

• Consumer Secret - this code is created automatically when the extension is registered with Confirmit - see 
also above. 

• Status - the current status for the extension. The options are: 

o Disabled - the extension is not available for use. 

o Development - the extension is under development, and will only be available for the user specified as the 
"Contact Person". This will allow the developer to test the Extension in a survey without others being able 
to access or use it. 

o Production - the extension is complete and may be used in production surveys. 

• Project tab - the URL to a configuration page for the extension that will appear on a tab in the Project 
Overview page (see also the Confirmit Authoring User Guide). 

• Survey start - the URL to be called whenever the survey is entered by a respondent.  

• Survey page complete - the URL specified here will be called every time the respondent completes a page in 
the survey. This could be used for example to log the time a respondent uses to answer the questions as part 
of a fraud detection program. 

• Survey frontend - the URL to an alternative renderer for survey pages (for example, specific to iPhones). 
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• User Agent - if you wish respondents using specific browsers to be automatically redirected to the survey 
frontend extension (specified in the Survey Frontend field) then you must specify a value (regular expression) 
in the User Agent field. For example, if you want iPhone and iPod users to be automatically redirected to the 
extension URL, then you can specify the value Apple.*Mobile.*Safari. All other users will see the normal web 
survey. If this field is left empty then all users will see the normal web survey. You will then need to manually 
specify the extension URL in the browser to access the extension for a survey. If you specify just .* in the field, 
then all requests will be redirected to the extension URL. 

• Information - the URL to the External Information page, which provides the Title, Created By, Version and 
Description information (go to The Information XML Page on page 110 for more information). 

• Email - the URL that is called when an active email extension is encountered from the respondent emailing 
task. 

• Scripting - Scripting Extension's URL, which is called when an extension is invoked through a script in a 
survey. 

• Scripting Name - the name of the extension as referenced in the script. 

• Panel Tab - the URL to the page that is displayed when an extension tab is clicked in the context of a Panel 
(basically the same as the Project tab, except that this is in the context of a Panel). 

• Categories - depending on the state of the checkboxes, the extension is enabled for Projects, Panels or both. 

• Contact person - the person responsible for the extension (the contact person in the event of problems with 
the extension). 

• Description - a short description and/or comments concerning the extension. 

15.2. The Information XML Page 

The Information XML Page is an XML file containing general information about the extension. This file should be 
created at the same time as the extension, and is intended to provide the title, version, created by and description 
details presented in the Extension Details page (go to The Extension Details Page on page 108 for more information) 
and the Project Extensions page (refer to the Authoring User Guide for further details). The file should be saved to the 
same server on which the extension is located. 

The XML file allows the creator of the extension to add comments and other text to the Extension Description without 
having to change the extension application itself. It also allows the creator to control what information should be 
displayed to Confirmit users about the extension. 

When you create an extension application, create a standard XML file with the content as shown in the example 
below: 

<ExtensionDetails xmlns:i="http://www.w3.org/2001/XMLSchema-instance"> 

<Title>iPhone Surveys</Title> 

<Version>0.1</Version> 

<Description>For running surveys on the iPhone with a more native look 

and feel.</Description> 

<CreatedBy>Confirmit</CreatedBy> 

</ExtensionDetails> 

The Title, Version, Description and CreatedBy texts will be particular to the extension application. 

Once the Information XML page has been created and stored on the extension server, go to the Extension Details 
page and add the URL of the XML page to the Information field (go to The Extension Details Page on page 108 for 
more information). The Extension Details page and the Project Extension page will then extract the details from the 
XML file and present them in the appropriate locations. 

15.3.  How to Check Which Companies are using an Extension 

You may need to find out which companies are using a particular extension. To do this: 

1. Go to the Admin > Accounts > Companies menu command. 

The Company List page opens. This page lists all the companies registered on the server. This page also 
allows you to search for companies that have add-ons and/or extensions. To search for companies that have 
access to a particular extension: 
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2. In the page's toolbar, open the drop-down list for the Has Extension field. 

This list contains all the extensions available. 

3. Select the appropriate extension. 

4. Click Search. 

The page will then list only those companies that have the selected extension. Click on the Company Name 
link for the company you are interested in, to open the Company > Details page for that company (go to 
Company Details Page Flex Extensions Tab on page 63 for more information). 

15.4.  The In Use Link 

If on the Admin > Accounts > Companies > Flex Extensions tab, the In Use column for an extension indicates 
"Yes", then this will be a link. Click the link to open a list of the projects owned by the current company that are using 
the extension. This provides a quick and easy method of checking which projects are using a particular extension. 

 

Figure 105  Example of a list of the current company's projects that are using a particular extension 

15.5.  How to Register a New Extension 

Note: The extension program itself will already exist, created by Confirmit engineers or your company's 
developers, and will be stored on a server to which you have access. Here you are creating a link between 
your Confirmit project and the extension by specifying the required URLs.  

1. Go to the Admin > Flex Extensions menu command. 

The Extensions Overview page opens. 

2. Click New Extension, located towards the right end of the page toolbar. 

Note: There is a limit on the number of extensions that can be registered for a site. This limit is determined 
inside Confirmit's license files. When the limit is reached, administrators will not be able to register new 
extensions in the Admin > Flex Extensions page. 

The New Extension Properties page opens. 

3. Fill in the details as appropriate (go to The Extension Details Page on page 108 for more information). 

Note: The Consumer key and Consumer secret fields are populated automatically by the system when you 
create a new extension, and these fields cannot be edited. 

4. On completion, click Save or Save and Close to save the changes. 
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16.  Other Properties and Functionality 

This chapter describes additional properties and functionality that do not fall naturally under any of the previous 
chapters. 

16.1. The Home > Company Menu 

This menu, only available to Administrators, provides a short cut to menus and logs that may be used regularly but 
which are normally accessed through a number of other sub-menus in the Admin menu. The pages and tabs 
accessed though here hold a reduced set of options, as "information" fields and settings which will not normally be 
changed by the administrator once they are initially set up, are not included. The properties and options are described 
elsewhere in this guide, so you are referred to those sections. 

The pages available through this menu are: 

• Company Settings - contains five tabs as follows: 

o Security - contains most of the settings available in the Company Details - Security tab (go to Company 
Details Page Security Tab on page 56 for more information). 

o Survey Channels - contains some of the settings available in the Company Details - Survey Channels tab 
(go to Company Details Page Survey Channels Tab on page 59 for more information). 

o Branding - contains a number of settings and fields that allow you to set your own company branding onto 
the Reportal login page. These settings are only available on this tab (go to The Company Settings > 
Branding Tab on page 112 for more information). 

o Fiscal Calendar - allows you to set up a non-standard fiscal calendar such that you can later create reports 
based on your company's accounting time-plan. 

o Other - contains most of the settings available in the Company Details - Other tab (go to Company Details 
Page Other Tab on page 66 for more information). 

• Default Survey Settings - provides access to the page available via the Admin > Default Survey Settings 
menu item (go to Admin > Default Survey Settings on page 107 for more information) 

• Default Survey Data Template Settings - allows you to set up a default template for survey data for the 
company, then when a user in the company creates a new survey data template it will be created with these 
settings as default (go to Creating a Default Template on page 117 for more information). The user can then 
edit the new template as required. Note that users can create their own default templates, which will then 
override the company default settings. 

• Survey Messages - provides access to the page available via the Admin > Languages and Messages > 
Survey Messages menu item (go to Admin > Languages and Messages > Survey Messages on page 102 for 
more information) 

• Email Activity Log - provides access to the log page available via the Admin > Activity Logs > Email 
Activity Log menu item (go to Admin > Activity Logs > Email Activity Log on page 30 for more information). 

• Transaction Log - provides access to the Transaction Logs page available via the Admin > Activity Logs > 
Transaction Log menu item . 

• Survey Dashboard Usage - provides a report with an overview of the Survey Dashboard licenses used per 
company and project. A filter is first displayed to allow you to search for particular surveys, users etc. 

16.1.1. The Company Settings > Branding Tab 

This tab contains a number of settings and fields that allow you to set your own company branding onto the Reportal 
login page. All panelists and end users for your company will then see this custom login page. 
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Figure 106  The Company Settings > Branding tab 

• Tile background - enter the URL path to an image uploaded to the file library. This image will then be used as 
the tiled background image of the underlying page area. Note that only images hosted in the file library can be 
used. 

• Background image - enter the URL path to an image uploaded to the file library. This image will then be used 
as the background image of the login details area. Note that only images hosted in the file library can be used. 

• Text color - sets the color of the text used in the login page. Either type the color code number into the field, 
or double-click on the example square to open a color picker and select the color you wish to use. 

• Button image - enter the URL path to an image uploaded to the file library. This image will then be used as 
the Submit button image on the login page. Note that only images hosted in the file library can be used. 

• Preview - enables you to check the page before you save the changes. 

• Disable Confirmit Branding - check this box to remove all references to Confirmit for Reportal users, 
specifically: 

o The Confirmit logo in the top right of the Report list page. 

o The Confirmit copyright text in the bottom right corner. 

o Mentions of Confirmit in Reportal export emails. 

• Disable cookie information - check this box to remove the standard "Cookie" text from the Reportal log-in 
page. This text informs users that Confirmit Reportal uses cookies. Whilst removing this text may be desirable 
for your branding purposes, read the Important note below first. 

Important 
Depending on the country in which your Reportal users are located, providing information about the use of 
cookies may be necessary for your company to comply with the “Privacy and Electronic Communications 
(EC Directive) Regulations 2011” - also referred to as the “Cookie Directive”. For more information, refer to 
our Extranet, http://extranet.confirmit.com/library/user-manuals.aspx, Fact Sheets, Memorandum of EU 
Cookie Directive. 

Important 
Saving automatically publishes the changes to the users' login page. 

16.1.2. The Fiscal Calendar Tab 

This tab allows you to set up a non-standard fiscal calendar such that you can later create reports based on your 
company's accounting time-plan. 

http://extranet.confirmit.com/library/user-manuals.aspx
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 Users with the Company Administrator permission can set up the calendar through the Admin > Accounts > 
Companies menu (go to Company Details Page Fiscal Calendar Tab on page 65 for more information) or via the 
Home > Company > Company Settings menu. Note that only one fiscal calendar can be set up per company. 

 

Figure 107  The Company Settings > Fiscal Calendar tab 

Note: The Fiscal Calendar functionality will be available only for reports using the Extended Tabulation 
Engine. Refer to the Reportal User Guide for further details on the Extended Tabulation Engine. 

You can enter the calendar dates manually or copy and paste from a tab-delimited .txt file created in another 
application such as Notepad. 

16.1.2.1.  How to Create a Fiscal Calendar Manually 

To enter the dates manually: 

1. Click Add. 

A default calendar is displayed.  

 

Figure 108  The default fiscal calendar that is created when you click Add 

2. Fill in the year, select the month and fill in the day for each row as required. 

3. On completion click Save to save the calendar. 

To delete a row or rows from the table, check the relevant box(es) to the left of the row(s) and click Remove. 

This calendar can now be used in your Reportal reports. Refer to the Reportal User Guide for further information. 

16.1.2.2.  How to Copy and Paste a Fiscal Calendar 

To copy the data into the fiscal calendar from a file: 



 
Confirmit Confidential Confirmit Horizons 22  Administrator Guide 

  

- 115 - 

Note: The data must be available as a tab-delimited txt file, with the columns in the order Year Month Day. 

 

Figure 109  Example of a .txt file from which the calendar dates can be copied 

1. In the tab-delimited .txt file, select and copy the required information, then return to the Fiscal Calendar tab 
and click Paste. 

Note: In a FireFox browser, you must first click Add to create a row in the table, then click into the row and 
click Paste to copy the data in. 

The data is copied into the appropriate columns of the calendar. 
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Figure 110  The data copied into the calendar 

The first cell in the Fiscal Year column is highlighted. 

2. Set the start year and select the start month. 

For the example these are 2010 and February. The Fiscal Year and Fiscal Month columns are then populated. 
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3. Click Save to save the changes. 

To delete a row or rows from the table, check the relevant box(es) to the left of the row(s) and click Remove. 

This calendar can now be used in your Reportal reports. Refer to the Reportal User Guide for further information. 

16.1.3.  Creating a Default Template 

If the users in your company use one type of template fairly regularly, you may wish to create a default template so 
they avoid having to repeat the same setup time and again. When a default template is defined, whenever the user 
creates a new template then the default settings will be initially applied. The user is then able edit the new template as 
required and save it, but will not be able to change the company default settings. 

The users can also create their own default templates (refer to the Data Processing User Guide for further details). 
The User Default setting has higher priority than the Company Default setting. So if a user has saved User Default 
settings and the company also has Company Default settings (as described in this section), the template wizard will 
apply the User settings as default. If the user deletes his/her own settings (clicks the Delete Default User Settings 
button), then the template generation wizard will use the Company Default settings if a company default template 
exists. If no company default settings have been saved, or if the Delete Default Company Settings button has been 
clicked, then the default system settings will be used. 
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To create a default company template: 

1. Go to the Home > Company > Default Survey Data Template Settings menu item. 

The Default Company Template Settings page opens. 

 

Figure 111  The Default Company Settings page - General Options tab 

2. Select the required template and project schema types (go to General Options Properties on page 119 for 
more information), then go to the Advanced Options tab. 

 

Figure 112  The Default Company Settings page - Advanced Options tab 

3. Again, make the settings as required (go to Advanced Options Properties on page 119 for more information), 
then go to the Quantum Options tab if necessary. 
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Figure 113  The Default Company Settings page - Quantum Options tab 

4. Make the settings as required. 

5. Click Save and Use as Company Settings. 

The settings you have made here will now be saved as default. If the user has not created his/her own default 
template then these settings will be applied whenever a user clicks their New Template button. 

16.1.3.1.  General Options Properties 

The properties and options available on the General Options tab are: 

• Simple - allows you to define a template specifying which variable(s) should be included or excluded and in 
which order. This template can be created based on variables from one or several projects. A simple template 
does not allow you to control the specific column positions of the variables, only the order in which they are to 
be exported. Simple templates are ideal for exports to Excel, Delimited Text File and SPSS formats, but could 
equally be used for Triple-S, SAS, Fixed Width File and Quantum exports. 

• Fixed Width - in addition to the capabilities of the Simple (Delimited) Template, the Fixed Width template 
allows column positions to be specified by assigning Start and Finishing columns or specifying the column 
Length. You will have access to more additional functions in the Template editor, which will allow you to 
change variable properties. For example: you will be able to set Bitstring or Spread to one or a group of multi 
variables, and you will be able to change the length of columns for one or a group of variables (for multi/ 
single/quantity/character only). These templates are suitable for the following exports: Triple-S, SAS, Fixed 
Width File and Quantum. If you use this template type for Quantum exports and the project contains loops, a 
Multi Trailer Card data set will be generated; otherwise a Single Card data set. If you wish to generate a Single 
Card data set for projects with loops, you must first flatten the project. 

• Quantum - in addition to the functions available in Fixed Width templates, a Quantum template will give you 
two additional columns in the editor. These represent the Start and Finish Card. These are editable. If the 
project contains loops, a Multi Trailer data set will be generated; otherwise a Multi Card data set will be 
generated. 

16.1.3.2.  Advanced Options Properties 

The properties and options available on the Advanced Options tab are: 

• Schema Language - this drop-down will list all the languages available in the project you have selected 
above. Select the language you wish to use for the template. 

• Text in Question Labels - select the type of question labels you wish to use. The options are: 

o Text Only - the label element will contain only the text of the question. 

o Title Only - the label element will contain only the title of the question. 

o Title and Text - the label element will contain the question title followed by the question text. 

o Question ID - the label element will contain the question id. 
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• Text in Answer Element Labels - allows you to specify whether the Answer element of a Grid / Open Text 
List / Numeric List Question is to be positioned in front of the Question label, after the Question label or without 
the Question label when exporting survey data or when generating a Survey Data Template which can be 
used for a survey data export. The content of the Question label depends on the Text in Question Labels 
setting, which allows you to specify whether you want the Question ID, Question text, Question title or 
Question text and Title exported. Select the text you wish to be included as the answer labels. The options are: 

o Answer label (Question label) -the question label is placed after the answer element. 

o Question label (Answer) - the question label is placed before the answer element. 

o Answer label - the answer element is placed without the question label. 

• Multi Questions with Loop Reference Answer List -This option is only relevant for surveys stored in 
optimized database format. With this setting you can specify how Multi questions using loop references are to 
be stored in the Template, and thereby the data structure in the survey data export. Refer to the Data 
Processing User Guide for further details. 

o As Standard Multis (flat) - the Multi questions will be stored on the responseid level. 

o Within Loop -the Multi questions will be stored as Single questions in the loop that is used as reference. 

• Exclude Hierarchy / Table Lookup Labels - check to exclude labels from the export. 

• Multiple Format - use this to define whether you wish to use BitString or Spread: 

o BitString - select this option to generate a Triple-S XML template for which data is recorded with one 
character per category of the corresponding variable. A character "1" is used to signify that a category has 
been selected; a character "0" signifies that a category is not selected. The category value refers to the 
relative position of the 0/1 code in the data field. Therefore a category value of 9 will always refer to the 
code in the 9th location of the data field even if some of the lower category values have not been defined. 
The data field length is defined by the highest category value. This means that with nine category values, 
nine fields in the data will be used. Using this storage type, Multi variables with long category lists will 
require a large data field length. In these cases you are recommended to use Spread instead. This can be 
selected as Multiple format when generating the template, or assigned to one particular variable or a group 
of variables in the Template Editor. 

o Spread - select this option to generate a Triple-S XML template for which data is recorded as a series of 
sub-fields, each containing one category value of the variable. The data sub-field length is the minimum 
number of characters required to represent the largest category value in the Values block. Thus variables 
with category values up to 9 have a data sub-field one character long; variables with category values up to 
99 have a data sub-field length of 2, etc. With this storage type it is possible to reduce the field size for 
multi questions, so it is recommended particularly for variables with long lists of category values. You can 
change this property for Multi variables in the Template Editor anytime. 

• Recode Multis - check this box to recode value codes for non-sequential multi variables. For example, a multi 
variable with the answer codes 1, 2, and 99 will normally use 99 positions in the export, although only three 
are actually required. Check the box to recode the variables such that they will have the value codes 1, 2 and 
3. The variable will then use only three positions. If you have many multi variables with non sequential codes, 
selecting Recode Multis will greatly reduce the size of the exported file. The option selected here will be stored 
with the template so it can be reused when adding multis from the pool or from the project. 

• Split Multis in separate variables - logical variables will be generated from each category for all Multi 
variables of format "BitString" in the template. For example, a Multi question q5 with 3 categories (1, 2, 99) will 
result in 3 logical variables (q5_1, q5_2, q5_99). These generated logical variables can be positioned in the 
generated survey template by moving them or by allocating specific columns. 

• Flatten Template - with the flattening process, a survey template that includes loops will be simplified such 
that the loops are converted to a number of 'standard' variables. This means that loop data will be expanded, 
and variables will be created to represent each iteration of each question. 

• Exclude all open questions - check this box to exclude the following question types from the generated 
template: Open Text, Open Text List, 'Other-specify' from answer lists, Multi questions with Open Text 
property selected. 

• Truncate Open Ends - for Open Ends (Open Text questions with no field width specified), it is recommended 
to truncate texts to improve performance. If a number of characters is specified, texts longer than this limit will 
automatically be truncated. 
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• Template Default - either include all the available variables in the template or create an empty template. 

16.1.3.3.  Quantum Options Properties 

The properties and options available on the Quantum Options tab are: 

• Maximum card size - specify the total number of columns on each card. The default value is 1000 ( the limit 
for Quantum). 

• Serial length - allows you to specify the number of columns required for the serial field. This field is not visible 
in the template, and will be used for reserving space for the storage of serial values. The default value is 8. 

• Card type length - allows you to specify the columns required for the card number field. The card number is 
stored on every card. The maximum allowed value is 27. The default is 2. 

• Split all variables over card - when the category list of a variable exceeds the defined card size, the 
remaining categories will be written on the next card. The variable can therefore be split over several cards. 
This is the default behavior. By un-checking this option, the following happens: the template will be generated 
and an error will be displayed in the Error column in the template editor. This will allow you to either delete the 
variable or decrease the length of the variable by assigning spread (when this variable is a multi). Alternatively 
you can generate a new template and increase the number for the Maximum card size option. 

16.2.  Confirmit Express 

This section describes the Confirmit Express admin functionality. 

16.2.1.  Express Library 

When a user is working in Confirmit Express and has a survey that he/she would like to use as the basis of future 
surveys, perhaps because it has a “standard” layout, you as Administrator can save this survey as a template. 

1. Open the survey in Express and go to the Survey Details tab. 

2. Check the Set survey as Express Library box. 

3. Click Save Survey Details. 

The survey is now saved as a template, and will appear in the New Survey Options list. Refer to the Confirmit Express 
User Guide for further information. 

Note: Surveys saved as Express Libraries will not be accessible in Reportal. 

16.2.2.  Approval and Approvers 

When an Express user is created/registered, all surveys he/she creates must by default be approved by a supervisor 
before they can go live (be made available to the respondents). The administrator can give users permission such that 
they do not need to have their projects approved, and can also give “approver” permission to supervisors. 

1. Go to the Admin > Accounts > Users menu command. 

2. In the User List, select the user you wish to edit, or create a new user. 

3. In the Permissions field, select the SYSTEM_EXPRESS_USER or SYSTEM_EXPRESS_APPROVER 
permission as appropriate. 

 

Figure 114  The SYSTEM_EXPRESS_.... permissions 
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4. Save the changes. 

Note: When an Approver is allocated a survey to approve, he/she will automatically be given full editing rights 
to that survey. 

16.2.3.  System_Company_Express_Account_Administrate Permission 

Users with this permission are allowed to manage Express users within their own company. The administrator can 
create, activate and deactivate users. Express users can have one of four statuses: 

• New – when an Express user is added to Confirmit, the user will have the status "New". Users with this status 
will not be subject to licensing, but cannot use Express. 

• Pending – the Express account administrator can activate one or more users depending on the licenses 
available. An email containing a link is sent to the activated user, and the user’s status will be upgraded to 
"Pending". 

• Active – once a user’s status is set to “Pending” by the administrator (see the point above), the user can enter 
the link in the email and create their own password. The user’s status is then set to "Active", the license will be 
counted, and the user can run Express. 

• Deactivated – the Express account administrator can at any time deactivate active users. This could for 
example be necessary prior to activating other users if there are not enough free licenses available. Note that 
only Account Administrators can set users as expired and set expiry dates; Express administrators do not 
have access to this. 

Note: If a company has 50 Express licenses, the company could have for example 100 Express users in the 
database. However only 50 of these users can be active at a given time. Note also that if an active user’s 
account expires, then that user’s license becomes available to another user. 

For further information on Confirmit Express, refer to the Express User Guide. 

16.3.  Batch Emailing Tasks 

To enable server administrators to set up emails using a fixed domain and emails where the domain has been 
overridden from different IPs (to prevent the fixed domain from being blacklisted due to spoofing), emails will be sent 
as different task types depending on which sender address is used. Server administrators may distribute these tasks 
to different servers (different IP addresses). When the fixed domain email address is overridden, the ordinary batch 
email task type will be used. 

The "Fixed Sender Domain" add-on provides a third level for respondent emailing. Each level has a designated task 
type. These task types are used to direct the different types of emailing to different servers, so that emails where the 
fixed sender domain is replaced (spoofing) are sent from different IPs than "fixed sender domain" emails. 

The three task types are as follows: 

• Batch Emailing is the task type used for such tasks. It is used if the "Fixed Sender Domain" or "Dedicated IP" 
add-ons are not set and activated, or if those are activated but the sender domain is overridden (spoofing). 

• Batch emailing - Fixed Domain is the task type used for clients with the "Fixed Sender Domain" add-on set 
and activated, as long as the fixed domain is not overridden. 

• Batch emailing - Dedicated IP address is the task type for emails sent from customers who have the 
"Dedicated IP address" add-on set and activated and the fixed domain overridden. 

The Business rules for the task types are as follows: 

• If the "fixed sender domain" or Dedicated IP add-ons are not set, the Initiating task will be always be Batch 
Emailing. Emails are sent from the batch server running the task, not the SMTP server specified as the 
Dedicated IP (if one is specified). 

• If the "fixed sender domain" add-on is set and activated, and the email sender domain matches one that is set 
either in the company settings or in the site-wide settings, then the Initiating task will be Batch Emailing - 
Fixed Domain. 

• If the "fixed sender domain" add-on is set and activated, and the email sender domain does not match one that 
is set either in the company settings or in the site-wide settings, then the Initiating task will be Batch Emailing. 
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• If the "dedicated IP" add-on is set and activated for the company, and the email sender domain matches one 
that is set in the company settings, the Initiating task will be Batch Emailing - Dedicated IP address. Emails 
are sent from the SMTP server specified as the Dedicated IP. 

• If the "dedicated IP" add-on is set and activated for the company, and the email sender domain matches one 
that is set in the site-wide settings, the Initiating task will be Batch Emailing - Fixed Domain. 

• If the "dedicated IP" add-on is set and activated for the company, and the email sender domain does not 
match one that is set either in the company settings or in the site-wide settings, the Initiating task will be Batch 
Emailing. 

16.4.  Switching Company 

Users with system_administrate and/or system_project_administrate can switch to another company and work in 
Confirmit as if you are registered in that company. This functionality may be useful if you need to edit projects created 
in a company other than your own. 

A Switch Current Company option is also available in the root node in the File Library page hierarchy. This allows 
administrators to see and upload files to other company’s folders. 

Note: Switch Company does not function for CAPI/Kiosk when sending the Activation files and certificates. 
Activation files and certificates can only be sent by “you” from the company in which you are registered. 

Note: The “current” company will be reset whenever you log in to Confirmit. The default company is that in 
which you are registered. 

Note that when accessing the CATI > Switch Company or the CAPI/Kiosk > Admin > Switch Company menu 
commands, Confirmit will display a list of all companies to which you have access that have a multimode instance 
enabled, not just those with the CATI or CAPI add-on respectively. 

16.5.  Debug Station 

Confirmit Debug Station is a downloadable application provided as part of the Confirmit license, to be used for 
debugging script code in Confirmit surveys. 

Important 
Confirmit Debug Station is a specialist feature that is intended to be used only by programmers who write 
advanced scripts as part of their surveys and who need to debug the script code. You must accept the terms 
of use as stated on the download page in Confirmit before you can download the application. 

Note: The Debug Station is not supported on users’ pcs. All support required for this feature is chargeable. 

Confirmit Debug Station must be installed on the user's PC along with a third-party .NET debugging application such 
as Visual Studio 2005. Confirmit Debug Station can then be used to run Confirmit surveys locally on the user's PC, 
attached to the .NET debugger, to debug script code in the survey (script nodes, code masks, question masks, 
conditions, validation code and piping). 

Launch the survey for debugging, synchronize it to the debug station, and then attach the .NET debugger to the 
debug station. Set breakpoints in the usercode, then when the survey starts, the debugger will pause the survey when 
it comes to a break-point in the code. 

16.5.1.  How to Install the Debug Station 

1. Open a project and go to the Designer > Quality Control > Debug Survey menu command. 

A page of information including several links opens. 

2. Click the link in the text to download the Debug Station, then follow the instructions displayed. 

Note: If you already have CAPI installed from author.testlab.firmglobal.net server, then you do not need to 
install Debug Station. Merely replace the activation files. 

16.5.2.  How to Run the Debug Station 

1. Log on to Confirmit and select a project from the project list. 
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2. Go to the Professional Designer > Quality Control > Debug Survey menu command. 

A page of information including several links opens. 

3. Click the Debug Survey button to launch the survey for debugging. 

The Task pane opens and the launch task is run. This launch will not require or update the survey database. 

4. Start Confirmit Debug Station. 

5. Start the debugging software and attach it to the Confirmit Debug Station process. 

6. In the debugging software, open the GeneratorCode.js file (containing the script code) for the survey you 
wish to debug. 

The file is located in C:\Program Files\confirmit\data\surveys\wi\pxxxxxxx. You can now set break points in 
this file. 

7. Select the project in Confirmit Debug Station and start the interview. The debugger will pause the survey when 
it comes to a breakpoint in the code. 

Note: Any interview data collected while the console is in Debug mode will not be synchronized back to the 
server. 

16.6.  Confirmit LDAP Logon 

The LDAP Logon add-on allows user’s in companies with the On-Premise license to re-use their local logon 
credentials when logging on to Confirmit. This will reduce the company’s total maintenance of user credentials for their 
applications. Access to the component is controlled in the Confirmit license file.  

The add-on functions as follows: 

1. An employee clicks the link to the company’s internal installation of Confirmit. 

2. Confirmit displays a login page asking for the user’s UserName and Password. 

3. The employee enters his/her internal “company” UserName and Password. 

4. Based on the information provided, Confirmit uses LDAP to perform a directory lookup in the company’s 
Directory. A successful lookup will log the user into Confirmit. 

5. On the first login attempt a Confirmit user will automatically be created. 

16.6.1.  Configuration 

After the functionality has been installed and enabled, it must be configured using the System Configuration interface 
available for system administrators, as displayed in the figure below. 
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Figure 115  The System Configuration interface 

The table below describes the site-wide settings and their use: 

 

Configname Type Description 

LdapLogOnEnabled Bool If enabled, LDAP directory authentication will be used when logging on to 
Confirmit. If disabled, normal Confirmit authentication will be used. 

LdapSyncPassword Bool If enabled, the Confirmit user will be given the same password as the LDAP 
directory user, and this will be kept in sync by performing a synchronization 
when the user logs on to Confirmit. If disabled, the Confirmit user will be 
given a random, strong password when created. 

LdapSyncUserSettings Bool If enabled, the user settings (first name, last name, email) will be kept in 
sync with the values found in the LDAP directory by performing a 
synchronization every time the user logs on to Confirmit. If disabled, the 
user settings will not be synchronized, but remain the same as when the 
user was created. 

LdapPath Text Path to LDAP directory. 

LdapAuthenticationType Int Authentication type. 

1 = Anonymous 
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2 = Delegation 

3 = Encryption 

4 = FastBind 

5 = None 

6 = ReadonlyServer 

7 = Sealing 

8 = Secure 

9 = SecureSocketsLayer 

10 = ServerBind 

11 = Signing 

LdapServerType Int Directory server type. 

1 = MS Active Directory 

2 = OpenLDAP 

LdapUserDomain Text Specifies the domain of the directory user. Not always required depending 
on server type. 

LdapBypassUser Text Specifies Confirmit user that can be used to bypass LDAP logon. 

LdapUserIdAttribute Text Specifies the directory attribute that is used when searching for user in 
directory. 

LdapUserFirstNameAttribute Text Specifies directory attribute that is used to provide the first name of the 
Confirmit user that is created during LDAP logon. 

LdapUserLastNameAttribute Text Specifies directory attribute that is used to provide the last name of the 
Confirmit user that is created during LDAP logon. 

LdapUserEmailAttribute Text Specifies directory attribute that is used to provide the email address of the 
Confirmit user that is created during LDAP logon. 

LdapNewUserCompany Text Specifies company name of the Confirmit user that is created during LDAP 
logon. Must be a company that has already been defined in Confirmit. 

LdapNewUserLanguage Int Specifies language code of the Confirmit user that is created during LDAP 
logon. Must be a valid language code. 

LdapNewUserLevel Int Specifies “level” of the Confirmit user that is created during LDAP logon. 
Must be a valid level code. 

0 = None 

100 = NoAccess 

105 = Express 

110 = Translator 

200 = Professional 

LdapNewUserRole Text Specifies “role” of the Confirmit user that is created during LDAP logon. 
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Must be a role that has already been defined in Confirmit, if specified. 

LdapNewUserType Int Specifies “type” of Confirmit user that is created during LDAP logon. Must 
be a valid type code. 

0 = Normal 

1 = Test 

2 = Training 

3 = Trial 

4 = ExpressConnect 

 

16.6.2.  New Confirmit User 

If the module has been activated, enabled and configured correctly, authentication will be performed using the LDAP 
directory for every user (except for the username specified in the LdapBypassUser config setting). If the user has 
never logged on before, a new Confirmit user will be created if the directory authentication is successful. The user will 
be configured according to the values entered in the config settings (company, language, level etc.). 

16.6.3.  Fallback 

If LdapSyncPassword is enabled, this new user will be given the same password as the directory user. This will 
enable to user to log on successfully in the future in the event of an LDAP failure (service unavailable etc.), or if the 
module is disabled. If LdapSyncPassword is disabled, the new user will be given a random (but strong) password, so 
it will be impossible to log on with the user if LDAP Logon isn’t operational. 

16.6.4.  User Settings 

When a new Confirmit user is created, the user will be given the same first name, last name and email address as 
found in the directory attributes specified in the config settings for the directory user. If LdapSyncUserSettings is 
enabled, these values will be kept in sync (synchronized when user logs on) and it will not be possible for the user to 
change these values in Confirmit. 

16.6.5.  Troubleshooting 

Errors related to LDAP Logon will be written to the Activity Log. It is possible to search through this log using the 
System Activities interface that is available for system administrators, as shown in the figure below. 
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Figure 116  Example of the System Activities page 

The search results will display events that occurred during the specified interval, and can be exported to a tab 
delimited text file for further investigation. 

16.7. The Single Sign-on Functionality 

Note: SSO is a company add-on and is subject to payment. If the client company does not have the add-on, 
then the SSO option will not be available in the Web Options page for a survey (refer to the Authoring User 
Guide), and the External Username field will not be available on the User Details page (go to User Details on 
page 36 for more information). 

The Single Sign-on (SSO) functionality enables clients to use their own company authentication infrastructure when 
logging on to the Authoring environment, Reportal (designers and report viewers) and limited surveys. If a respondent 
has already logged on to the company system, they will be able to access the survey without the requirement for 
additional in-logging. 

For a client to be able to use SSO, the client must provide Confirmit with a 256-bit AES key for establishment of the 
trust, and this should be done over a secure file transfer channel. This key is supplied in the Company Details page 
(go to The Company Details Page on page 53 for more information). This key will be used when decrypting the tokens 
that are presented by the users during login. The SSO company add-on must also be enabled for the client. 

The External Username field in the User Details page (go to User Details on page 36 for more information) should 
contain a combination of <company>_<username>, where company is a constant configured in SSO and username is 
the username the user has in the external system and which is also provided through SSO. 

Authentication: 

1. SSO authentication is performed by sending a clear-text company identifier (“co”) and an encrypted token 
(“key”) via HTTP(S) POST or GET to a Single Sign-on enabled login page in Confirmit. 

• The “co” parameter should contain the client company id. 
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• The “key” query parameter should have a value equal to the base 64 encoding of the encrypted value of the 
string composed of semi-colon delimited key value pairs for id, timestamp, and in some cases destination 
URL: 

o id – Confirmit user id 

o ts - UTC timestamp of the form “2007-01-10 23:39:39” 

o url - Destination URL 

Sample decrypted “key” value: id=abc123;ts=2007-01-10 23:39:39 

2. The value for the “key” parameter must be encrypted by the client using the same 256-bit AES key that was 
sent to Confirmit previously when enabling SSO. ECB blocking and PKCS5 padding must be utilized. 

3. Confirmit will attempt to decrypt the “key” parameter using the key associated with the client identified by the 
“co” parameter. If this fails, the authentication request will be rejected. Otherwise authentication will be 
successful as long as the timestamp parameter is not older than a predefined (but configurable) number of 
seconds. This leeway is used to address lack of systematic clock synchronization across client and Confirmit 
systems. Every effort should be made to reference a common time source and narrow the timestamp timeout 
period. After a successful authentication, authorization is performed using the decrypted “id” value. 

Surveys: 

Generic SSO can be used to access open surveys. If it is, when returning to an already started interview via the use of 
“__sid__” or “r” and “s”, if “co” and “key” are also supplied, the “username” field is updated with the value of “id” from 
the “key” parameter. This behavior is introduced in Confirmit Horizons v14 patch 15. 

To use Generic SSO when logging on to a limited survey, the survey must be deployed as “Single Sign On survey". 
This option is selected under Survey Settings > Web Options > Survey type, which is available if the user's 
company has the SSO add-on. Note that SSO requires respondents to be uploaded with a "username" column. 

The survey can then be accessed using two different endpoints: 

1. Normal survey link: <deployment server url>/wix/<project id>.aspx. 

2. SSO survey link: <deployment server url>/wix/sso.aspx. In this case the Destination URL parameter should 
be used, and given a value that equals the normal survey link. The user will be redirected to this URL after 
successful authentication. 

The “co” and “key” parameters must of course be included to enable the authentication. 

If SSO is used to access an interview, after the respondent is located by “__sid__”, the “username” value is matched 
against the “id” value in the “key” parameter. If the values do not match, the interview will not start. 

16.8.  Password Policy 

As part of the continuous effort to ensure that Confirmit complies with the highest standards of security, the following 
password policy applies from the introduction of Confirmit 14, for end users (CAPI interviewers, report viewers, 
Analysts and Designers) and Authoring users (Express, Professional and Translator). 

General: 

System messages are provided (with translations to the usual common languages) for these settings. The appropriate 
error messages will be displayed when users choose passwords that do not comply with the site settings.  

From Confirmit Version 14, the Authoring (Express and Professional), Reportal and Community Portal modules all 
have ‘Forgotten Password’ functionality. This allows end users to trigger an email so they receive an activation link 
that opens a page where they can reset their password. 

All passwords are hashed and not transmitted in plain text. From Confirmit 14, passwords of panelists in Community 
Panel and Basic Panel will be also be hashed. Consequently, passwords will not be available in plain text for any 
system users. Instead, users will be sent an activation link to open a page where they can choose their own 
password.  
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Panelists: 

The changes to the password policy for Panelists are optional, and users must actively enable the restrictions for 
Basic and Community Panels. Users may then define custom settings for a panel. Panelist passwords will be hashed, 
meaning that passwords will not be available in plain text. When panelists use the “Forgot password” feature, they will 
be sent an activation link which will open a page where they can reset their password. Refer to the Community Panels 
User Guide for further details. 

On-Premise users: 

The following configurable settings will be enforced for all users in companies with On-Premise contracts. If the 
Company Administrator selects to use the settings, users within the company will have to comply with these settings 
when changing their password: 

• Password history - the user’s new password must be different from his/her last X passwords. 

• Minimum age - the user will have to wait X hours after changing the password before being allowed to change 
it again. 

• Maximum number of login attempts - after X invalid login attempts the account will be locked. The user will 
not be allowed to login again until the account is reactivated by the system administrator. 

• Non-alpha-numeric characters - the password must contain a minimum of X characters that are not numbers 
(0..9) or letters (a..z, A..Z). 

• Uppercase characters - the password must contain a minimum of X uppercase letters. 

• Non-alpha characters - the password must contain a minimum of X characters that are not letters (a..z, A..Z). 

• Password length - the password must have a minimum of X characters. 

• Password expiry days - the password will expire (and the user will have to enter a new password) after the 
specified number of days. Note that this will not apply for login to the CAPI console. 

• Password strength - in addition to a combination of the above settings, a regular expression may be used to 
enforce an even stricter policy. 

• Password Link Timeout - the reset password link is valid for X minutes. 

For Authoring users, it is possible to enforce even stricter requirements through certain company settings. 

SaaS users: 

The following configurable settings are default for all Confirmit SaaS users. Company Administrators for companies 
using Confirmit’s SaaS servers can change the settings to make them more restrictive, but cannot reduce the security. 
Users within SaaS company will have to comply with these settings when changing their password: 

• Password history - the user’s new password must be different from his/her last 12 passwords. 

• Minimum age - the user must wait 24 hours after changing his/her password before being allowed to change 
it again. 

• Maximum number of login attempts - after 5 invalid login attempts the account will be locked. The user will 
then not be allowed to login again until the account is reactivated by the system administrator. 

• Non-alpha-numeric characters - there is currently no requirement for characters that are not numbers (0..9) 
or letters (a..z, A..Z). 

• Uppercase characters - the password must contain a minimum of 1 uppercase letters. 

• Non-alpha characters - the password must contain a minimum of 1 character that is not a letter (a..z, A..Z). 

• Password length - the password must have a minimum of 8 characters. 

• Password expiry days - the password will expire (and the user will have to enter a new password) after 90 
days. Note that this will not apply for log-ins to the CAPI console. 

• Password strength - in addition to a combination of the above settings, a regular expression may be used to 
enforce an even stricter policy. This is not currently used for SaaS passwords. 
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• Password Link Timeout - the reset password link is valid for 60 minutes. 

16.9.  Administrate Online Coding 

Users with the Administrate Online Coding permission for a survey will have access to the Survey Data > Coding > 
Administrate Online Coding menu item. 

Two tabs are shown to the user: 

• Assign Coders - where questions can be allocated to coders. Grid headers are searchable and sort-able. For 
multi-language projects, the ability to change language directly on the page is supported (from bottom toolbar). 

• Filters - here the user can create, modify, activate or delete filters. 

Filters based on Interview Status and/or survey variables can now be created for both legacy and optimized format 
database projects. The expression builder is accessible for filter creation, but the questions must first be launched in 
the survey. 

Only one filter can be active at any one time, and this filter is applied to the selected project for all coders. 

There is an export toolbar action to export the open text response data for the selected question, assessable from 
the Assign coders tab. The coding administrator can export response data from open questions into zipped tab-
separated text files. 

To export open text data, the user must select one item only from the list (if none or more than one are selected an 
error message is presented) and click the Export button. The Export dialog will appear, in which the user can select 
the online coding filter to be used for the export. The user may select the currently active filter, no filter or any existing 
filter from the filters list. The user will be prompted to save the resulting zipped file the Export button is clicked. The 
zipped file is available for download. 

Note: Any filters created for online coding in Confirmit pre-v16 will NOT be available once Confirmit v16 is 
installed. 

16.10.  Report History 

Note: This option is only available to users with the Admin or Pros permissions. 

To simplify investigations concerning changes to reports (for example a report is edited and the user wants to know 
when and by whom the change was made), an administrator or Pros user can open a page that contains a complete 
list of all the changes that have been made to a report since it was first created. You can open a history for the entire 
report or for an individual component in the report.   

1. To open the history for the entire report, go to the Quality Control > Report History menu item. 

The Report History page opens. 
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Figure 117  Example of the Report History page 

2. To open the history for an individual item in the report, in the Report toolbox expand the tree until you can see 
the item you wish to view the history for, then right-click on the item and select History from the drop-down 
menu. 

The Report History page opens for that item. 
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Figure 118  Example of a history list for an item in the report 

In both cases, the columns are as follows: 

• Component type - the type of report component to which the change was made, for example a page or a 
component on a page. 

• Action - the action that was performed on the component, for example it was created, deleted or updated. 

• Component Name - the name of the component in the report on which the change was made. 

• User Name - the user name of the user who made the change. 

• Timestamp - the date and time when the change was made. 

For example, the first item in the report (currently sorted by Timestamp so it is at the bottom of the page) states that 
the report Root was created at 14:16:00 on 21.01.2011. In other words, that was when the report was created. Later 
items indicate, as the timestamps are so close, that the user made use of the Report Wizard to create the various 
pages in the report. 

Up to 50 items can be displayed on a page. If the list contains more items than can fit on one page, use the Back and 
Next page arrows in the lower-right corner of the page to switch between pages and browse through the list. To sort 
the list by one of the columns, click on the column header; an arrow within the header indicates in which direction the 
list is sorted, ascending or descending. You can also search for particular items based on the action that was 
performed (all actions "in use" in the list are listed in the drop-down), or by the time the change was made. 

Click on a blue Component Type link to open a Report Event Details overview for that item. 
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Figure 119  Example of the Report Event Details overlay for an item in the report history 

The upper area of the overlay details the component to which the change has been made, while the lower area details 
what has been done. Select two items in the Report History and click Compare to open event details overlays for both 
items simultaneously, allowing you to compare the details in the items. Any differences in the two lower details areas 
are highlighted. 

 

Figure 120  Example of comparing report events 

Note that the illustration above shows very simple events; the lower details areas can contain several hundred lines of 
data depending on the complexity of the change. 
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16.11.  Execute Tasks as a Different User 

An “Execute As other user” option is available in the following user interfaces: 

•  Survey Data (Exports/Imports). 

•  Data Processing Rules (for Surveys). 

•  Respondent (Export/Upload). 

The “Execute As other user” option allows you to select a different user from the company to which the project 
belongs. If PGP is enabled (go to Public Encryption Key on page 48 for more information), it will use the public 
encryption key of this selected user for the above export and import tasks. The option is available for users who have 
the “SYSTEM_ACCOUNT_READ” and “SYSTEM_PROJECT_DATA_EXPORT_ADMIN” permissions enabled in 
addition to the permissions which are required for running the tasks above. 

In Survey Data > Exports and Data Processing Rules, an additional check box “Encrypt File” is available, and will be 
set depending on the company settings of the selected user. 

• If the “Always use encrypted file transfer” company setting is assigned to the selected user, the “Encrypt File” 
checkbox will be checked and cannot be changed by the user. 

• If the “Always use FTP for file transfer” company setting is assigned to the selected user, the “File transfer” 
option changes to FTP and cannot be changed by the user. 

In addition, the recipient email address will change to the email address of the selected user. This email 
address can be overwritten if required. 

  

  



 
Confirmit Horizons 22  Administrator Guide Confirmit Confidential 

  

- 136 - 

17. APPENDIX A: USER ROLES AND PERMISSIONS 

The Horizons platform includes a wide variety of features and functionalities for survey authoring, data management, 
and reporting. Optional modules and features can also be enabled to enhance the core platform, providing additional 
functionalities. Optional modules and features include but are not limited to: Action Management, Active Dashboards, 
CAPI, CATI, Discovery Analytics, Genius Text Analytics, Hierarchy Management, Instant Analytics, Model Builder, 
Panel Management, CRM Connect and Translation. 

To ensure maximum data security and guarantee your staff has access to the functionality they need, Confirmit 
Horizons employs an array of user roles and permissions. Note that your users will only have access to modules and 
features that are enabled in accordance with your Confirmit contract, regardless of all other factors. 

Within the terms of your contract, your users’ access to Horizons, with all its licensed and optional modules, its system 
features and its data, is governed by each user’s assigned User Role and the permissions allocated to each user. 
User Roles refer to a set or group of privileges that can be granted to one or multiple users who require common 
system accesses and permissions. A User Role must be assigned to every person who will be accessing Confirmit 
Horizons for any reason. Unless otherwise indicated, the system administrator is able to further tailor specific 
permissions within the constraints of the assigned User Role for each system user. 

This appendix provides a high-level overview and indicates the maximum permissions that each User Role can have. 
Note that the individual users’ actual permissions may vary based on your company’s contract and/or the permissions 
granted by your designated system administrator. 

17.1.  Designated User Roles 

Designated Users are system users who have a requirement to access system functionality to facilitate their day-to-
day work. Designated Users are created by Confirmit according to the number of licensed users for each role 
specified in the contract. 

• Professional User is the most common Designated User Role. The user can access and have permissions 
granted to the following modules and functionalities: Professional Survey Authoring, Survey Designer, 
Reportal, Instant Analytics, SmartHub, Hierarchy Management, Active Dashboards, Action Management, 
Business User Management (see below), Panel, CAPI, CATI, Database Designer, Translation Module, CRM 
Connect and File Library. A Professional User may also be granted elevated permissions to serve as the 
System/Company Administrator. This User Role allows for the maximum number of permissions and flexibility 
available in Confirmit Horizons. It does not however have default permission to access Model Builder, Flex 
Extension development, or web services API. 

• Standard User is intended for users who do not require the full set of features and functionalities available to 
Professional Users. This User Role can access the following modules with limited permissions: Professional 
Survey Authoring, Survey Designer, Discovery Analytics, and Translation Module. An example of how 
permissions are limited is that this user is only able to create and deploy a single-language survey. This user 
can also manually add respondents and send reminders, export survey data and translate assigned surveys, 
and can also create, view, and manage reports in Discovery Analytics. 

• Analyst User is intended for users who need access to review or analyze system data and perform functions 
in Active Dashboards, Action Management and Discovery Analytics. This User Role can access the following 
modules: SmartHub, Business User Management (see below), Active Dashboards, Discovery Analytics and 
Action Management. In terms of permissions, this user is limited to only view permissions in SmartHub and the 
Contact Database. This user has full permissions to create, manage, and view Active Dashboards, Discovery 
Analytics, and Action Management. Analyst Users can also create Business User lists and are able to modify 
only the Business User lists they have created. 

• CATI Supervisor is the Designated User Role for individuals responsible for directing day-to-day CATI 
operations. This user is able to create and manage interviewer accounts, manage sample and quotas, review 
CATI reports and dashboards, monitor interviews, edit verbatims, and play back recordings. 

• CATI Interviewer is the Designated User Role for individuals responsible for conducting CATI interviews. This 
user is only able to view the surveys and respondents that are assigned to them. 

• CAPI Supervisor is the Designated User Role for individuals responsible for directing the day-to-day CAPI 
operations. This user is able to create and manage field force interviewer accounts, and review CAPI reports 
and dashboards. 
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• CAPI Interviewer is the Designated User Role for individuals responsible for conducting CAPI interviews. This 
user is only able to view the surveys, respondents and quotas that are assigned to them. 

• Translator is a User Role available for individuals responsible for translating surveys. Translators access 
Confirmit Horizons through a dedicated URL for security, and their permissions are strictly limited to viewing 
and translating assigned surveys. Any changes made by the Translators will be visible in the Confirmit 
Authoring interface. It is important to note that the permissions for this user role cannot be changed. 

• System/Company Administrator is the person designated to administrate the software-related aspects of 
Confirmit (users, permissions, etc). The Administrator has access to all the company’s projects, reports, forms 
and end-user lists, and can give other users read, write, delete, and administration permissions to these 
objects. 

17.2.  End User Access 

End Users are user roles that are allocated by Designated Users to people who access Confirmit Horizons for 
business (end) user functions such as accessing reports, dashboards and Action Management. Generally, these 
users are department leaders and executives who need access to the insights contained in reports and dashboards, 
but who are not directly involved in the detailed set up and day-to-day use of the software. With this user type, you 
contract your desired number of user licenses and then self-manage the assignment of access rights for those users. 

• Report Viewer Access (RVA) is the most common End User type. This user type can access reports and 
dashboards that have been assigned to them in Reportal and Active Dashboards. An RVA user can also 
access all Action Management functions and edit hierarchies in Hierarchy Management if permissions are 
granted. 

• Report Analyst Access (RAA) allows End Users to analyze existing report data and create tables. This is an 
intermediate user who has the ability to "play" with the data, analyze it on the fly, and create simple tables in 
Reportal. An RAA user can also access all Action Management functions and edit hierarchies in Hierarchy 
Management if permissions are granted. 

• Survey Dashboard & Instant Analytics Access allows for access to Instant Analytics and Survey 
Dashboard. 

17.3. Other User Types 

In addition to the most common user types listed above, Confirmit also has Designated User roles for staff members 
responsible for managing the more technical aspects of your Confirmit Horizons platform, including secure FTP file 
transfers, APIs, and Flex Extension development. Contact your Confirmit sales representative or account manager for 
additional details. 

17.4. User Roles and Permissions At-a-Glance 

 

Designated User Roles 

Function Professional Standard Analyst Translator CATI 
Supervisor 

CATI 
Interviewer 

CAPI 
Supervisor 

CAPI 
Interviewer 

Professional 
Authoring & Survey 
Designer 

              

SmartHub               

Hierarchy 
Management  

               

Admin & End User 
Management 

              

Reporting & 
Analysis 

           

Action Management 
- Add-On  
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Designated User Roles 

Genius Text 
Analytics - Add-On 

               

CATI - Add-On               

CAPI - Add-On               

Panel - Add-On                

Translator module - 
Add-On  

            

 

 

End User Roles 

Function RVA License RAA License SD & IA 
License 

Professional 
Authoring & Survey 
Designer 

      

SmartHub       

Integrations       

Hierarchy 
Management  

    

Business User 
Management 

      

Reporting & 
Analysis 

    

Instant Analytics      

Action Management 
- Add-On  

   

Genius Text 
Analytics - Add-On 

      

CATI - Add-On        

CAPI - Add-On        

Panel - Add-On       

Translator module - 
Add-On  

      

 

 

  Full permissions 

  Limited permissions 
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